Samsung forum

Question

Can't make Samsung Link work -- Blank browser page

by DigitalPiglet / January 25, 2014 11:04 PM PST

Hi there,

I've got a Samsung UE40D6530WKXXU TV.

I've just downloaded and installed Samsung Link on my XP PC. The icon shows up in the systray, but it's grey rather than green. When I click on it and go to Log In it opens a browser page (I'm using Chrome) that has the url http://link.samsung.com/, but the page is blank.

When I click on the systray icon and choose Nearby Device Connection Settings it does see my TV and router (I'm doing this wirelessly) but I can't find a way to set the folder to share. When I click on the Add link it opens a box that shows my HDs, but nothing happens when I click on any of them or when I click on the + next to Add a New Folder. Add a New Folder is greyed out.

I've uninstalled and reinstalled, and checked that the software on the TV is up to date.

Can't work out what's going wrong. You may have gathered that I'm not an expert on any of this.

Any help very gratefully received. I just want to stream videos from my PC to the TV.

Discussion is locked
You are posting a reply to: Can't make Samsung Link work -- Blank browser page
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't make Samsung Link work -- Blank browser page
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Link fails here on firefox.
by R. Proffitt Forum moderator / March 1, 2014 2:34 AM PST

All Answers

Collapse -
Answer
Try another browser
by xhiiZor / March 1, 2014 2:14 AM PST

I had the same problem with the blank page. The page doesn't work on chrome, who knows why. Try IE and it should work.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?