Question

Can't install Ubuntu, black screen

I'm running Windows 7 Ultimate 64 bit edition on a 3TB GPT hard drive with the standard three partitions that Windows creates. I have an ASRock Z97 Extreme6 motherboard with an Intel i7 4790k processor and 8GB of RAM.

I've been trying to install 64 bit Ubuntu alongside Windows for several days now and keep running into the same error. I create a bootable USB for the installation ISO and boot from it on startup. I am given the option to boot through BIOS or UEFI (two different options for the USB when I pull up the boot menu), but the outcome is not different for each, just the interface. When faced with the menu to choose whether to try or install Ubuntu, selecting either option brings me to a black screen. I've let the screen sit like this for a couple hours and nothing changes. On a USB with an activity LED on it, the LED does not flash during this time.

I have tried deleting the installation ISO and redownloading it, to make sure the file downloaded correctly. I have tried rewriting it to the USB, trying a different USB (including one that I just recently successfully used to install Windows), and then trying a different USB writer on each USB drive (tried Rufus, Pen Drive Linux's USB installer, and ImageUSB). None of this has changed anything. I have no idea what the problem could be, as on the same hardware I have previously been able to start the installation of Ubuntu (I quit halfway through). The only difference between then and now is that I've installed a better CPU cooler and an additional case fan.

Discussion is locked

Follow
Reply to: Can't install Ubuntu, black screen
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't install Ubuntu, black screen
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
That black screen

Is sometimes a hardware support issue. I don't see much about this PC but when this happens to me I usually go with another distro. Nod to Linux Mint.
Bob

- Collapse -
Answer
Will it boot up

as a live OS from the thumb drive? If it runs as a live OS it should install.

Digger

- Collapse -
Just an FYI.
- Collapse -
True

Even though these distros say they will boot through UEFI , I still disable CSM and have no problems

Digger

- Collapse -
Answer
I've had this happen when using other than the VGA

connector for the installation. Once installed, HDMI or other supported video ports work. Make sure you start with VGA if you didn't do that initially.

- Collapse -
Connector

Well that's awfully inconvenient. I don't have a VGA out on my motherboard. There's DVI-I, Display Port, and HDMI, and I tried both DVI and HDMI (my monitor doesn't support Display Port). Besides, at this point I've gotten the black screen problem to go away, but now it sticks on an Ubuntu loading screen.

- Collapse -
Answer
I am not sure if this will help or...
- Collapse -
Answer
try F6 select nomodeset
- Collapse -
Answer
Try too.F

F4 will give you graphic specific options to try

- Collapse -
Answer
sounds like a gfxpayload problem

First, make sure Secure Boot is turned off.

When you are presented with the Ubuntu menu, press the TAB or "e" key or whatever allows you to change some of the boot options. Try first the "nomodeset" mentioned.

Linux Mint is derived from Ubuntu. If you have NVIDIA....

http://linuxmint.com/rel_qiana_cinnamon.php

Solving freezes with some NVIDIA GeForce GPUs
If you are unable to boot Linux Mint with an NVIDIA card, or if you are experiencing constant freezes and system lock ups, please append "nomodeset" to your boot arguments. At the boot menu of the live DVD/USB, press Tab to edit the boot arguments and add "nomodeset" at the end of the line.
If you're still having issues, you can also remove "quiet splash --" from that same line.
Alternatively you can use the "nouveau.noaccel=1" boot argument.
Once the system is installed, use the Driver Manager to install the nvidia-304 driver.


There used to be a generic vga=*** setting, but that's been "deprecated" (a word meaning too bad for all of us) and instead the gfxpayload phrase is now introduced. I have to look it up every time.

https://www.gnu.org/software/grub/manual/html_node/gfxpayload.html

try this by adding on the boot line where "quiet splash" is, just before it

set gfxmode=1024x768

next try

set gfxpayload=1024x768

one of those should work. You can use a different resolution your monitor supports. You may also need to add it BEFORE the linux boot line, but I think on the line will work.

CNET Forums

Forum Info