PC Hardware forum

General discussion

Can't get my second HD to use Ultra DMA Mode

by steelfixer / October 30, 2004 10:53 AM PDT

I have a Dell Dimension 2400, running XP, with 512KB of memory and an 80 gig hard drive.

I added a second Hard Drive (160 gig) as the Slave on the Primary IDE Channel.

It works fine in every respect except speed -- which I discovered when trying to record and play back .avi files, which are badly fractured in both sound and vision.

Thanks to help elsewhere on these forums, I think I've identified the problem:

Although the Device is set to "Ultra DMA where possible" it sticks to PIO Mode. The other three devices (main hard drive and two cd-rom drives) are all operating in Ultra DMA mode with no problems.

I don't think there's anything more I can do through Device Manager, and it appears that BIOS is the next step. I'm way out of my depth there without any advice.....so I'd welcome some. Thanks.

FYI, here's the earlier post http://reviews.cnet.com/5208-6122-0.html?forumID=44&threadID=42259&messageID=495454

Discussion is locked
You are posting a reply to: Can't get my second HD to use Ultra DMA Mode
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't get my second HD to use Ultra DMA Mode
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by R. Proffitt Forum moderator / October 30, 2004 10:59 AM PDT

There are many items you didn't tell in your post. Such as what jumper setting you used, the cable type, why you didn't have Dell walk you through the BIOS update, what XP Service Pack is installed and most important if you followed Microsoft's instructions to set it to PIO, Ok your way out and then go set it back to DMA if available.

Why? Because it's broken. Read http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx and read CAREFULLY how Microsoft tells you to flip it to PIO then back. I repeat... it's busted.

Bob

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by steelfixer / October 30, 2004 12:05 PM PDT

Bob (M)

I read your response CAREFULLY several times, and decided I don't need help badly enough to get it from you.

I think you need to go and lie down.

Why? Because if anything's busted, it's one of your blood vessels.

Collapse -
Best of luck.
by R. Proffitt Forum moderator / October 30, 2004 12:10 PM PDT

I can only point it out, many will just LOOK at the settings and miss the clue that Microsoft wrote to set it to PIO, OK it and then go back to change it again.

I'm more than willing to help, but I've found it necessary to PRESSURE people to read the note because when I didn't, then just looked at the setting.

Bob

Collapse -
Re: Best of luck.
by steelfixer / October 30, 2004 12:18 PM PDT
In reply to: Best of luck.

I appreciate your attempt to help, and I'm sure that technique works well with some people. It doesn't with me, and neither, regrettably, did Microsoft's Change-OK-Change directions.

Collapse -
Now tell the other items.
by R. Proffitt Forum moderator / October 31, 2004 12:02 AM PDT
In reply to: Re: Best of luck.

It's still important to know what jumper setting and other items I asked about. Here's why. While it may "work" for some drives to be set to Slave on an 80 conductor IDE cable, some systems will balk and do as you note until its set to Cable Select and repeat the Microsoft procedure.

The service pack of XP is important since over 127GB support is only in SP1 and later. The machine's motherboard drivers are necessary since Microsoft doesn't update such for us.

I really can't read minds so I can't tell what works for you but I know the issue. You can deal with it or just ignore me.

Bob

Collapse -
Re: Now tell the other items.
by steelfixer / October 31, 2004 9:52 AM PST

I'm sorry -- I took your "Best of luck" heading as a sign-off.

-- I have Service Pack 2.

-- I'm using the second plug on the IDE cable already connected to the factory installed hard drive.

-- Jumper setting is per the drive manufacturer's instruction manual for a slave.

-- I checked for an updated driver for the disk, but there's no newer one available.

Let me know if you need more. Thanks for your help.

Collapse -
Slave.
by R. Proffitt Forum moderator / October 31, 2004 11:07 AM PST

"Jumper setting is per the drive manufacturer's instruction manual for a slave."

I'd use cable select. These 80 conductor cables set that for us and right or wrong some machines get odd when we use the slave or master on 80 conductor cables.

It's a safe thing to change, then I'd triple check that my motherboard drivers are current (NO Microsoft tools for this one I fear) and then I'd do the DMA to PIO and back to DMA again...

Here's hoping.

Bob

Collapse -
Re: Slave.
by steelfixer / October 31, 2004 11:34 AM PST
In reply to: Slave.

Thanks --

I'm not familiar with Cable Select, nor how to check the motherboard drivers (via Device Manager, I assume, but what might the motherboard be called?).

Collapse -
same problem
by frankzxcv / October 31, 2004 3:23 AM PST
In reply to: Re: Best of luck.

I had the very same problem a few months ago with a seagate drive. their support told me over and over again that this was a "system problem." I tried everything, finally returned the drive for an exchange, and the new one worked perfectly out of the box.

the moral is, it's quite possible that the hardware is just plain busted. might not be, but, . . . --fj

Collapse -
Re: same problem
by steelfixer / October 31, 2004 10:11 AM PST
In reply to: same problem

Hmmm.......entirely possible, especially since mine is a Seagate, too....

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by Bob__B / October 30, 2004 10:49 PM PDT

When I boot this machine (not a DELL) in one of the POST screens that flash by I get a display of the BIOS settings for the IDE ports.

If your machine does the same that might give you a way to determine if the bios has this port set to PIO.

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by steelfixer / October 31, 2004 9:53 AM PST

Thanks for the suggestion -- I'll wait to see if there's a non-BIOS fix suggested, but it may be where I end up.

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by swisse / October 31, 2004 2:26 AM PST

Steelfixer,
If you have VIA chipsets in your motherboard then try downloading the latest VIA Hyperion 4-in-1 drivers for example from this site http://www.fileflash.com/?action=info&program=213. Maybe there's a later version to it, but you could do a search. Then install the drivers and click Enable DMA in one of the questions, then reboot your PC.

Swisse

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by steelfixer / October 31, 2004 9:54 AM PST

Thanks -- how can I check if I have VIA drivers?

Collapse -
Re: Can't get my second HD to use Ultra DMA Mode
by swisse / October 31, 2004 8:02 PM PST

Click Start, right-click My Computer, then click Properties. Once in System Properties click Hardware, then click Device Manager. Once in Device Manager double-click the entry System Devices. If VIA drivers are installed in your system it should be listed there. Then you could download the latest Hyperion drivers, otherwise if VIA drivers are not installed then other chipsets are installed.

Swisse

Collapse -
VIA Drivers
by steelfixer / November 1, 2004 10:25 AM PST

Thanks for the tip, but no such luck -- no VIA drivers listed there.

Collapse -
FIXED
by steelfixer / November 1, 2004 11:51 AM PST
In reply to: VIA Drivers

...thanks to a friend. In bcase anyone else has the same problem:

It was pretty straightforward, as it turned out -- perhaps something I missed in the Seagate instruction manual.

- Went into the BIOS
- Went into Drive Configuration
- Selected Primary Slave
- Reset from OFF to AUTO
- Rebooted
- Drive was now set to Ultra DMA

Thanks to everyone who offered help.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.