Networking & Wireless forum

General discussion

Can't find printer on network

by GusGusGus / September 13, 2008 11:29 AM PDT

I've been had my computer plugged directly into the back of my WRT54G router until recently with an assigned TCP/IP address and it's worked fine. Recently we've moved and have ethernet throughout the house which was all tested. The room with the printer is upstairs, and there's a comms cabinet downstairs, where the router, a switch and modem and server now live. So far so good.

I've got a number of devices plugged in to access the server and they've worked okay, but today when I hooked up the printer (an HP Laserjet 4050N with a JetDirect card) I wasn't able to get it to work.
I then turned the wireless card off on my laptop and disconnected the ethernet cable from the back of the printer and plugged it into my laptop to see what would happen. It sees that its connected to an unknown network by LAN cable, but doesn't have access to the internet (it accesses the internet fine when its using wifi).

I tried creating a new Printer connection with a new IP address and entered this on both on the Laserjet and the new profile but still no luck and I get a print error when I try to print a test page.

Down on the patch bay, the appropriate connector is wired to the router (and as I get confirmation when I plug in the laptop that it's connected to a network, albeit not the internet, it seems that the physical wiring isn't a problem.

Settings on the router are:
Operating Mode: Gateway
Interface: LAN and Wireless
Login Type: PPPoE
DHCP Server: Enable

Can anyone suggest a solution? I guess there are two things that I'd like to fix (and they may be related issues for which a single "fix" will correct both: 1) the fact that the printer won't work and 2) that when I connect via ethernet, I'm not autmatically getting onto the internet. This is driving me round the twist! Advice would be much appreciated.



Discussion is locked
You are posting a reply to: Can't find printer on network
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't find printer on network
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check RJ45 connections for flakiness
by samkh / September 13, 2008 11:51 PM PDT

Also try connecting to the same ethernet port on router using a short Cat 5 to see whether the port works.

Collapse -
I'm B-A-A-A-CK!
by GusGusGus / September 23, 2008 12:07 AM PDT

So sorry, but my post coincided with moving and, as a result, other things that needed sorting out. But I'm now back to struggling with my uncooperative printer.

I've tried all the connections, but still nada. And then, after fiddling around with the JetDirect configs, I've suddenly started getting a "LAN error-loss of carrier" message. (At least before that I was getting a message saying the card was ready). I'm using a 600N JetDirect on a 4050N HP.

This is driving me crazy! Any suggestions would be hugely appreciated!


Collapse -
by samkh / September 23, 2008 12:32 AM PDT
In reply to: I'm B-A-A-A-CK!

resetting JetDirect back to factory default (and re-seating) doesn't result in a successful connection, it's time to replace the card. Or a cheaper alternative is get a cheapo external parallel print server. First test the printer using parallel directly to PC to be sure the printer still works.

Collapse -
How do I reset the JD?
by GusGusGus / September 23, 2008 9:19 AM PDT
In reply to: If

I've just done a cold reset and reinstalled the jd, but still getting the "Lan error - loss of carrier" when I print the Jetdirect config page. In case it's useful, other (selected) info appearing...

Port select: none
Port config: disconnected
aut negotiation: on
I/O card not ready: 0E

SNMP Set cmty name: none
tcp/ipn status: initializing

Host name: not specified
config by: not configured
IP address:
subnet mask: no specified
def. gateway:
syslog server: not specified
idle timeout (seconds): 90
bootp/dhcp server:
config file: not specified

ipx/spx status: initializing

Mode: queue server

DLC/LCC status: ready

IPX/SPX retrans: 0
Network frame type: RCVD

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.