Windows Legacy OS forum

General discussion

can't drag-and-drop files anymore

by fauxarbres / January 8, 2006 2:53 AM PST

Using Windows XP Home, Sony Vaio Computer.

I woke up one day (hadn't installed anything in the meantime) and was unable to drag any icons or folders. My mouse won't "pick up" any of them, on my desktop or within a folder. I can drag program windows around, so I don't think it's an issue with my mouse. I thought maybe a recent Windows Update had messed it up, so I uninstalled the most recent one, but it didn't do anything.

I hadn't changed a *thing* on my computer before this started happening, so I don't know how it could be a settings problem, but maybe it is.

Any help would be much appreciated!

Discussion is locked
You are posting a reply to: can't drag-and-drop files anymore
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: can't drag-and-drop files anymore
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
There is some spyware that does that. Free tools....
by R. Proffitt Forum moderator / January 8, 2006 6:09 AM PST

Look up HOUSECALL and EWIDO on and eject what they find.


Collapse -
Lost drag and drop ability
by Kono Kusotare / January 8, 2006 6:20 AM PST

Do as Mr. Proffitt suggested. If the problem persists go to Start/Run/ type regedit... Then Click on Registry/Export Registry. Save the file somewhere you will definitely remember.

Then Reboot.

Go to Start/Programs/System Tools/System Restore. Create a New Restore Point.

After all of that is done. Download this file. It is a fix for the Lost Drag N Drop in XP. (

After you install this, Reboot.

If for some reason your computer is unable to bootup after you do this, restart and hit the F8 Key. Choose Restore to last known good configuration.

Collapse -
by fauxarbres / January 8, 2006 11:39 AM PST

It's fixed, thanks for the help Happy

Collapse -
kono kusotare
by jasontflaco / February 3, 2006 12:19 PM PST

ay man ive been lookin for the answer for like 1-2 years

but to tell u the truth ur solution didnt work for me

now it sounds like you really know youre stuff

and when it comes to registry and system32 stuff part of windows im just a rookie

if u can please help me out because not being able to drag and drop files, folders, or even just arranging desktop icons is so annoying!

my email is

please contact me soon

Collapse -
Re: Drag and Drop Problem
by Tufenuf / February 3, 2006 8:39 PM PST
In reply to: kono kusotare

jasontflaco, You could go to the link below and scroll down to Line 233 (right column) and click on "Enable Drag and Drop" to download a reg file fix. Save the REG File to your hard disk. Double click it and answer yes to the import prompt. It may correct your problem.


Collapse -
by jasontflaco / February 4, 2006 2:03 AM PST

ok so i did what kono kotsuro said....

and i did what tufenuf said


i ran 2 different spyware progs
ad aware and ewido online

i checked folder options and right clicked desktop to uncheck options

god why is this happening!!!!!!!!!

running windows xp

this is such ******** im startin to hate windows

Collapse -
Try This
by Tufenuf / February 4, 2006 3:26 AM PST
In reply to: nooooooooooooooo!

jasontflaco, Open Internet Explorer>Tools>Internet Options>Security tab. Hilite the "Internet" Icon, click the Custom Level button and make sure that "Drag and drop or copy and paste files" is enabled, click Apply/OK.


Collapse -
still nothin
by jasontflaco / February 4, 2006 4:11 AM PST
In reply to: Try This


my computer is gettin on my nerves

Collapse -
Re: still nothin
by Tufenuf / February 4, 2006 4:20 AM PST
In reply to: still nothin

jasontflaco, Try the following:
Start>Run and type in: regsvr32 /i shell32
then click OK then restart your computer.

Note that there is a space betweem regsvr32 and /
Also a space between the i and shell32


Collapse -
by jasontflaco / February 4, 2006 4:53 AM PST
In reply to: Re: still nothin

nope nothin

i can almost swear its from a windows update

Collapse -
I have the EXACT same problem...
by brianreeves / March 11, 2009 8:53 AM PDT
In reply to: ...

Files will not drag/drop, cannot copy paste, start menu disappears except when I disabled autohide, and my restore does not work.

If you found an answer, please repost it.

If you have any ideas, please let me know!!

We can't be the only two that have ever experienced this...

...and indeed it DID happen RIGHT after a major Windows Auto Update that forced me to restart my computer...


Brian Reeves

Collapse -
That can hardly be the same update ...
by Kees Bakker / March 11, 2009 8:57 AM PDT

as it was three years ago.

Anyway, you can undo any Windows update - even when System Restore doesn't work - by finding the correct $NTUninstall subfolder in your Windows folder, going into it and run the uninstaller (spuninst.exe).

Worth a try.


Collapse -
Understanding "Restore"
by Cursorcowboy / March 11, 2009 10:11 PM PDT
Collapse -
Mee Too!!!
by hungluff / March 30, 2009 3:33 AM PDT

I also have exactly the same problem!!!

Please if anyone knows a solution for this. Tell!!!

I also already tried the known reg fixes and the regsvr of the shell and ole dlls. Didn't help.

I also had the problem after a windows update experience you don't want to have yourself. I had to delete the whole SoftwareDistribution folder, to get the update work again. So I am not able to undo the SW updates anymore.

There must be a solution!
Again the problem: I can drag and move the icons with the mouse. But when I drop them, nothing happens.

BTW: Since my update experience I have another problem: Namely that it does the updates now always only at the reboot. Although I set it so, that it should ask for download and install. Now after prompting for downloading and after it downloaded new updates, the yellow icon in the task bar disappears. Usually it showed up and after a double click on it, one could select which updates to install, and then it installed these immediately. Now he doesn't ask anymore, and just installs them on a shutdown. That's very unpractical...

Collapse -
It worxxx
by hungluff / March 30, 2009 3:48 AM PDT


It worx again!

Although I already tried various reg fixes. E.g. the dragndropx.reg mentioned here it didn't work before. Now I tried another two from the link above:

and voil

Collapse -
Fixed My Problem...
by brianreeves / March 30, 2009 5:27 AM PDT

If nothing else, temporarily enough for me to back up my files...

I inserted the WinXP install disk, and click through as if I was going to do a fresh install. When the disk found that I already had an operating system installed, it asked if I wanted to reinstall it.

I did, and it fixed the problem. Probably overkill, but I didn't get the newest posts before I did it and I was desperate. Happy

Be sure if you do that, to not use the 'System Restore' option on the may not work.

I wish I had the other options noted later in the posting...probably a lot easier, but this way DEFINITELY fixes the problem.

Collapse -
lost my documents files
by joedalho / June 20, 2009 2:35 AM PDT
In reply to: kono kusotare



thank you

Collapse -
In your case.
by R. Proffitt Forum moderator / June 20, 2009 2:37 AM PDT
Collapse -
Thank You!
by AzDayton / June 19, 2009 2:54 AM PDT

I've been trying to get Drag-and-Drop fixed in the Start Menu on this POS computer for ... well it seems like forever. All the searches I did kept saying the same thing (turn on Drag-and-Drop in the Preferences).

Your .REG file actually FIXED the ******! Thank you very much!

- Dayton - Fri. 06/19/2009 @ 09:54:39

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.