General discussion

Can't delete certain Comodo Internet Security registry files

I only installed the CIS firewall and not the other features on my pc. After I uninstalled it in "Programs and Features", I can't delete registry entries labeled DeviceDesc. When I go to Permission to get Full Control for Everyone, I get an error message, "Unable to save permission changes on 0000. Access is denied". I attempted to delete the entries in Safe Mode too, but I received the same error message.

Discussion is locked

Follow
Reply to: Can't delete certain Comodo Internet Security registry files
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't delete certain Comodo Internet Security registry files
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Harv, if that is a driver of Comodo firewall..

you can try to uninstall using Device Manager.

Go to Hardware and Sound Control Panel > Device Manager.
Next, click View menu then select "Show hidden devices"
Expand "Non-plug and play devices"
Locate the comodo driver you want to remove.
Right-click to uninstall.

- Collapse -
"Non-plug and play devices" not shown in "hidden devices"

Donna, I went to Control Panel>Device Manager, etc. and there's no "Non-plug and play devices" listed.

One registry entry I couldn't delete looks like this:

LEFT side of screen: LEGACY_CMDGUARD
0000

RIGHT side of screen: DeviceDesc REG_SZ Comodo Internet Security Sandbox Driver

- Collapse -
Harv, did you select...

"Show hidden devices"? In Device Manager, click "View" then select "show hidden devices". The non-plug and play devices should appear. If it won't display the hidden devices, try another method:

Make sure Comodo service is gone. Type services.msc in run box, locate any Comodo services. Stop it, if exist. Close the services console.
Try now to delete the registry keys for Comodo. Find:
LEGACY_CMDGUARD
LEGACY_CMDAGENT
LEGACY_CMDHLP

Delete the keys. But ensure to create a backup of your registry before deleting anything.

But I suggest to first try to show hidden devices in Device Manager.

- Collapse -
Registar Registry Manager deleted all LEGACY entries

When searching internet, I found that someone was having a similar problem with LEGACY registry entries. An application named Registar Registry Manager (http://www.resplendence.com/registrar) was suggested to remove them and it worked like a charm.

Thanks for your help, Donna.

- Collapse -
(NT) Cool. Good to hear this, Harv.

CNET Forums

Forum Info