Can't connect to Internet after installing Comodo Firewall?

I downloaded and installed COMODO Firewall because I have read that it is the best Free firewall available. Once I install it, It will not allow me to connect to the Internet. I have shut down all other Security programs while installation is in progress, but still no luck. A couple of times it loaded my 'Homepage' but when I attempted to go further it started popping up 'Error messages', asking me if my Internet connection was working,(which it was).
Is there some set of rules for configuring it properly"

Sony PCV-RX650
1GB Ram
Radeon 9250/9200 Series GPU w/256MB Ram
80GB Primary HD w/66.9 Free Space
250GB Secondary HD
AVAST Free anti-virus
Spyware Terminator Free

Any help with getting me online with Comodo would be greatly appreciated. Have uninstalled it and just using Windows Firewall at this time
Thank you,

Discussion is locked
Reply to: Can't connect to Internet after installing Comodo Firewall?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't connect to Internet after installing Comodo Firewall?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Clarification Request
Is this machine behind a router?

If so, what exactly is the firewall adding?

Your answer is going to tell me a lot. Some folk layer on the protections. With that much ram I'd be looking for lighter protection and removing it when my firewall is already in place.

- Collapse -
Check MS security

Review the MS status of security, which product is actually being used for a firewall. WHY? because, Avast and the OS could be providing it, one or the other and now you have Comodo. Also, if I suspect, Comodo may have loaded Dragon s/w which really isn't needed, you can un-install it and still have Comodo firewll acyive. Check all that come back with results. And yes, I have Comodo installed.

Also, review the Comodo status itself from it setting window. Also, recall if you didn't decline web access because you replied with a "no" for a browser or anything along those lines. BTW, Comodo has its own user forum visit the support website.

tada -----Willy Happy

- Collapse -
Appreciate responses from both members

Thank you, please consider this post closed.

- Collapse -
Hope COMODO forums gets you there

Cardinal rule: Run only one firewall at a time.

This would mean that Windows Firewall is turned off/disabled before installation of new firewall. Only exception to this I know of is Avast! Internet Security. This one will actually turn Windows Firewall back on when it is installed, and you have first uninstalled the old third-party firewall. It is the only security suite I know of that allows Windows Firewall to run alongside the vendor firewall without conflict.

Be sure to investigate use of Threatfire and/or Spyware Terminator Free. Threatfire in particular is known to cause no connectivity conflicts or disabled a/v programs when an a/v or firewall is updated or changed.

I used COMODO in the past. The result on my XP system was inordinate hangs and system slowdowns when it would go to check a file I was attempting to run via checking with the COMODO cloud. If the file was found to be clean and reputable, it would eventually allow it to run. Then and only then would the system hang end.

- Collapse -
solved it

i had the same problem today. and stubled on the answer. pretty easy too. click on the wireless connection icon in left lower corner. or open the network connections icon. click properties on the wireless connection... under internet protocol (tcp/ip) highlight it and click properties. make sure it says obtain ip address automatically. write down the numbers you see before you do that just incase it doesnt work. then see if a website like google comes up.. credits to him:

CNET Forums

Forum Info