Resolved Question

Can't connect to a wifi network, it shows "disabled".

Have a Lenovo A269, gingerbread 2.3. I've used it very little the last few months. On another thread you can read that I haven't even transferred my contacts yet. So haven't dropped it, no damage whatsoever.

As of today it refuses to connect to a wlan network. I have only tried three, my home and 2 public hotspots, all unsecured. First it says "obtaning ip address", then "remembered", then it drops the connection and says "disabled".

Restarted my phone, same thing. I know my home connection is ok because I'm connected right now typing this.

Any suggestions? Is a factory reset in my immediate future? Which I don't care as I've only added a few apps to this phone and that's it.

Thanks.

Discussion is locked

Sunsetlover has chosen the best answer to their question. View answer
Follow
Reply to: Can't connect to a wifi network, it shows "disabled".
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't connect to a wifi network, it shows "disabled".
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

Best Answer

- Collapse -
2.3 is getting old

First, backup so you're ready to factory reset.

Second, have it forget all networks to date. This varied with each Android so I don't go beyond the forget or delete advice. Folks, sorry, Android is that nutty.
Bob

- Collapse -
Yes, new phone with old OS

Bob, thanks, I did have it "forget" the networks and now it's working. I was afraid it might be the wireless adapter.

Will update if it starts doing it again.

- Collapse -
Answer
wifi network

Once you can check your wifi setting or you can install wifi from play store.

- Collapse -
(NT) Why do that when the old forget networks worked?
- Collapse -
Answer
Solution

I may be late in answering this but I recently had this issue and was going mad solving it and trying each and every method. There is no fixed solution for this anywhere, just trial and error. Mentioned below are the solutions you can try.
1. Forget the WiFi access point and reconnect with correct password (if it has any)
2. Restart your phone and/or router.
3. Check if your phone gets connected to other WiFi. Maybe try creating a hotspot from another phone and check if it's connecting.
4. Check if other devices are getting connected to the WiFi router.
5. Login to the router admin panel and check and verify is settings like if it's having MAC filtering on (needs to be off).
6. Check if it's broadcasting using 802.11 b/g/n, or just 802.11 n. Older phones do not support 802.11 n [this was my problem]

CNET Forums

Forum Info