HolidayBuyer's Guide

E-readers forum

General discussion

Can't connect Nook to home Wi-Fi

by bopci / January 1, 2011 6:47 AM PST

Trying to connect wife's Nook (Wi-Fi connection only edition).
The home router name comes up but has a lock symbol next to it. Trying to sign in won't accept the password saying it is incorrect. I know it is right because I can sign onto the router info at D-Link website.
The router is a D-Link DIR655 WP/WPA security.
Help please.

Discussion is locked
You are posting a reply to: Can't connect Nook to home Wi-Fi
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't connect Nook to home Wi-Fi
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
The router password and the router admin password
by R. Proffitt Forum moderator / January 2, 2011 3:26 AM PST

Do not have to match. Go figure.

Collapse -
Use the "Guest" feature on your D-Link 655 router.
by EscapePod / January 7, 2011 9:34 AM PST

Your router has a feature to easily set up a "Guest" wifi connection, separate from your regular home network. Check the router's Help to find out about it. You can get to it by logging into the router, click on the Advanced tab, and then on Guest Zone at the bottom of the column on the far left. This Guest setup seems to work best for Nooks, and similar reader-type devices. You won't be able to see the other devices on your network, but that's usually not something you do with a reader anyway.

Collapse -
Thx, EscapePod!
by Tom_Clark / August 17, 2011 3:09 PM PDT

You saved my daughter and her Nook, EscapePod. Thx so much.
Had the same problem trying to sign in and password not accepted, though it was correct. Barnes and Noble tech support was clueless and D-Link tech support could not help. I finally turned to the Cnet chat forums and found this one.
Followed your advice and read the user manual to create a new connection under Guest Zone. Configured it for WEP security and connection did not work, same message about the password. Then configured it for WPA-Personal and same problem. Only after choosing No Security did the connection work. I don't care about the lack of security for a Nook.
These forums are invaluable! Priceless!

Collapse -
by EscapePod / August 17, 2011 10:10 PM PDT
In reply to: Thx, EscapePod!

Glad it worked out OK.

Collapse -
I have decided to use a password....
by Tom_Clark / August 18, 2011 2:26 AM PDT
In reply to: Welcome

Thought about it and I don't want an unsecured connection on my router. I had 1st configured the Guest Zone connection for WEP security
and connection did not work, same message about the password. Then
configured it for WPA-Personal and same problem.
I am going to try again tonight, but right now, any thoughts on this failure to connect? Thx.

Collapse -
by EscapePod / August 18, 2011 5:55 AM PDT

Using a passphrase, even on the Guest Zone, is a good idea, as is using WPA-Personal. Double-check the passphrase (password) carefully for that zone on both the router, and the Nook. Try to be relatively close to the router when setting up the Nook. Also, make sure both are set to provide the IP address via DHCP.

If you have a laptop PC, you could temporarily configure that to connect via the Guest Zone, just to test it to be sure everything is working correctly on the router.

Collapse -
Guest Zone Works!
by SAnderslam / November 17, 2011 8:20 AM PST
In reply to: Re-connecting...

Thanks SO much! I just got a Kindle Fire and could not for the life of me get it to connect to my DLink 655. With Guest Zone + password, it worked immediately. Bonus- the husband's DROID also finally connects. THANKS

Collapse -
by EscapePod / November 17, 2011 10:07 PM PST
In reply to: Guest Zone Works!

You are very welcome. Enjoy your new Fire. I am considering upgrading to that, too. Of course, I'm pretty sure it will be difficult to pry from my wife.

Collapse -
Cisco Routers
by Sparrows / August 22, 2011 12:43 PM PDT
In reply to: Thx, EscapePod!

Your story only made me think of how happy I am to have my Cisco router. Should I forget the password which I am always doing, the program to connect it and show me my password is on my start menu under Programs. There I have a program called Cisco Connect and when I click on it, it has everything I need to know about my network including my password.

Thank you Cisco. Silly

Collapse -
802.11b or g
by pbferry / January 7, 2011 2:31 PM PST

Make sure that your router is not set to 802.11n only. The Nook and Kindle connect only with b or g. That router will broadcast both b and n together. Temporarily set your router to no encryption at all to make sure the devices talk to each other under the best of conditions and then add encription.

Collapse -
Thank you!
by patjulie76 / June 2, 2011 7:49 AM PDT
In reply to: 802.11b or g

I have been trying to get my husband's Nook to connect to our home wifi and thanks to your post pbferry, it is now working. We are very happy people!! Thank you, thank you, thank you.

Collapse -
Found the solution
by blmckee / December 5, 2015 2:57 PM PST

I have 3 Nooks and they all had trouble connecting. After reading about the guest network it got me on the right track. I used the Guest-WIFI with the security set to WPA-Personal. The part that I feel did the trick are these settings:

WPA Mode: WPA Only
Cipher Type: TKIP

Good luck to you.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.