Question

Can't connect my PC to wireless n router

Upgraded my router from g to n. Easily connected my laptop, itouch, iphone. My wireless g card in my windows xp desktop sees the new wireless n network and tries to connect, but it times out and cannot connect. Restarted computer, didn't help. What now?

Discussion is locked
Follow
Reply to: Can't connect my PC to wireless n router
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't connect my PC to wireless n router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
(NT) Did you set your router to allow G connections?
- Collapse -
Says it is backward compatible for a/b/g

Must I config the router to allow G connections?

- Collapse -
Router

The dlink router says 802.11 Mode: 11bgn
Does this or does this not mean it is already set to allow g signal to connect?

- Collapse -
Where does it say that?

And yes you must configure it or KNOW it is configured. It's not automatic.

There may be other reasons such as the RF Channel is at 13 but I'm starting with what you posted.
Bob

- Collapse -
It says that when I connect/log-in to the router

The router is a d-link DIR 655. The channel is 6. I did not see anywhere to change the setting to allow certain signals. I am "assuming" it should be connecting because of the above post/info about the 802.11 Mode begin set to 11bgn. Do you any other thoughts...

- Collapse -
Cool. Let's use the simulator.
- Collapse -
Router details/settings in the "Wireless LAN" section

The emulator varies only slightly to mine. There is "mixed". This what my router reads...

Wireless Radio: Enabled
802.11 Mode: 11bgn
Channel Width: 20/40 MHz
Channel: 6
WISH: Inactive
Wi-Fi protect setup: Enabled/configured

- Collapse -
For a test, set the wifi security to none.

Some devices won't connect to some security choices.

Sorry I can't know all the combos. I have to test what works where and with what.
Bob

- Collapse -
Some success!

On the router, I was able to set an individual IP address to accept on the network. I set a new IP address on the computer and copied that MAC address to match the same on the router. But on the desktop, I did not know the DNS server address so I left it blank. My Wireless Network Connection box now says that I am connected to the network, but Internet explorer says that I have no connection. I assume that it is because I have not set the DNS address. If so, how do I obtain that number?

- Collapse -
AHA.

Are you using MAC filters? Those give folk far too much pain.

- Collapse -
MAC filters?

Not sure what MAC filters are. What should I be trying next?

- Collapse -
If this was mine I would.

Reset the router to factory defaults and if the default is wifi disabled (some arrive like that) turn it back on.

After this many posts details are still not being told. I hope members will realize it's up to them to tell all. Firmware versions, settings and such. These problems involve so much that to ask all 34 questions with each new post would tire everyone out.

Start over and hope it's some setting that is amiss.
Bob

CNET Forums