Nevermind my question. I was able to solve the problem on my own.

For anyone else having this problem, here is the solution:

On your handheld, go to the Calendar.
Click on Menu -> Filter
Click on "More..."
Check off the categories you want shown on the calendar of your handheld.

It's still not the perfect solution, IMO, as, if I set up private appointments, I wouldn't necessarily want all employees to be able to turn on the appropriate filters and see what other employees are doing, but it will work. I don't really have to schedule too many private appointments anyway, so no big deal.