Computer Help forum

General discussion

Can't boot into safe mode or anything for that matter

I've got a Dell 8300, P4-2.80G, 1G DDR SDRAM, XP Pro. I made the cardinal error of trying to fix something that wasn't broke. I decided to see if there was a driver update for my Maxtor HD, using the update driver function in the Device Manager. It searched for the update and then I received a BSOD with this error ?Stop: c0000221 Unknown Hard Error \SystemRoot\System32\ntdll.dll?. I shut down the system and rebooted. I get a momentary manufacturers splash screen. My two hot keys are F2 and F12. I can reach the BIOS information and the Boot Device Menu, that's it. I can't reach "Safe Mode", I can't reach anything. I used my XP Pro disk and the system won't accept it, and it's the disk that came with the system. I got a new copy of the ntdll.dll and tried to replace it but I couldn't do anything with it. I consider myself fairly knowledgeable but this has left me with the taste of rank amateur in my mouth. Any ideas? Please?

Tig

Discussion is locked
You are posting a reply to: Can't boot into safe mode or anything for that matter
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't boot into safe mode or anything for that matter
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
"I used my Windows disk and the system won't accept it".

In reply to: Can't boot into safe mode or anything for that matter

That can't be caused by anything you did in Windows, because the PC should boot from a bootable Windows XP disk even with the hard disk totally new and blank and empty. It boots the OS from the CD, only then starts to look at the hard disk and see what it can do with it.

It's not clear from your post what you did after searching for the update (and maybe finding it?) and receiving the BSOD. Did you download something, install something? Or did the BSOD come before you even started the download. You simply don't tell and leave us guessing.

If the boot device is set to cd first AND the xp cd is bootable (as an authentic Microsoft CD is) and it still doesn't boot, you can be sure it's a hardware issue somewhere that needs repair.
You can check the boot device in the BIOS, as you say. You can check the CD on any other computer where you can access the BIOS. After those 2 simple checks you know more.

Kees

Collapse -
Can't boot...

In reply to: "I used my Windows disk and the system won't accept it".

Sorry, I thought I explained it fairly well. I searched for the update using the link for(updating)the HD in the Device Manager. I selected the "Update driver" and allowed it to search automatically for any possible upgrades. As it was searching, I suddenly received a BSOD with this error ?Stop: c0000221 Unknown Hard Error \SystemRoot\System32\ntdll.dll?. As I said, I had simply selected to "Update Driver" and this error occurred during its search. I also used the Boot Device Menu and changed the boot order so the CD-Rom was first. The disk opened and it checked my configuration, etc.,etc. and then after running the "Windows Setup" it says that "Setup is starting Windows". I'm then offered three choices 1.Set up Windows XP now 2. Repair Windows XP 3. Quit Setup. Selecting either 1. or 2. I receive a notice that "Setup cannot access this disk." In the same box it says "39206 MB Disk 0 at Id 0 on bus 0 on atapi." It has mentioned that I need to partition the drive and when I attempt to do that it opens that same window indicating Setup cannot access this disk.

I fail to see how it could be a hardware failure because it was operating fine and this occurred only after trying to update the hard drive driver. It is a genuine MS XP Pro disk and I have the key, so it's not a counterfeit disk. I apologize for the scattered explanation. Thanks Kees...

Collapse -
Also

In reply to: Can't boot...

I just received a notice that setup cannot install to the selected partition.

You can only install to GPT disks on IA-64 machines and MBR disks on X-86 machines.

Enter to continue which takes me back to the screen mentioned previously.

Collapse -
Re: hardware failure

In reply to: Can't boot...

- Setup can't access the disk.
- Setup uses the drivers from the CD, not the drivers you tried to update.
- You got an 'unknown hard error' while searching for a new driver.
- There's nothing in your story that points to the update being done already.

That leaves one conclusion: it's the disc itself or the interface to it on the motherboard. It was operating fine. And now it isn't. Such things happen. That's what I call a failure.

Things I would do:
1. Reset the BIOS to something called 'defaults' or 'safe defaults'. But I don't believe searching for a disc driver will corrupt the BIOS, so it's a small chance that it will work.
2. Download killdisk or dban (both free) and boot from its CD to wipe the entire hard drive. Then - if they don't fail - try installing XP again. But my idea is right, they will fail.
3. Trying another (new?) disk.
4. Replace the motherboard.

If there's data on the disk you don't want to lose and don't have on a backup, skip #2.


Kees

Collapse -
I'm going to comment about "Update Driver"

In reply to: Can't boot into safe mode or anything for that matter

If there's one thing to learn is that you can't trust this button.

Use this as your personal lesson then look to last known good boot or even wipeout and start over.

-> Let me repeat this another way. Update drivers from the makers. Not Microsoft.
Bob

Collapse -
That boot error.

In reply to: I'm going to comment about "Update Driver"

Collapse -
So true!

In reply to: I'm going to comment about "Update Driver"

That's something I generally don't do but have in the past and got away with it. This has turned into a train wreck for me. I read the information you recommended Bob but I can't boot to anything. It's either the BIOS or the Boot menu. I can't get passed that point. Anything I try just gets me a notice that "Setup cannot access this disk." Is this thing toast?

Collapse -
"Setup cannot access this disk."

In reply to: So true!

All too often I find this when the hard disk is on the SATA connections and the BIOS doesn't emulate IDE.

The old F6 key during the XP CD boot is used and we supply the drivers on floppy for old times sake. Who said the floppy was dead?
Bob

Collapse -
Could be, but ...

In reply to: "Setup cannot access this disk."

this is what he wrote a few posts above:
I receive a notice that "Setup cannot access this disk." In the same box it says "39206 MB Disk 0 at Id 0 on bus 0 on atapi."

That didn't look like SATA to me, so I didn't mention that possibility. Agree?

Kees

Collapse -
I always check...

In reply to: Could be, but ...

Then again they could be dual booting which could cause the second odd boot issue.

Collapse -
IDE Drive Diagnostics

In reply to: I always check...

IDE HD Diag. running,
Primary SATA Drive 0: no device
Secondary SATA Drive 0: no device
Primary IDE Drive 0: Maxtor 6E040L0-Error attempting diagnostics
Drive 1: no device
Secondary IDE Drive 0: JLMS DVD-ROM XJ-HD166-Diagnostics not supported
Drive 1: SONY CD-RW CRX216E-Diagnostics not supported

Test complete, Press <ENTER> to reboot

Collapse -
There's a missing clue here.

In reply to: IDE Drive Diagnostics

See post 7 and tell us about it.

Otherwise it looks like a failed hard disk or you tried to format that drive ahead of installing XP (which can trip up the XP installer.)

Collapse -
GUID

In reply to: There's a missing clue here.

I sent you a message earlier on this subject but I see it didn't make it past the gate keeper. Anyway, it is impossible for me to reach any sort of command interface. I can't access any function, no safe mode, no My Computer, nada. I believe that my BIOS page is nothing more than the setup utility. My bad... I've seen everything in the last two days except the things needed. So strange that simply looking for a driver update would ruin my system. I can't do anything with it.

Collapse -
OR...

In reply to: GUID

The hard disk failed and it just chose a bad time.

Collapse -
Thanks

In reply to: OR...

This has truly been a lesson. By simply using a M$ link to try and update a hard drive,ruined the drive instead of updating it. There's something very wrong with these results! The system was operating so well and has always been very dependable. I always stayed on top of required maintenance, good firewalls, anti virus programs, never put trash on the system, yada, yada, yada. I'm so peed off right now that the only azz I need to kick is my own. I'm not sure who stinks more right now M$ or my decision to trust them. I think I'm going to take a shower. Thanks gents for your patience. Is there anything I can do with this now or is it junk?

Collapse -
Just luck I guess.

In reply to: Thanks

Think about how old most 40GB drives are. I just pulled my wifes drive out of a machine that was getting wierd. It was a 40GB drive and the very first thing I did was get her to copy ALL the files out. The drive is now failing the drive maker's diagnostics.

Small world it seems. That drive is so old I can't remember when we got it.
Bob

Collapse -
Installing new HDD?

In reply to: Just luck I guess.

Okay, it took the better part of this evening to free my tower from captivity, what a job. Uggh... Now that we've decided that this Maxtor IDE 40 Gig paperweight is toast, what is the recommendation for replacement? Another IDE or a SATA? Granted I'll be upping the storage space considerably, will the new drive adjust itself accordingly or will a BIOS Flash be required? One of my major desires would be to recover some of the software from the old drive. Is there anyway of determining that beforehand or should I consider everything non recoverable? I've got my business files, passwords and email contacts backed up about 80%. Everything else will have to be installed again. A lot of the software came pre-loaded and will be lost. Carbonite sounds pretty good right now! Would you recommend taking the box into a shop where knowledge is far better than my own? Any opinions up to and including replacing the system are welcome and appreciated. It's a Dell Dimension 8300, purchased in 2003. It has been a great system but I'm not sure if spending two or three hundred for a replacement drive is the best way to go.

Signed, Confused in FLA :^[

Collapse -
Re: new hard disk

In reply to: Thanks

http://www.bestbuy.com/site/olspage.jsp?skuId=6963565&st=hard+disk&lp=4&type=product&cp=2&id=1099384455782 is an 320 Gb IDE disk for $99.99 and it might be OK. That depends on
1. The BIOS (might have a 127 Gb limitation in a machine from 2003)
2. Your OS (must be at least XP SP2)

You surely can use it as a second hard disk in most modern machines. They all have SATA, but there's a fair chance they support 2 IDE-drives: choose 2 from DVD-burner, DVD-read only, CD-burner, CD-read only and this nice hard disk.

But just as well, you might consider to save this $100 and buy a new machine right now. Your choice.

As to getting your data back, you can try to mount this disk in an external drive and use data recovery software (like GETDATABACK or ZERO ASSUMPTION RECOVERY), but if it's an electronic or mechanical failure (and it seems like it, because even the diagnostics won't run) that's useless. Unless you want to pay $1000 or more for professonial recovery, consider everything on it lost.

Best of luck with this issue.

Kees

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.