First, try disabling UAC. Open the Control Panel (Classic Style), then double click on "User Accounts", then in the "Turn User Account Control (UAC) on or off", UNCHECK the box for "User Account Control". Reboot the computer.

Once that's done, Vista may warn you of the lack of security by throwing a red or yellow warning shield in the lower right corner/system tray. You can disable that as well by opening Control Panel, then the "Security Center" icon, then select the "Don't Notify me and don't display the icon" option.
________________________

If that doesn't get it done, then see the instructions in the link below:

http://www.mydigitallife.info/2007/05/25/how-to-take-ownership-and-grant-permissions-in-windows-vista/

Hope this helps.

Grif