Windows Legacy OS forum

General discussion

can't access internet options in IE

by (nick) / July 28, 2004 2:26 PM PDT

I run XP Pro. In Internet Explorer, when I click on Tools/Internet Options I get this message: "this operation has been cancelled due to restrictions in effect on this computer. please contact your system administrator." However, I am the administrator.

The internet options icon is missing from the control panel as well. I was able to find the Inetcpl.cpl file and put a link on the desktop. This is only a temporary fix. I want to regain access to the options from IE and the control panel.

1) I do not have spybot or any other such program.
2) I have searched the registry for this: HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions
and I found this instead:
HKEY_CURRENT_USER\Software\Policies\Microsoft\SystemCertificates (no Internet Explorer)

I suspect this started happening after I downloaded a Windows XP security update from Windows Update, but I have tons of them downloaded.

Thank you for your help,

Discussion is locked
You are posting a reply to: can't access internet options in IE
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: can't access internet options in IE
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: can't access internet options in IE
by R. Proffitt Forum moderator / July 28, 2004 9:41 PM PDT

Even if you don't have Spybot, I use it to remove the restrictions. Try it.


Collapse -
Re: can't access internet options in IE
by Cursorcowboy / July 29, 2004 12:43 AM PDT

What is generally found:

Note: Two important things to know is that the system registry copies changes immediately and there is no Undo command. The editor does not wait for a Save to be issued since it does not have one and therefore makes changes permanent as they happen -- you make a change it's gone forever unless you remember it or have already backed up a copy. Use the editor sparingly and soberly and do not leave it open unnecessarily.

a. Click Start, Run, type regedit, and then press Enter.

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Note: Click the "Plus" before each of the words preceded by a back-slash in the above registry address until you reach Restrictions, which you will then bold/highlight by clicking.

b. You may find that the Restrictions key contains two entries, the first line is a Windows default entry and the second is usually added when using the Spybot restrictions option (periods added for clarity and is not part of the information) and a Policy restriction setting that precluses the use of this IE feature:

Default . . . . . . . . .(value not set)
NoBrowserFunctions . . . . . . . . . . 0x00000001 (1)

Collapse -
still not working
by (nick) / July 29, 2004 1:19 PM PDT

1) spybot did not remove restrictions

2) as I said in my first post: I DO NOT have this

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

I have this instead:
HKCU\Software\Policies\Microsoft\System Certificates

no internet explorer or restrictions

3) I ran System File Checker, and it did not find a problem.

thank you

Collapse -
Nothing further, but . .
by Cursorcowboy / July 29, 2004 10:00 PM PDT
In reply to: still not working

Besides your reported, I have also the following address that is used with Win98FE/MSIEv5.02SP2, but it may not matter:


[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer] (sub-key for Microsoft & value is not set)

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery] (sub-key for Internet Explorer & value is not set)

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\CompletedModifications] (sub-key for Infodelivery and its value)

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel] (sub-key for Internet Explorer & its value)

Collapse -
Re: can't access internet options in IE
by bob8650 / July 29, 2004 7:38 PM PDT


Collapse -
Re: can't access internet options in IE
by raj22 / July 30, 2004 1:40 AM PDT

While you are logged on as an administrator, click Start, and then click Run.
In the Open box, type regedit, and then click OK.
Locate the appropriate registry subkey, right-click the IsInstalled (REG_DWORD) value, and then click Modify.

To reinstall only the Internet Explorer 6 browser component on Windows XP, use the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{89820200-ECBD-11cf-8B85-00AA005B4383}

To reinstall only Outlook Express 6 on Windows XP, use the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{44BBA840-CC51-11CF-AAFA-00AA00B6015C}

Change the value data from 1 to 0, and then click OK.
Quit Registry Editor, and then install Internet Explorer 6.

Collapse -
restrictions won't go away
by (nick) / July 30, 2004 8:46 AM PDT

I did an uninstall from the registry; then reinstalled IE. I still have the restrictions!

Collapse -
Re: restrictions won't go away
by xcks / July 30, 2004 2:39 PM PDT

You seem a bit stubborn about downloading & allowing sybot to simply fix your computer. How about this? Go to this site, fill out the info for a free CD it will automatically get your comp info and regaurdless of how long it says it may take to recieve it, in 3-5 days and you will have it. Cant beat that.
1. FREE Update CD:
and many helpful registry help tips are avaible.

Collapse -
Why restrictions won't go away with reinstall.
by R. Proffitt Forum moderator / July 30, 2004 10:56 PM PDT

Microsoft has it coded to keep prior settings.

It's why I use Spybot to unlock such settings, then and if that doesn't do it, I get to dive into the registry and delete the NO words that can restrict actions.

Sorry, I have no step by step procedure since it's rare I didn't fix it with the Spybot, but I do use Google to look up "no" words in the registry to refresh my memory as to what keys are at play. Such as This search is usually where I start since I've run into the nodesktop too often. The policy keys are in and around that area and after awhile "you know" which to just delete.


Collapse -
Re: Why restrictions won't go away with reinstall.
by (nick) / July 31, 2004 1:39 PM PDT

Evidently none of this stuff is activated. All I find is NoDriveTypeAutoRun.

Collapse -
Thanks for the help
by (nick) / July 31, 2004 7:30 PM PDT

however, the restrictions are now a moot point. I am having hardware problems again and finally decided to send it off to the supplier for repair.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?