Windows Legacy OS forum

General discussion

Can not associate AVI with Classic Media Player

by gargoyle_xlvii / November 20, 2006 7:32 PM PST

Can not associate AVI with Classic Media Player.
It seem that no matter what I try I just can not get a AVI to associate with the
Classic Media Player.

I have:
Gone to Tool/ File type/ Avi/ Edit / Classic Media player

Right click on file Open with choose Classic Media Play (checked off always Use)

Right click choose from Listed programs Classic media Player.

None of the above will stick. If I double click on the avi in Windows Explore it
wants to install the MS Windows Media Player.

How do I change this so it is set for Classic Media Player not installMS Windows
Media Player?

Discussion is locked
You are posting a reply to: Can not associate AVI with Classic Media Player
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can not associate AVI with Classic Media Player
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Can't see the issue/cause so here's a workaround.
by R. Proffitt Forum moderator / November 20, 2006 10:40 PM PST

Let WMP install and finish. Now replace WMP's .exe with Media Player Classic's .exe.

Poof. Fixed.


Collapse -
If only it were that easy
by jackson dougless / November 20, 2006 11:13 PM PST

Somewhere along the line, Microsoft made it a bit more difficult than that. If you delete the WMP exe, it will magically respawn from a special hidden cache. If you change the exe to one that doesn't match what's in the cache, it will get overwritten. If you delete the copy from the cache, it's respawned from the non-cache version. You have about 2-3 seconds to hit both of them before one respawns the other.

The key is Media Player Classic itself, which has an option to associate different file types with itself. The icon for these files won't change from the WMP one, so it trips some people up at first, but it does work. I'm on a Linux box at the moment, so I can say exactly where it is. Just go to the MPC options, and it should be in the first section regarding the player. If in doubt, go through them one by one until you find it. There are even handy buttons to select all audio formats, video formats, etc.

Collapse -
I have a solder iron.
by R. Proffitt Forum moderator / November 20, 2006 11:44 PM PST

And am not afraid to use it. You're right but I pulled this off without tripping SFP. Go figure.


Collapse -
You were right under Options
by gargoyle_xlvii / November 22, 2006 8:01 PM PST

To jackson dougless:
You saidThe key is Media Player Classic itself,

And you were right, I had not used the Option in MPC to associate AVI's with it, once I did it worked properly.

Thanks for pointing this out, just wish I will be able to remember it in the future.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?