Networking & Wireless forum

General discussion

Can connect to Linksys router, but internet won't work.

by MTipton / October 22, 2006 6:15 AM PDT

I'm having problems using my Linksys Wireless B router. I have 3 roommates and all 4 of our laptops are unable to use the wireless internet. It was working fine and messed up on all our laptops the same night. Our laptops are an HP Pavillion ze5500, a Compaq Presario v2000, and 2 Inspiron notebooks. All use Windows XP Home SP2.

The router shows up on the available networks, and we can all connect. But the internet itself will not work. However, I can connect with a Cat5 cable via the router and the internet is fine.

I've tried resetting the the router. I reset the IPconfig. Downloaded some programs from I've read through some forums. I can't figure it out.

Please help!

Discussion is locked
You are posting a reply to: Can connect to Linksys router, but internet won't work.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can connect to Linksys router, but internet won't work.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Not good....
by jgvillan / October 23, 2006 9:19 AM PDT

It sounds to me that the wireless portion of your router may have fried. It's not uncommon, but it's certainly possible. Other than just resetting the router...have you tried to flash the firmware of your router? Downloading the latest firmware for your router? It's also possible that you are getting interference from someone's wireless. See you if you change it's wireless channell with a different SSID. Try that first....and if all else may need to get a new wireless router, or a dedicated WAP (Wireless Access Point) and connect that to your router.

Hope that this helps and good luck.

Collapse -
Bad news...
by MTipton / October 24, 2006 11:42 AM PDT
In reply to: Not good....

I tried everything I could think of to get the wireless router working, but to no avail. So.. I bought a new router. I bought the Linksys Wireless G router, installed the software, and it still doesn't work on any of the computers. If it were just mine I would expect it to be my laptop. Does anyone know of any possible problems it could be with my ISP?

Collapse -
by MTipton / October 24, 2006 12:03 PM PDT
In reply to: Not good....

My computer will sometimes connect to an unsecured network from across my apartment complex. So it's not my computer.

In case this helps.. when I try to connect to my wireless network, it automatically refreshes the list of networks, but when it returns it says "Automatic" beside my network. If I try to connect again, it just says connecting... but will never connect.

Collapse -
similar issue
by UMichClay / October 27, 2006 8:59 AM PDT
In reply to: Update...

i have a similar issue... i had a windows popup the other day saying something like win32 app is trying access my pc do i want to allow, block once, always block, or ignore. i chose always block thinking it was a virus of some type. now i cannot get any web pages to display. i am connected, but it jus t gives me the cannot find window page. i cannot find anythign to help in this matter. if anyone has any info pleas help. i do not want to reformat, but it may be my only option. I really think it is some type of BS windows security issue. but to try and talk to an english speaking person than knows their *** from a hole in the wall is impossible.

Collapse -
Maybe this will help you connect to the internet.
by Anapestic / October 31, 2006 2:06 AM PST

Go to the Linksys Configuration online site: If you have already been there before, sign in. If not, type Admin in the password block and when the page opens, click on WIRELESS, then click on WIRELESS MAC filter.
Now click on EDIT MAC FILTER list. Starting in the left column: List all your wireless Laptop MAC addresses. Don't forget to list the colons. At the bottom of that page, click SAVE SETTINGS. When the page returns, click ENABLE & PERMIT ONLY the PC's listed. Click SAVE SETTINGS. Close the configuration page.
Have your laptops in the same room as the Router for now and turn them on. Unplug the router for 10 seconds - then plug it back in. If you have a Linksys WRE54G Range Extender, you should also list it's MAC address in the MAC Filter list. I did that on my system

Collapse -
TCP/IP stack??
by MTipton / October 31, 2006 8:25 AM PST

When I run command promt>ipconfig, for my wireless internet it says "media disconnected." I read that the problem may be a corrupted TCP/IP stack. I'm not sure what that is, but I downloaded a program that is supposed to repair it. Immediately after I repaired it, I ran ipconfig again, and my wireless showed up working, but returned to the previous state right after.

Any ideas?

Collapse -
Solved Problem
by joshboteam / September 29, 2009 2:33 AM PDT

I had this problem for about 2-3 weeks, I finally figured it out last night, what I did was use Internet explorer, I normally use safari, so if you use firefox or anthing different, just use internet explore 1 time. When you click on it, it brings up the usual screen, no internet. In the middle of the page, it has a button or link called network diagnostics or something. Click on that. It test your system, why you not connecting. 1st it says the usual thing, turn off router, everthing else, blah, blah, blah, we've all done that before doesn't work. then keep clicking continue or what ever it is, then for me it said the problem is your key is not identical with the router, I've put the key in a billion times before, but I clicked on there little blue link, followed there directions, typed my key in again, an ta dah. It somehow worked. I now have wireless internet again. I tried everything, turning off firewall, removing software, going through my computer changing stuff, all the ipconfig stuff, ping stuff, resetting computer a billion times. For whatever reason this worked for me. I had to put my key in that exact spot or program whatever and it worked. Hopefully its works for you.

Collapse -
Linksys says automatic..I had
by rico1010 / November 24, 2011 9:50 PM PST

I had the same problem with an old laptop , and resolved it. I changed the settings on my router( cell phone router) from "Automatic" to Channel 1 and viola it worked. I hope this will work for serveral people out here, Happy Holidays.....

Collapse -
I GOT IT !!!!
by DannyKawaii / July 13, 2012 9:33 AM PDT

I had the same problem as the guy said, after hours trying to do all the regular procedures.

I was happy reading a good post. The hint is make your modem route-able then:
use automatic configuration DHCP;
***change the number in the 3rd block of IP address (because if the router and the modem have the same, it causes conflict!!!)
TAH DAH it worked like miracle, i didn't even had to restart anything.

Collapse -
This is a well known area if you know to ask google.
by R. Proffitt Forum moderator / July 13, 2012 9:41 AM PDT
In reply to: I GOT IT !!!!

"How to use a router as a WAP?"

Collapse -
Thanks for the posting!!
by SrikarthikV / January 10, 2013 12:23 PM PST
In reply to: I GOT IT !!!!

Yes, changing the subnet of router from default 192.168.1 definitely helps. The ISP provided by modem is always conflicting with this subnet. A very valuable suggestion, Linksys needs to make a note of this and alert their consumers.
Thanks for the posting!!


Collapse -
Same problem, tried all, the simplest works!
by chdyl / April 16, 2014 3:36 AM PDT

I had the same problem. My router worked fine and stopped working one night.
After I reconfigure and reboot everything that I know, the problem is still there.
I came across this posts and tried all the good tricks, but still not work for me.

Before giving up. I turned to the most naive trick that even a housewife can do:

1. Unplug cable, unplug router and turn off computer (yes, turn off computer. Although my rationality tells me that it is totally irrelevant).

2. first, restart cable; second, restart router; third, restart computer.

And the problem solved!

I did try to restart cable and router earlier, but not in this order as above and did not restart my computer.

I don't really know which tricks really solved the problem though, maybe all of them combined.
God know. :.p

Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!