Question

Can Avast Anti-virus mess up your USB port?

Apr 21, 2016 12:05AM PDT

I put this in General Help because I really don;t know where the problem is. I have a homebuilt computer (Intel DP35DP motherboard with Intel Core 2 Duo CPU running Windows Vista) that has been working just fine for the past 7 years. I have been loading pictures from a Canon PowerShot SD1100 IS via cable to a USB port without problems this entire time. A couple of days ago I switched from Norton Security to Avast Anti-virus. From that point on when I plug in the camera, the computer buzzes 3 times and nothing happens. I tried various settings in Avast, including disabling all of the "shields" to no avail. I even uninstalled Avast and rebooted, but incredibly, the problem remained. The only other thing I had changed was turning on the Windows firewall, so I turned that off, still to no avail. I have tried different USB ports on the board. The ports do work, because I can plug in flash drives and they open up just fine, although they also trigger the 3 buzzes, which has never happened before now. I checked the Canon site to download fresh drivers, but they apparently use the default Windows Vista drivers. I even uninstalled a couple of the USB drivers in the Device Manager and rebooted to force a reset (I say a couple, because there were about 16 listed and I really didn't want to go futzing with all of them.) There are no messages in any of the event logs. If Avast has a log of its activity, I haven't found it. I have run out of things to check, and I haven't even isolated where the problem is. The fact that it started after installing Avast would seem to be a big clue, but the problem remained after uninstalling it, so was that just coincidence? Any ideas would be greatly appreciated.

Discussion is locked

Follow
Reply to: Can Avast Anti-virus mess up your USB port?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can Avast Anti-virus mess up your USB port?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
this sounds BIOS related
Apr 21, 2016 12:13AM PDT

Go into the BIOS of the computer and check it's USB settings. Has your computer initially on bootup had wrong date and time? It would automatically set the current date and time from internet. Boot it up once with it unplugged from internet. It's likely your motherboard battery is losing BIOS settings due to needing replacement.

Once that's out of the way, if needed, reload the software for the Canon camera.

- Collapse -
reply to James Denison
May 10, 2016 12:13AM PDT

Hi - sorry about the delay in responding. (I was expecting to get email notifications when someone replied to my question, but apparently not. Anyway, I just now found time to check in on my original post.) I checked my BIOS and the only options for the USB were enable/disable. They were enabled, (not surprising, since I could read flash drives, it's only the camera that has stopped connecting.) I looked on the Canon site for drivers, but it says they use the standard drivers in Vista. That is why I tried forcing a reset of the USB drivers. Thanks anyway for you time and effort.

- Collapse -
Answer
Uninstall norton
Apr 21, 2016 9:07AM PDT
- Collapse -
I agree.
Apr 21, 2016 9:28AM PDT

Just last week I uninstalled McAfee along with this to get a machine to work again. 15 minute boot time dropped to 3. Still long but will agree on your idea.

- Collapse -
reply to Uninstall norton
May 9, 2016 11:48PM PDT

Hi - sorry about the delay in responding. (I was expecting to get email notifications when someone replied to my question, but apparently not. Anyway, I just now found time to check in on my original post.) I did use the Norton Removal tool, and rebooted before continuing. I found and deleted some remaining Norton files, but it didn't seem to make a difference. They were mostly .dat files and logs, so I'm not surprised. Thanks anyway.

- Collapse -
Look at this link and see if it offers a clue
May 10, 2016 2:29AM PDT
http://www.boche.net/blog/index.php/2011/07/27/usb-thumb-drive-not-recognized-3-fast-beeps/

I've had USB port issues where uninstalling the drivers through device manager, rebooting and allowing Windows to re-detect the hardware has resolved such issues. It's been a while but I've seen it. As well, I've had USB hubs/controllers return to USB 1.1 for no known reason and the same process fixes them. USB has been an enigma for a long time. As for your Canon, sometimes some service needs to be started that looks for devices to appear. Your camera may be one such that, though it detects that something has been plugged in to a USB port, it doesn't know what to do next. Such would be the case if you wanted to download photos from it. It's not like a flash drive where files are right there in the root of the drive. It takes some kind of service/application that knows the camera and where to search for the photos.
- Collapse -
Thanks, that worked!
May 10, 2016 9:23AM PDT

Your specific link had some useful information, but it also pointed me to a site for troubleshooting USB problems. From there I was able to identify the exact USB root hub the camera was using and uninstall the driver. Once it reinstalled everything was back to normal. Thanks again.

- Collapse -
Sounds great
May 10, 2016 12:29PM PDT

Feedback of this type is always good

CNET Forums

Forum Info