Internet Service Providers forum

General discussion

(Cable) DNS Lookup Failures Result in ''Connect'' Boxes

Since we switched from ADSL to cable, whenever there is a DNS failure (whenever we type a URL that doesn't exist, in IE or Firefox), the ''Connect to <ISP-name>'' dialog box appears. This even though cable is of course an always-on connection and there actually is a connection at the time the dialog box appears.

It is as if one of the several 'elements' involved in the connection reports that there is no active connection, instead of reporting that the domain name is unreachable.

Previously (in ADSL or dial-up), we would have seen the usual ''DNS failure'' page in IE. This doesn't happen with our cable connection.

The connection to existing URLs works without problems. The problem is that these ''Connect'' dialog boxes become a nuisance if we have to close them every time we type an 'incorrect' URL.

Is there a solution to this problem?

In advance, thank you for your help.

Discussion is locked
You are posting a reply to: (Cable) DNS Lookup Failures Result in ''Connect'' Boxes
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: (Cable) DNS Lookup Failures Result in ''Connect'' Boxes
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Here's something you need to consider.

In reply to: (Cable) DNS Lookup Failures Result in ''Connect'' Boxes

The solution may be Operating System dependent. I read your post twice and didn't see it. You could be using a Macintosh for all I know. Try this:

Note: If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem.

Collapse -
(Cable) DNS Lookup Failures.. (Additional Information)

In reply to: (Cable) DNS Lookup Failures Result in ''Connect'' Boxes

We are using Windows XP Professional (Service Pack 2 installed). Internet Explorer (IE) and Firefox are the most current openly available versions.

Since we switched from ADSL to cable, whenever there is a DNS failure (whenever we type a URL that doesn't exist, in IE or Firefox), the ''Connect to <ISP-name>'' dialog box appears. This even though cable is of course an always-on connection and there actually is a connection at the time the dialog box appears.

It is as if one of the several 'elements' involved in the connection reports that there is no active connection, instead of reporting that the domain name is unreachable.

Previously (in ADSL or dial-up), we would have seen the usual ''DNS failure'' page in IE. This doesn't happen with our cable connection.

The connection to existing URLs works without problems. The problem is that these ''Connect'' dialog boxes become a nuisance if we have to close them every time we type an 'incorrect' URL.

Is there a solution to this problem?

In advance, thank you for your help.

Collapse -
Req. additional info...

In reply to: (Cable) DNS Lookup Failures.. (Additional Information)

Did your previous ADSL connection require PPPOE authentication for the connection? In less technical jargon, did your ISP give you a userID and a password that was necessary to connect? In WindowsXP, you would have enabled the PPPoE connection type in the neworking properties and then embedded this userID and password in there to automatically connect from then on. If so, you need to turn off the PPPoE stuff as it is not used for a cable modem connection.

dw

Collapse -
Re: Req. additional info...

In reply to: Req. additional info...

Thank you for your reply.

Yes, our ADSL connection does use PPPoE tunneling, authentication is required. Our cable connection doesn't use PPPoE, and is kept as an always-on network connection.

The problem is we still keep the ADSL connection as a back-up (as well as the dial-up alternative), and for this reason, we can't turn it off.

Is there anything we could do, other than deactivating RAS? Can't these two (three, with dial-up) systems coexist?

Collapse -
Nope, one or the other...

In reply to: Re: Req. additional info...

You can't have both PPPoE and straight ethernet connectivity simultaneously at the operating system level. Dialup, because it operates through a different adapter (the serial modem), can coexist with an ethernet connection. Your choices regarding the ADSL and cable connection:

1. If you are using WinXP's internal PPPoE client, learn how to turn it on and off. Turn it off when using the cable modem and turn it back on when using the ADSL connection. If you are using an earlier Windows operating system and a software client (such as WinPoet or Rassppoe), learn how to manage it during the startup using MSCONFIG so you can quickly reactivate it and reboot when you want it.

2. Solve the problem with external hardware. A standard broadband router can do either PPPoE or standard ethernet. The computer remains set to plain ol' ethernet regardless of what the router is programmed to do. You use your browser (Internet Explorer or your favorite substitute) to browse to the router's main configuration page and change the connection type. Then the router reboots itself.

My recommendation would be option 2, the hardware solution. It is easier to reconfigure, reboots faster, and as an added benefit, provides a layer of internet security through address translation.

dw

Collapse -
Thank you.

In reply to: Nope, one or the other...

I have tried your first option, and I have disabled the previous ADSL connection. As a short-term solution, I suppose it is acceptable.

In the future, we could change to a more adequate router, maybe one that also has NAT and the feature you mention.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.