General discussion

Built-in card reader will not open in Autoplay (Windows 7)

Hello. I have an HP Pavilion dv5 laptop with a built-in JMicron card reader. My OS is Windows 7 Home Premium 64-bit (which is an upgrade from Windows Vista 64-bit). When I used to put my camera card in the card reader, Autoplay would open and give me the option to choose the program to view the photos. However, Autoplay no longer opens when the card is put in the reader. (I believe this problem started before I upgraded to Windows 7 but am not certain.) I am able to download the photos manually by going through My Computer and clicking on the F: drive, which is the drive associated with the card reader. So, in other words, the card is not defective and the drive is being recognized, just not in Autoplay. Also, Autoplay does otherwise work with other items (e.g., if I plug in the camera with a USB cable). Any suggestions on how to have the Autoplay window pop back up when the card is first inserted?.

Discussion is locked

Follow
Reply to: Built-in card reader will not open in Autoplay (Windows 7)
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Built-in card reader will not open in Autoplay (Windows 7)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Try this

Start > Control Panel > Hardware and Sound > Autoplay

Check the box which says "use autoplay for all media and devices"

On the side of pictures choose 'ask me every time'.

If this does not work, it is possible to enable autoplay through the windows registry - but that is only advised if this does not work

BTW, autoplay is disabled in windows 7 by default, so there is no problem with your windows.

- Collapse -
Built-in card reader will not open in Autoplay (Windows 7)

Thank you.

Those settings you recommended are already in place. Any other thoughts?

- Collapse -
Through the registry

Then you could try enabling it through via the registry. Ok there are two ways you can do this, either use the registry hack (a registry key which modifies your registry) from here

http://www.howtogeek.com/howto/windows-vista/disable-autoplay-in-windows-vista/

OR you could do it manually, instructions here

http://www.mydigitallife.info/2008/01/14/autoplayautorun-not-working-or-missing-not-open-in-windows-vista/

BTW - there is one method explained in the first link to enable autoplay through the group policy; this only works on computers running the Ultimate version of windows, so that will not be useful
Hopefully this will solve your issue; post back if you are successful or if you have any further issue

- Collapse -
Built-in card reader will not open in Autoplay (Windows 7)

Thank you for this suggestion. However, I am reluctant to try this as Autoplay does work with all other items -- e.g., when I plug something in with a USB cable. In other words, it is only the JMicron card reader that will not open in Autoplay (although at one time it did). My suspicion is that it has something to do with the card reader driver, even though Windows says that the most current driver is installed.

CNET Forums

Forum Info