Windows 7 forum

Question

Both IE and Google Chrome work slowly

by bassinbill42 / December 1, 2015 9:43 PM PST

Hello I am using a Dell Desktop computer:
Windows 7 Home Premium 32 bit SP-1, Intel Core Duo CPU E7400
@2.80GHZ 4 GB RAM NVIDIA GeForce 310
I use CCleaner once a week to clean up my cache and my hard drive is defragged at least twice a week. I am using Avast Antivirus. My problem is a slow working browser. Both IE and Chrome are slow loading pages: It takes anywhere from 15 to 30 seconds to for the page to load. It did not take as long for pages to load when I used a previous desktop running Windows XP. Any advice?

Discussion is locked
You are posting a reply to: Both IE and Google Chrome work slowly
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Both IE and Google Chrome work slowly
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Same here.
by R. Proffitt Forum moderator / December 1, 2015 10:16 PM PST
Collapse -
My response
by bassinbill42 / December 2, 2015 6:09 AM PST
In reply to: Same here.

Thank you. I defragged the hard drive, did a disk clean up and will do what you mentioned about resetting the DNS.
Many thanks!
David

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.