Computer Newbies forum

General discussion

Boot up fail with "checking NVRAM"

by msi-770-c45 / April 3, 2011 12:58 AM PDT

My specification,

- MSI 770-C45, AM3 AMD 770 (motherboard)
- AMD Phenom II X4 810 (2.6 Ghz) AM3 boxed 512 Kb L2 cache (processor)
- Kingston 4 Gb DDR3 1333 (2 sticks of RAM)
- WDC WD16?..(hard drive)
- Hitachi-HDT-721?.(hard drive-1TB)
- A Open 400W peak Z400-08FC (power source)
- MSI N9400 GT (Vidieo card)
- Sound blaster X-Fi Xtremen Audio (sound card)
- OS is window XP home edition & SP3
- Cooler Master V8 (cooling unit)

Dear community,

I am currently having problem with my boot up sequence; it hang after it says "checking NVRAM". Afterward I get the Black Screen of ?(bloody annoyance), it's a black screen with only 1 white cursor.

History of my case:

I have been thinking about OverClocking my computer.(yes the big OC). I have downloaded articles on how to do it and was snooping around the BIOS to familiarize with all the setting and terms. I have played around with some setting like FSB, multiplier and voltage setting. Before you hit the panic button, I would like to say my "playing around" was not extreme I stay within the safety range of my computer (ie. Ram volt ~ 1.6, cpu volt ~1.25, FSB ~305 and multiplier ~9-9.5). so in theory I have not fried anything (I hope). I than downloaded the application "Prime95" and ran a test on my system. I have a quad core so Prime95 choose to do 4 test simultaneously, within 1-2 min a test fail. I though lets boot the "Fail-safe default" setting in the BIOS and check for stability there and as that was stable than I could use that as my "baseline"(from this baseline I could begin with my overclocking). After the "Fail-safe default" setting was safe in the BIOS and reboot the problem with "checking NVRAM" started.

I have gone online and searched around for solutions. Most of the forums concluded that the CMOS is corrupted and some suggested ways to resolve this problem.

Here is a list of what I have tried:
- removing the battery on the motherboard for a few hours, press in the power button on my computer and than reset the jumper according to my manual. With the power cord laying on the floor.(and variation of this method but no power in the power cable) - NO LUCK
- Some solution suggest that the NVRAM problem was caused by USB devices. I did have 2 USB devices connected to my computer(my wireless keyboard and mouse). So that was removed and the boot sequence retry - NO LUCK
- Other suggestion include checking the BIOS for the option "Quick Boot" is set to "enable" and it was. (I had hope that was the problem) - NO LUCK
- Another included loose IDE cable may be the cause, so checked all the IDE devices and cables (IDE cable sit in the DVD and HD).
- Two other suggestions which I could not try are:
1) disable extended memory test-how do I do that?

2) turn of NVRAM check in the BIOS-how do I do that?

I'll look into the last two suggestions further in my manual or online, but if there is some one out there that is familiar with my computer configuration or have a similar system with the know how please feel free to drop a line of 2 or more if needed. - thank you.

I hope this is not too much information to set on the forum. But if there is anyone out there in the community that can come up the suggestion(s) that I can try, please feel free post the suggestion(s) on the forum or contact me at

I sincerely thank all participants in this forum for your help.

Discussion is locked
You are posting a reply to: Boot up fail with "checking NVRAM"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Boot up fail with "checking NVRAM"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Just explaining
by Kees_B Forum moderator / April 3, 2011 1:14 AM PDT

The NVRAM is the non-volatile RAM in which the BIOS stores its settings. It's integrated on the motherboard. I think it's unlikely that anything like USB or IDE would cause it to fail.

Resetting the BIOS to fail-safe defaults, or clearing it via the jumper settings or by removing both the power and the backup battery for a while should be the things to do. If those don't help, a new motherboard might be the only solution.


Collapse -
Long shot.
by R. Proffitt Forum moderator / April 3, 2011 4:36 AM PDT

I ran into this years ago and it was "none of the above."

It turned out the owner had installed ALL the motherboard standoffs and one of them shorted out somewhere on the back side of the motherboard. What stumped and stopped them from fixing it was "it worked before." That is, they even were insisting we not pull the motherboard to look for this issue because "it worked before."

Try to remove ideas such as "it worked before" and consider starting over, on cardboard and the least amount of parts.

Collapse -
problem solved
by msi-770-c45 / April 3, 2011 6:05 AM PDT

First I would like to thank Kees_B and R.Proffitt for thier input.

But I've some how solved the problem. The solution may have been a combination of factors.

1) setting the jump switch to delete memory and leaving it there of a while(had dinner while the jumper sit in the delete position)than press the power button with NO power(no cr2032 battery on the motherboard and no power from the cable.)

2)I must admit, I did move my ram from slot 3&4 back to slot 1 & 2.(don't know if this had anything to do with this situation)

3)I did let the memory check ran longer in a previous attemps, maybe this resulted in the check running to completion before I shut the system down.

what ever the case maybe, my system is back and running on "fail-safe default" setting. I have also run the "prime95" application for the last 1 1/2 hours and nothing weird in the the result(which was expected). I hope these information will be useful to the next person who may ran into this situation.

Now of to the OC section of the forum. Happy thanks again.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.