Question

boot sequence

I bought a Powerspec G704 with an Asrock B450M Pro4 motherboard from Microcenter.

When I set the boot sequence in bios for the optical drive first and then the hard drive, it boots fine with a boot disk. When the boot disk is removed, instead of going to the hard drive it gives the error boot device not found. It boots from the hard drive fine when it is placed first in the sequence.

I talked to a tech from Microcenter who said that the motherboard was custom designed for Microcenter. Microcenter wanted the auto seek function for boot devices disabled in the bios. The tech agreed it was strange and didn't know why that would be done.

I love the computer and it's not a big deal to go to the bios or boot menu to change the boot order. I guess there's no way to enable that function?

Discussion is locked

Answer
Follow
Reply to: boot sequence
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: boot sequence
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
the only way

is to reflash the BIOS with one for that motherboard which Microcenter hasn't tampered with.

- Collapse -
That's what I thought

I asked the tech if I could do that but he said don't do it on your own. He said bring it in and let Microsoft do it or you'll lose your Win 10 license.

I keep everything backed up with a Terabyte image and restored to this computer using Win 10 from the previous computer with no problem. So I don't think that would be an issue when flashing the bios myself right?

- Collapse -
It's done by people all the time

Post was last edited on September 9, 2019 2:08 PM PDT

- Collapse -
I meant

let Microcenter do it.

- Collapse -
I flashed the bios

to the latest version 3.60. When the sequence was changed to optical drive first and then hard drive it still doesn't go to the hard drive. Maybe there's something hardwired to the motherboard that's preventing it from doing auto seek?

- Collapse -
The problem is that special BIOS

Unless there's a BIOS for same Asrock from some other place that does the 'seek", I don't see much you can do about it.

- Collapse -
What's strange

is why would they give the option for second and third boot device, etc. if it doesn't work.

- Collapse -
badly written code?

I have no idea why they'd leave it.

- Collapse -
Answer
Try a test.

Set the BIOS to boot the CD/DVD first and see it fail.

OK, now power down and unplug the SATA date cable from the CD/DVD drive.

TEST!

What happens? I wonder since I think I've seen this before and to fix it we swapped the DVDRW for another model. I could be wrong here but it's a rare issue with the steep decline of ODDs.

SECOND ISSUE I've seen. The boot HDD was not on the lowest numbered SATA port.

Post was last edited on September 10, 2019 8:42 AM PDT

- Collapse -
I'll try that.

The boot drive is ssd sata 0, then the data drive is sata 1, and then the optical drive. Do you think if the optical drive and data drive swapped ports that would do anything?

If it works with the optical drive unplugged should I return the optical drive and try another?

- Collapse -
Sounds correct to me.

As to the ODD test, if you can share the make and model I might search to see if anyone is noting this one.

- Collapse -
It's an LG

hl-dt st dvdram gh24nsb0. I'll try looking in the web also to see if I find anything.

- Collapse -
Consider checking the ODD's firmware.
- Collapse -
Thanks for eveyones help

The main purpose of this was to try fast boot from bios. If anything went wrong from Windows I could boot a rescue disk without having to reset the cmos battery.

It boots now from power on to desktop from an ssd drive in 25 seconds. The 17 or 18 seconds I would save is not a big deal. Thanks again.

- Collapse -
Let me share.

I haven't booted a DVD this year for home or office. Moved to cheap USB sticks over a year ago. Not going back.

- Collapse -
I'm curious

when you look at the SATA ports on the motherboard, does one look different than the others, maybe a triangle by it, or a different color than the others? Is the HDD plugged into that one? If so, move the HDD cable to a different SATA and see if that continues. I ran across this bit of info in a linux forum, and the claim there is the designated SATA had some special added function, maybe related to UEFI and boot security.

- Collapse -
The sata connections

on the motherboard are all black.

I previously gave wrong information on how the connections are labeled. They are Sata 3_1,2 and Sata 3A_1,2,3, 4. The ssd boot drive is connected to sata 3_1. The optical drive is on sata3_2. The data drive is on sata3A_1.

- Collapse -
Just ideas.
- Collapse -
Still no change.

The fact that the bios update did nothing seems to indicate something is hardwired into the motherboard that is preventing autoseek of the boot drive.

I tried doing a support ticket with Asrock which requires a serial number that is supposed to be on a sticker on the board. I couldn't see any sticker on the board, probably because it's not a stock board but custom made for Powerspeck and Microcenter. I put this isssue on the Asrock forum but no answer after 2 weeks.

The only solution would probably be replacing the motherboard with a stock board which I'm not going to do.

- Collapse -
Re: boot sequence

Does the optical drive with the disc appear in the F11 (or F8?) boot menu? If it does, it's easier than changing the standard boot sequence, because it's a choice for the current boot only.

See https://www.asrock.com/support/faq.asp?id=27 . On my MSI-motherboards it mean pressing F11 repeatedly early in the boot process, until it get it and says it's going to boot into the boot menu. I don't know the details of the ASRock implementation.

Post was last edited on September 16, 2019 6:03 AM PDT

CNET Forums

Forum Info