Samsung forum

General discussion

Bluray unit network connectivity frustrations

by iPreparator / August 5, 2009 2:20 AM PDT

I just purchased a BP1600 Bluray device to compliment my LN40A550 40? LCD television. While Bluray and the evening news look killer, really absolutely beautiful (for example, our dog thought the dogs on tv were real), like many users I?m having a heckuva time ?connecting? the Bluray to my network to view Netflix content. I have attempted with both the wireless dongle and an Ethernet line, coming from my Dynex G router and Time Warner Road Runner modem. I put connecting in quotes because I am able to download firmware updates, and my Bluray has a designated MAC address and IP address that are displayed both onscreen during connection testing and are recognized by my router control pane, so obviously I am connected to my network. However, the network connection test in Setup fails at Gateway Ping every time, and attempts to connect to Netflix are also frustrated by the ?your network has issues, dude? error. Additionally, and this seems common to many of the 20 or 30 or so complaints I?ve seen online, my info isn?t being picked up when DCHP is on, and has to be entered manually.

So far, I?ve gone back and forth between cable and wireless connections, most of the time my network shows up as an access point, and with my WEP wireless security disabled would connect to the firmware update, but when enabled, would refuse the WEP password. Two other computers were on the network at various times, and I was able to achieve a laptop connection with the same Ethernet cable that went into the Bluray. So, my LAN is fine, but my next step will probably be to chuck the Dynex router and see if another brand works, because this is a fix for some people. I have not been prompted for any other passwords, like for instance, passwords that may be on cable modem. Hopefully there is advice out there that will solve the problem before I buy anything else, I'm beginning to feel ridiculous spending near $400 to watch streaming movies when there is a perfectly serviceable video store right down the street.

Thanks in advance,

Matt

Discussion is locked
You are posting a reply to: Bluray unit network connectivity frustrations
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Bluray unit network connectivity frustrations
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Over in the Cnet Networking forum
by R. Proffitt Forum moderator / August 5, 2009 2:32 AM PDT

We slam WEP, MAC address filtering as insecure, error prone and just "trouble for most."

Instead, disable MAC filters on the router, broadcast a SIMPLE SSID and use WPA for security. This simpler setup will head off most network issues without taxing most users or routers.

Hope this helps and for more details read the Cnet Networking forum sticky post.
Bob

Collapse -
Whoops....
by iPreparator / August 5, 2009 3:02 AM PDT

Yes, it is currently setup with WPA, my mistake. I don't think that the MAC filter is on, but I'm not home to check at the moment. MAC addresses would still exist without the filtering, correct?

Thanks for the comment

Collapse -
Whoops....
by Samsung_HD_Tech Samsung staff / August 5, 2009 4:26 AM PDT
In reply to: Whoops....

iPreparator,

As noted above, an SSID without "odd" characters or spaces is recommended. Keep us posted.

--HDTech

Collapse -
Ok, it mostly works....
by iPreparator / August 5, 2009 9:16 AM PDT
In reply to: Whoops....

Connection is now excellent, turning off the firewall on the dynex router allows the gateway ping through, though that is a less than ideal solution. I'm guessing it's pretty much entirely a router issue?


Thanks for the input

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.