HolidayBuyer's Guide

Samsung forum

General discussion

Blu Ray movies

by Mikicinski / November 1, 2010 6:30 AM PDT

I just purchased a PN58C8000 and 3D Blu Ray. The movies on Blu Ray look awful, they look like soap operas much too clean and crisp the flesh colours are not that great. Anything cartoon is OK but movies look like they have been filmed on video and not film. Is there any way I can change this other than hooking up my old DVD player to look more like a rich movie filmed in film other as opposed to glossy soap opera made on video? I tried changing it to 1080P with 24 HZ instead of 60 HZ but it still looked awful. TV looks fabulous but Blu Ray movies and DVDs played in 2D look cheap.

Discussion is locked
You are posting a reply to: Blu Ray movies
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Blu Ray movies
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Blu Ray movies
by Samsung_HD_Tech Samsung staff / November 1, 2010 8:28 AM PDT
In reply to: Blu Ray movies

Mikicinski,

Try adjusting the Motion Judder Control in the Picture Options menu.

Menu > Picture > Picture Options > Motion Judder Canceller.

Also, in the Picture Options menu, there is a Film Mode and Cinema Smooth option, however a 1080p (24Hz) signal must be used to adjust the Cinema Smooth function.

Keep me posted on which one seems to work best for you.

--HDTech

Collapse -
Thank you
by Mikicinski / November 2, 2010 5:54 AM PDT
In reply to: Blu Ray movies

Thank you for the idea, I have the motion judder set to ooff, I did not see a Cinema Smooth option or film mode on the TV, I set up the settings as per calibration on plasmatvbuyingguide.com Should I turn BFI auto off on the Blu Ray and set the 1080P 24HZ manually

Collapse -
Thank you
by Samsung_HD_Tech Samsung staff / November 3, 2010 9:19 AM PDT
In reply to: Thank you

Mikicinski,

You're welcome.

Films are mastered to Blu-Ray at 24Hz typically, so that would be ideal.

--HDTech

Collapse -
Same for me - solution
by HarveyLA / November 19, 2010 1:56 PM PST
In reply to: Blu Ray movies

Had the same issue. Turned off motion judder canceller. Solved.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.