PC Hardware forum

General discussion

Blasted NT 4.0!!! Device removal issues...

OK, I recently installed a new Sony 11000 backup tape in my old NT server (dual PPro 200, 512MB Ram, SCSI) and, after asking advice, removed the old devices (AIWA drive & TEKRAM adapter) & drivers (or so I thought). I have not been able to get a backup since. Event log:

"The description for Event ID [15] in source (sonysdx-VRTS) could not be found. It contains the following insertion string(s): \Device\Tape0"

I ran the Veritas diagnostic and found:

"DEVICE NAME: \\.\Tape0
Primary Inquiry "AIWA GD-8000 0119"
Serial Number "AIWA GD-8000 <1000:0002:0000:0000:0000>
Device Flags SCSI SN(DEFAULT)
Device State 3, Online
Device IDs 1002
Device Name AIWA 1"

Needless to say, this is the device I removed (or so I thought). This is exactly what I feared before removal. Any ideas? Thanks.

Tony

Discussion is locked
You are posting a reply to: Blasted NT 4.0!!! Device removal issues...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Blasted NT 4.0!!! Device removal issues...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
driver cleaner might help

In reply to: Blasted NT 4.0!!! Device removal issues...

and then installing your new back-up device

but i'm not so hot when it comes to back-up devices such as these
but driver cleaner should wipe out the old drivers

Collapse -
Remove it in the registry.

In reply to: Blasted NT 4.0!!! Device removal issues...

"HKEY_LOCAL_MACHINE

This key contains configuration information particular to the computer. This information is stored in the systemroot\system32\config directory as persistent operating system files, with the exception of the volatile hardware key.

The information gleaned from this configuration data is used by applications, device drivers, and the WindowsNT 4 operating system. The latter usage determines what system configuration data to use, without respect to the user currently logged on. For this reason the HKEY_LOCAL_MACHINE regsitry key is of specific importance to administrators who want to support and troubleshoot NT 4.

HKEY_LOCAL_MACHINE is probably the most important key in the registry and it contains five subkeys:

* Hardware: Database that describes the physical hardware in the computer, the way device drivers use that hardware, and mappings and related data that link kernel-mode drivers with various user-mode code. All data in this sub-tree is re-created everytime the system is started"

NT 4 is not user friendly. It never was intended to be either. The expectations of that time some decades ago (if we includer NT 3.0) was that the owner would take classes and own the Server Resource Kits. Some will not accept this " 'tude " and flame when I note the view of those days. But it's worth knowing about when you take a dive into the deep end of the NT 4.0 pool.

If this was my machine, I'd boot safe mode and search the registry for the old hardware to be removed. And of course I'd be ready for a full reinstall and restore from backup.

Bob

Collapse -
Oops. Forgot to attribute the quoted material. Link...

In reply to: Remove it in the registry.

Collapse -
What if I didn't want to fiddle with the registry?

In reply to: Remove it in the registry.

How about unistalling/reinstalling Veritas 9.1? I also noticed the TEKRAM device in the Veritas disgnostic. I installed this software with both devices in place, what if I re-installed now? Or, replace the removed components and reinstall Veritas?

I'm not ready for a possible disaster recovery, the software disks (not Veritas) are locked in a fire safe w/ the key holder on vacation. I have backup copies at home, but can't get there right now. Thanks for the prompt responses.

Tony

Collapse -
Looked in the registry. Not there.

In reply to: What if I didn't want to fiddle with the registry?

No AIWA GD-8000, no TRM (Tekram). Maybe it's just in Veritas?

Collapse -
You would have to ask Veritas why this is so.

In reply to: Looked in the registry. Not there.

I don't have a NT 4.0 system to play on anymore. We dumped them 2 or more years ago over the security issues.

Bob

Collapse -
Troubleshooting Log

In reply to: Blasted NT 4.0!!! Device removal issues...

Progress to date:

Removed Veritas Driver
Installed Sony utility, drive checks out A-OK
Installed OEM driver
Tried running NTBackup, 200MB in, error message:

"Tape Device reported an error on a request to write data to tape. Error reported: Hardware Failure"

Removed Sony OEM Driver
Reinstalled Veritas Driver
Replaced SCSI cable
Updated firmware
Ran Sony diagnostics
Passed all tests
Wrote & Read 1 GB Data OK
Configured "New Backup Job" in Veritas
Ran "Test Run"
Job failed.

Should I just reinstall the old devices?

Collapse -
Update on situation, advice, Bob?

In reply to: Troubleshooting Log

To eliminate one possiblilty, I went to the office & got the drive and my spare Adaptec 2940uw PCI card, hooked it up, XP Pro detected & installed drivers for both. Ran a 2-hour 15GB backup w/ Windows Backup, flawless.

What about installing that same rig, the 2940UW card & drive to the NT4.0 server? I'm positive the NT SCSI driver's there, the native SCSI of the PR440FX mainboard is the Adaptec 2940. Might this create any conflicts?

We do now know the drive is in perfect working condition, I await further guidance.

Tony

Collapse -
WOW. New info.

In reply to: Update on situation, advice, Bob?

I don't recall you having an UW card. The ULTRA SCSI settings can stress some owners since you get to go into the Adaptec BIOS and pull back the SCSI speeds on what devices error out when they are run at ultra speeds.

One of the endearing qualities of SCSI.

-> There should be no conflicts.

Bob

Collapse -
No holiday when you can't get a backup...

In reply to: WOW. New info.

...took the stuff in to the office today, plugged in the spare controller and off we went. Backup is back up. Thanks for all the help.

Tony

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.