General discussion

Blank Screen After Startup Beep.. Any Info Appreciated

My cpu screen goes blank after the startup beep. I've unplugged, then plugged everything back in and tried control f8 + f10. Unfortunately I'm not sure what to do at this point.

Discussion is locked

Follow
Reply to: Blank Screen After Startup Beep.. Any Info Appreciated
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Blank Screen After Startup Beep.. Any Info Appreciated
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Have the machine repaired ...

Most likely a new motherboard is needed. A good tech will be able to tell you what needs to be done, and what it costs.

Kees

- Collapse -
Have you tried a different

video card???

Is it just the normal single beep?? Normally a bad video will create multiple beeps.

- Collapse -
(NT) (NT) Well there's a normal beep.. so I don't think it's that
- Collapse -
moniter

Wonder if the monitor is ok.

CNET Forums

Forum Info