Try booting into Safe Mode, (instructions here), and select the first option. See if Explorer works in Safe Mode.

If not, then also in the Safe Mode list of options, try the "Last known good configuration" option.

See if either of those work.

Mark