General discussion

Black curtain of death - anyone able to tell why it happens?

Here's the report that is generated upon reboot.

Interval Since Last Panic Report: 259204 sec
Panics Since Last Report: 1
Anonymous UUID: 63F6A3CE-34A4-46F5-AED5-B64E81942C27

Mon Apr 19 13:08:46 2010
panic(cpu 1 caller 0x2347eb): "zalloc: \"buf.8192\" (4886 elements) retry fail 3, kfree_nop_count: 0"@/SourceCache/xnu/xnu-1504.3.12/osfmk/kern/zalloc.c:981
Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
0x5c3b3208 : 0x21b449 (0x5ce420 0x5c3b323c 0x2238a5 0x0)
0x5c3b3258 : 0x2347eb (0x586e2c 0x593eb8 0x1316 0x3)
0x5c3b32f8 : 0x234e37 (0x1df3d4c 0x1 0x0 0x5c3b3354)
0x5c3b3318 : 0x2caa00 (0x1df3d4c 0x0 0x5c3b3348 0x3)
0x5c3b3358 : 0x2cb791 (0x57158490 0x2000 0x5c3b33d8 0x485c67)
0x5c3b33f8 : 0x2cba1e (0x730fce8 0x2bce 0x0 0x2000)
0x5c3b3438 : 0x2cbadb (0x2000 0x0 0x0 0x10)
0x5c3b3458 : 0x40f709 (0x730fce8 0x2bce 0x0 0x2000)
0x5c3b34c8 : 0x446073 (0x730fce8 0x2bce 0x0 0x5c3b352c)
0x5c3b34e8 : 0x447fb8 (0x7308804 0x2bce 0x0 0x5c3b352c)
0x5c3b3568 : 0x44487f (0x7308804 0x366f8420 0x5c3b3594 0x5c3b3634)
0x5c3b3658 : 0x441f88 (0x731ae30 0x366f8404 0x5c3b370c 0x5c3b371e)
0x5c3b3738 : 0x2f7d72 (0x5c3b3750 0x722b859c 0xffffffff 0xffffffff)
0x5c3b3788 : 0x2f4f1b (0xf219e10 0x59dbe5 0x0 0x5c3b385Cool
0x5c3b37d8 : 0x31031c (0xf219e10 0x59dbe5 0x0 0x5c3b385Cool
0x5c3b3878 : 0x310e48 (0x1 0x5c3b38c8 0x70f00b0 0x0)
0x5c3b39c8 : 0x43cb8f (0xf219e10 0x13008264 0x5c3b3a18 0x41a9c7)
0x5c3b39f8 : 0x43dda8 (0xe7389c8 0x0 0xc7a28 0x1)
0x5c3b3a98 : 0x2f8b2c (0x5c3b3abc 0x3 0x5c3b3ae8 0x462e54)
0x5c3b3ae8 : 0x2fa482 (0xf219e10 0x5c3b3c94 0xbd4c5d4 0xbd4c5d4)
0x5c3b3b38 : 0x2c5f8a (0xf219e10 0x5c3b3c94 0xbd4c5d4 0xbd4c5d4)
0x5c3b3de8 : 0x2c767c (0xbd4c5d4 0xffffffff 0x5c3b3f38 0x258c9f)
0x5c3b3f78 : 0x4ecbb9 (0x4103cd20 0x1397e408 0xbd4c514 0x1)
0x5c3b3fc8 : 0x29f43d (0x1397e404 0x0 0x10 0x0)

BSD process name corresponding to current thread: Mail

Mac OS version:

Kernel version:
Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09 PST 2010; root:xnu-1504.3.12~1/RELEASE_I386
System model name: MacBookPro3,1 (Mac-F42388CCool

System uptime in nanoseconds: 260021827162765
vm objects:8794604
vm object hash entri:1064880
kernel map entries:5578716
vm pages:43975140
ipc ports:1564864
HFS node:14367100
HFS fork:5592384
ubc_info zone:1876800
Kernel Stacks:1867776
unloaded kexts: 1.2.0a3 (addr 0x553a2000, size 0x8192) - last unloaded 246104647535296
loaded kexts:
com.usboverdrive.driver.hid 3.0.1
com.parallels.kext.prl_netbridge 4.0 3522.205912
com.parallels.kext.prl_vnic 4.0 3522.205912
com.Cycling74.driver.Soundflower 1.3.1
com.parallels.kext.prl_hypervisor 4.0 3522.205912
com.parallels.kext.prl_hid_hook 4.0 3522.205912
com.parallels.kext.prl_usb_connect 4.0 3522.205912
at.obdev.nke.LittleSnitch 2.2.05 1.5.0 9.7 5.0 1.9.3d0 2.1.0 1.4 3.3.2 7.0.0 6.1.0 1.8.4fc3 1.1.2 3.0.0d4 3.1.14b1 422.19.10 1.5.0d1 4.1.1d0 1.4.11 170.0.16 19 1.8.1b1 1.8.1b1 1.8.1b1 303 2.6.2 31 1.0.0d1 1.3.0 1.6.1 2.1.1 2.5.1 4.5.7 3.9.6 3.9.6 3.9.6 1.3.1 1.5 160.0.0 1.3.2 1.5 1.3.2 1.4 104.3.0 0 0 2.1.11 104.3.0 1.2.0a3 - last loaded 247560286737744 2.6.1 2.6.2 2.3.1f4 17 10 14 10 10 20 74.0 2.3.1f4 10.0.3 1.8.4fc3 1.7.6fc2 1.3 6.1.0 6.1.0 2.0.3 310.6 1.9 1.8.4fc3 1.8.4fc3 4.1.1d0 2.1 2.1 3.0.1d2 41 2.3.1f4 2.3.1f4 2.3.1f4 1.2.0a3 3.9.6 3.9.6 3.9.0 2.6.2 1.6 1.6 1.6 402.1 2.5.1 2.6.2 2.0.3 2.5.1 4.2.6 3.9.6 3.9.6 1.3.0 1.6.2 1.1 6 1.0.0d1 283 1.6 1.3.2 2.6 1.3.0
Model: MacBookPro3,1, BootROM MBP31.0070.B07, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.18f5
Graphics: NVIDIA GeForce 8600M GT, GeForce 8600M GT, PCIe, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), Atheros 5416:
Bluetooth: Version 2.3.1f4, 2 service, 19 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
PCI Card: pci168c,24, sppci_othernetwork, PCI Slot 5
Serial ATA Device: FUJITSU MHY2250BH, 232.89 GB
Parallel ATA Device: MATSHITADVD-R UJ-85J
USB Device: Keyboard Hub, 0x05ac (Apple Inc.), 0x1006, 0xfa200000
USB Device: Apple Keyboard, 0x05ac (Apple Inc.), 0x0220, 0xfa220000
USB Device: My Book, 0x1058 (Western Digital Technologies, Inc.), 0x1100, 0xfa400000
USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8502, 0xfd400000
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8205, 0x1a100000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x021a, 0x5d200000
USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x5d100000

Discussion is locked
Reply to: Black curtain of death - anyone able to tell why it happens?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Black curtain of death - anyone able to tell why it happens?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
I'm guessing

I'm guessing by "black curtain of death" you mean a kernel panic error message. The screen takes on a black tint, and there's white text in about three different languages telling you that you need to reboot.

If so, that's USUALLY a hardware issue. Could be bad RAM, failing hard drive, or a bad logic board.

Go to Apple's website and download the appropriate Apple Service Diagnostic (ASD) for your system, and either burn it to a DVD (it might need a dual layer disc) or get an external drive to install it on. There are instructions inside the DMG file on how to do this. This will perform a number of diagnostics on your system and should either pinpoint or rule out various possibilities.

Also keep in mind that on recent systems there's two sets of ASD test programs. One is EFI the other OS. The EFI version tests a lot of the low level hardware, while the OS version does higher level tests. Run them both.

- Collapse -
Kernel panic

I'm guessing it has something to do with RAM then, because an Apple center replaced the logic board and HD a few months ago. This issue only happens after the computer's up and running for a couple days straight. I'm looking on the Apple site for the ASD tool, but no luck yet.

Based on the report I posted, no way of telling what's causing these kernel panics?

- Collapse -

No, but you can also just put your OS X install disc into the drive, and boot the system holding down the "D" key. This will load a lesser version of ASD known as Apple Hardware Test (AHT) that should include some RAM checks. It's also not big on the visual feedback that it's doing anything, so just try to be patient. It'll probably take around 30-45 minutes.

- Collapse -
Do you have a link for the ASD's?

I see you have advised people to download them but I cannot find a link to them.

Are you sure that this software is available to the public and not just to those employed by a AASP?


- Collapse -
I swear

I swear I found a place to download these once upon a time that wasn't the service source site. Maybe they removed them, or put them behind a GSX wall.

Looks like it must've been locked up behind the GSX wall, and you have to either be a certified tech, or at least enrolled in the training program. So, my apologies for the wasted time. You can find these on torrent sites, you just need to know which version to get. I'm not saying you should download it from a torrent site, merely pointing out that you can. What you decide to do is your choice. You also still have AHT which is part of every Mac OS X install disc. Just hold down "D" when booting. Not as comprehensive, but it should tell you if there's anything obvious wrong.

If your MacBook Pro is a late 2008 to mid-2009 model you want ASD 3S132, and early 2008 is 3S123. If it's one of the brand new ones, which seems unlikely, there is no ASD yet. If you have some other model, let me know, I can look up the version for you. Since they're about 3GB or so, even if it weren't legally dubious, I wouldn't offer to send it to you.

I swear they used to have these up for general download. Again, my apologies for the wasted time. Can't imagine why they would keep those locked up. We all know 99% of people would never download them unless they had a specific reason to, and probably 99% of the 1% who did download it, wouldn't really know how to interpret the results. But I guess there's no real point in trying to figure out Apple's motives. Odds are, someone web lacky might have just screwed up the server permissions by complete accident, and everyone else just assumed there was a reason for it and never questioned it. The original person moves on to another job, but their legacy lives on. Sad thing is, how often that sort of thing actually happens.

Anyway, give AHT a spin, see if that turns up anything. Just be sure to tick the extended tests box. Let it run overnight, or when you go to lunch.

- Collapse -
here is the link
- Collapse -
Same issue

I was having the same issue when I upgraded from 10.5. I would tend to get the 'kernel panic' about once a week. Sometime the system would not awake from sleep or the screen saver, ie beachball. Other times the screen would come back on with the kernel panic screen sitting there. I have even had it happen a few minutes after turning it on. It seemed that Safari was causing the issues.

The Apple experts checked out the system and found nothing wrong with it, reset PRAM, ran a quick diagnostic. It even hung on the blue screen for 5 minutes while rebooting. They suggested using a different logon thinking that maybe it was the software. Nope happened at least as often as before.

I fixed it by going back to 10.5 and have had zero problems. That tells me that it wasn't hardware related and that it was the OS. This makes me leery to upgrade again.

2008 iMac 3.06 core duo with 4gb ram

- Collapse -
"This issue only happens after the computer's up and running

"This issue only happens after the computer's up and running for a couple days straight. I'm looking on the Apple site for the ASD tool, but no luck yet."

Many machines can't do that. Did you try a cooling pad or pointing a fan at this machine? I can't guess why it's running for days, do tell.

- Collapse -

Haven't tried a cooling pad or anything of the sort.

It's up and running for days as we edit during the day and at night leave it to upload dailies to clients overseas.

- Collapse -
That sounds like a job for...

A server. Most machines made for human use tend to fail at 24x7 operation. You can improve the odds by simply pointing a fan at the machine.

CNET Forums

Forum Info