Desktops forum

General discussion

BIOS doesnt see HD's but can access with boot disk. HD data missing?

by Ghost Rider / April 8, 2004 2:32 AM PDT

I have a Dell XPS1000Br P3-1000 with 512MB, Two 40GB HD's DVD player and CDRW. Running Windows XP (FAT32). This has been the configuration for a few years and had operated fin with no problems, Until now. Last night when booting up my PC I received a Invalid Disk Error. When I checked the BIOS it did not recognize my HD?s however it did see both the DVD and CDRW drive. On a whim I rebooted with the boot disk and was able to see and explore both drives that the BIOS said where not there.
Data wise things are even stranger. The directory tree for the slave is intact and all data looks good. The primary HD is all screwed up. Scan disk recognizes the full drive volume, 40GB. However when I do a DIR listing the file structure is gone and only two empty directories exist, and no files. According to DOS there is only 2.5GB available on the drive, so it looks like my data is still there however it has been Hidden or encrypted in some way.

Both HD?s are connected to a Promise UTLRA 100 PCI card, and the CD drives are connected to the
Motherboards IDE controller. When I plug the HD?s into the Motherboard BIOS sees the drives, however
The data is still gone.

Any Ideas on what is going on and how to fix it?

Why doesn?t the BIOS see the HD?s attached to the ATA card, when I can navigate the drives from a Boot disk.

What happened to my Data?

Thanks.

Discussion is locked
You are posting a reply to: BIOS doesnt see HD's but can access with boot disk. HD data missing?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: BIOS doesnt see HD's but can access with boot disk. HD data missing?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?