Computer Help forum

Question

BIOS can't see HDD

Hi.
The story: I ran out of storage on my Windows partition so i decided to move 30GB from my Data partition to my Windows partition using a " separate program". It said it need to reboot because the partition is being used and after the restart my PC booted straight into the BIOS. The Boot category is empty.

The problem: I tried changing all kinds of settings in the bios but no result. So i decided to install a fresh copy of windows. So i did without any problems. The windows installation went perfect (all my partitions were detected. I even made a new bigger partition for windows). Setup said it's all done and rebooted. But after that it went back straight to the BIOS and HDD was not a boot option again (HDD was not detected, only the USB..). I ran the windows setup again and the changes i made are still there. (New partitions and a fresh installed Windows)

Please help! :??:

Discussion is locked
You are posting a reply to: BIOS can't see HDD
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: BIOS can't see HDD
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Reinstall Location

In reply to: BIOS can't see HDD

Did you re-install from the mfg drive i.e. "reinstall to factory default" or something like that?
Most brand named systems use a BIOS based boot to partition for the factory Windows install files with drivers and apps. To enable the install partition to launch they either make a custom BIOS or custom master boot record or master partition table, both or all three since BIOS customization extensions can be made from the boot sector with most machines.
Over time it has proven disastrous for security software to utilize this method across platforms.
If your partitioning software changed the custom master boot record or boot sector, the BIOS wouldn't like it.
If you didn't do anything after the reinstall and it just went fiiith, I'd say you caught a bad cold or a drive sector dropped out which would result in the same if the BIOS is expecting a key code added via the boot sector.

All Answers

Collapse -
Answer
what motherboard model?

In reply to: BIOS can't see HDD

Or computer model? Is it UEFI type BIOS?

Collapse -
Asus

In reply to: what motherboard model?

Asus X551MA 60NB0480-MB1501 Motherboard

Collapse -
(NT) UEFI

In reply to: what motherboard model?

Collapse -
Forget UEFI.

In reply to: UEFI

Collapse -
Need driver files

In reply to: UEFI

Your manual or handbook
http://www.asus.com/Notebooks_Ultrabooks/X551MA/HelpDesk_Manual/

Your Downloads by Operating System used.
http://www.asus.com/Notebooks_Ultrabooks/X551MA/HelpDesk_Download/

You only loaded Windows. This means some drivers used are generic only. You need to get the specific driver files for your particular motherboard. Download them and install, then reboot.

Slovenian
Vi naložen le Windows. To pomeni, da nekateri vozniki so samo generično. Boste morali, da bi dobili posebne datoteke gonilnika za vaš motherboard. Jih prenesti in namestiti, nato pa reboot.

Russian
Вы загружается только Windows. Это означает, что некоторые используемые драйвера только общий характер. Вы должны получить конкретные файлы драйверов для вашего материнской платы. Скачать и установить их, а затем перезагрузить.

Collapse -
This one looks like it needs Apps too.

In reply to: Need driver files

Apps to turn on/off WiFi, control volume, etc. Frankly I'd get back to the stock OS. Or Linux.

Collapse -
Answer
CSM

In reply to: BIOS can't see HDD

Switching to CSM does nothing. Sad

Collapse -
Answer
Wow, this one really got me PUZZLED.

In reply to: BIOS can't see HDD

Alright guys...do UEFI really do strange things like that? How the hick did OP managed to installed an OS to the Hdd. when the bios can't see it. Something has to wrong with the bios setup. Not that I am any kind of expert on this thing called UEFI, hehe.

Collapse -
See

In reply to: Wow, this one really got me PUZZLED.

"The Boot category is empty" is not exactly the same as the bios didn't see it. UEFI is strange like that as you can corrupt an UEFI boot drive so it vanishes from the boot category.

The BIOS can still list the drive but most folk won't write it all here.

Collapse -
True, there like 2-3 maybe more places

In reply to: See

The BIOS recognizes as UEFI or Legacy CSM, it recognizes as a HDD, then there's a place to list drives that are bootable, and then the boot order might be in a different place and finally, go to another UEFI motherboard and the steps to do it are different. I thought of buying one to play around in it, but then realizing the variety of them, different per maker, it didn't make much sense.

Collapse -
I have deal with UEFI before but...

In reply to: True, there like 2-3 maybe more places

not something strange (unfamiliar) like this. I'll mark that down in my book.

Collapse -
So it's somewhere.

In reply to: See

We just have to find it.

Collapse -
Answer
USB is bootable

In reply to: BIOS can't see HDD

A plugged Flash-Drive gets instantly listed in the BIOS and is bootable. Not a single problem installing OS. I guess the connection between HDD and BIOS (or maybe bootmanager) got destroyed somehow and I need a way to restore it...

Collapse -
Most USB bootable drives are not UEFI formatted.

In reply to: USB is bootable

There are so many articles on the web but I can't condense it here. It sounds like the HDD was in a secure boot format and is not, or the BIOS is not in UEFI so reset the BIOS to defaults and try again.

Collapse -
reset

In reply to: Most USB bootable drives are not UEFI formatted.

I did that like 5 times doesn't do anything..

Collapse -
That will not correct a UEFI formatted HDD that is lost.

In reply to: reset

But after all this, maybe it's a product defect. You've followed their advice and it's busted. Time to make a warranty claim.

Collapse -
tough

My master thesis is on that hard drive so ill do whatever it takes to save it Happy

Collapse -
It's still there then

In reply to: tough

Put the drive in another computer that boots, or in a drive case and plug to USB on a computer that boots and you can get all your files for the thesis off it.

Collapse -
Answer
Damn

In reply to: BIOS can't see HDD

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Enter to win* a free holiday tech gift!

CNET's giving five lucky winners the gift of their choice valued up to $250!