Computer Newbies forum

General discussion

Bios can't see addition slave hdd

Hi Guys (Network security now all set up OK)
New project: Installed an additional HDD for storage only. Its a Maxtor 52049H3. 20GB 7200 Checked out the installation guides & data on their site (Brilliant site) www.maxtor.com Downloaded their installation floppy but cannot get the Win Me computer to see the new HDD. Bios screen says Pri Slave HDD error.

Auto detect / Standard Cmos. says
Pri Slave Cyln,Head,Wp com Sec. All 0
LBA mode OFF, BLK mode OFF, P10 mode 0, 32 Bit mode ON.
I tried putting in the various settings Cyln 39704 : 16 : 63. etc but no good. On comming out of the bios there is a further message Cmos/GPNV checksum Bad.
Please help. Have not tried Fdisk or any other settings. Apart from not seeing the new HDD the Pc is running OK Please help

Discussion is locked
You are posting a reply to: Bios can't see addition slave hdd
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Bios can't see addition slave hdd
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Do you have the jumpers set properly on the drive???

In reply to: Bios can't see addition slave hdd

Don't waste time in the BIOS setting the parameters, simply set it to AUTO, and LBA further over to the right if it lets you. That should be sufficient for tthe BIOS. The drive simply gets redetected during each boot. Get rid of the parameters.

Are you using the 80 conductor cable??? If so why not use CS [cable select jumpering for both drives]. Then the Slave MUST be connected to the middle connector.

What type of drive is the boot drive, if it is a WD then jumpering is likely the problem, if so, using CS for both drives will fix that.

Collapse -
(NT) Hi Ray Need to go a little slower please.

In reply to: Do you have the jumpers set properly on the drive???

OK. The jumpers according to the Maxtor data should be set as follows: The Master which in my case is a Fujigsu HDD set vertically on the first 2 pins (the left as you look at the back of the HDD0 and there should be no jumpers at all on the slave. The cable is new and is one with the three connection sockets. Blue to Motherboard, Black to Master and grey/middle to slave.
Is this cable select??

The Bios boots from floppy and I cannot see any way to change that. Not even to CD. Not sure what you mean by
the boot drive being WD. Please explain.
I will go back into the maxtor site and look at the cable select jumper settings. Thanks a !0000000000

Collapse -
The cable is one that supports

In reply to: (NT) Hi Ray Need to go a little slower please.

Cable select, but also the drive jumpering must also be set to CS in order for the team [mobo, cable, and drives] to work properly. LOL.

Therefore I would recco that you set the jumpers on both the drives to the CS jumpering. Then the Master [your original drive] must be put on the end connector and the one on the middle connectro. Then from a jumpering standpoint that aspect should be complete.

Why would Maxtor be telling you how to set the jumpers on a Fujitsu drive?? Not really normal.

A digreesion re the WD statement. Western Digital is a hard drive mfr, and their jumpering confuses most people because they use no jumper for Master without a slave, but require a jumper for a Master with a slave. Thus is one adds a slave to a WD drive, one must change the jumpering of the Master.

Are you saying that in your BIOS you cannot set the boot selection sequence??? Extremely unusual. If the mobo is old enough I could see it not offering to boot from the CD. No big problem if it doesn't allow booting from CD, easy to get around that when you decide to install XP. We'll simply use a Win 98 boot floppy [or a Win ME boot floppy, just not familiar with the ME one, but can find out when the time comes].

Collapse -
Ok Will try to answer questions

In reply to: The cable is one that supports

I don't know if the cable supports "cable select" Is there any way of telling apart from the fact that it has 3 connection points blue,gray & red?

On Maxtor site you can download a diagnostice floppy On the floppy it names every hard drive and serial number manufactured in the last 10 years. This is where I got the Fujitsu jumper info. I cannot see anywhere in my bios where I can change the boot up sequence but as I just use floppys as neccessary, up to now this has not caused a problem. By the way the installation & diagnostics on the maxtor site can be d/l to CD as well.
But now I am really upset and concerned as my machine is now refusing to boot into normal mode. It just goes straight into the bios. I can get into safe mode by using the Win Me bootup disk but I can't get into it via pressing F8 anymore. Had a message saying Windows Me has detected that the C drive does not contain a valid Fat or Fat 32 partition My C drive is not partitioned. When I got into safe mode and clicked my computer it was there and I was also able to access the control panel and the applications that I tried opened Ok. Do you think I have broken the Bios? Two more things which might be relevant. Put on next reply Thanks

Collapse -
The post that you made this reply

In reply to: Ok Will try to answer questions

to is me telling you that the IDE cable that you are referring to is , IN FACT, one that supports CS. I didn't word that very well.

Usually when it jumps straight into the BIOS it is because a change was made that was causing a CPU speed problem. It normally would have defaulted to safe parameters, so you should have been able to simply save and exit, and get back working.

If it is having BIOS problems, it could simply be that the battery is going bad.

I think that I goofed and read your other replies before reading this.

Collapse -
BTW the jumpering

In reply to: (NT) Hi Ray Need to go a little slower please.

info is normally shown right on the drive itself.

The main annoyance with the Fujitsu is that you may have to pull it out to see it. Possibly go to their website to see.

Also if the Maxtor is jumpered CS and put on the middle connector, and one ***-u-me s that the Fuji is jumpered as Master you may not need to change it as long as it is on the end connector.

My only fear is that it is like a WD drive and jumpering as a Master when there is no other drive on the cable is different than the jumpering when there is a slave on the same cable. That was my first fear, because that would cause the new slave to not be seen.

I guess that I am saying that you need to be certain about the jumpering on each drive.

The LBA issue is because without it your BIOS would only see 2GB as the drive size.

I'll go visit the Fuji site.

Collapse -
Sorry Cable in last post should have read Blue, Grey, Black

In reply to: BTW the jumpering

Ray on the maxtor site you can go into interactive macroflash tutorials and the positioning of the jumpers is very clear for all combinations.

When doing the installation I took out the fuji to list the details incase I needed them. The jumper is positioned vertically on the first two pins and this is confirmed by the maxtor diagnostic floppy. I would be more than happy to try the cable select jumpers but this is now a problem because this HP/XP machine appears to have lost its macroflash and does not seem to be able to download it again & this is needed to get into the interactive tutorial. I accessed the tutorial previously on the WinMe PC but now can't get into the WinMe. Please help. Don't mind the HDD not working but would really like my Win Me back. Cheers marg

Collapse -
I would think that the first thing

In reply to: Sorry Cable in last post should have read Blue, Grey, Black

to do is remove the Maxtor drive and try to get back to normal.

Apparently possibly] you used the new ribbon cable when you installed the maxtor. Possibly it is not plugged in properly or simply defective. Can you tery the original cable??

As an aside, I could not find a macroflash or any such thing at the Maxtor site but that's me not them. I don't need ii because you have the needed info.

I assume that the Fuji drive supports CS.

How old is this computer. If its like 6 years old or more, the mobo IDE controller may not support CS. If that is true then simply use master slave jumpering if you are certain that the Fuji doesn't use two different schemes, one without a slave and another with a slave.

Collapse -
I can't find Fuji jumpering

In reply to: (NT) Hi Ray Need to go a little slower please.

unless I know the model number. Hopefully it is printed on the drive itself. Their site is a little tough to navigate, and I'm navigating as if it is in the UK.

Collapse -
Thanks for all your trouble Ray

In reply to: I can't find Fuji jumpering

I really appreciate it.

Not bothered about the HDD too much but as you know I really wanted to put XP on the Tiny WinMe PC.

The other two things that might be relevant.
IN safe mode In My computer it shows the normal A, C, & D drives, however it also shows another harddrive icon with the letter'E' named host files (or something similar) I think that this is the networked
drive/programme files from the XP machine.
Is it possible that the bios is trying to allocate the letter E to the new HDD but can't because of this 'E' file/drive showing in My computer.

Also in hardware devices there is a device named as "unknown device" with a red X throught it. I don't know what it is. I have not installed any harware other than the new maxtor hdd.

I am now going to completely disconnect the maxtor hdd to try to get my system up and running again. If I manage this I will check the maxtor tutorial for the cable select jumpers. Must be worth a try. Another thing I thought of was to disconnect the existing fuji drive and install the maxtor as a master (stand alone)
just to see if it can be seen then. What do you think.

Collapse -
At the moment I am not sure what is

In reply to: Thanks for all your trouble Ray

the best thing to do. I just can't figure why such a simple thing can get so complicated.

If I read you properly, right now you are working to get the newer computer, the HP with XP working again.

That may be an issue for Grif re networking. Maybe networking is involved with the added drives if you are sharing the data on the drives over the network. I really don't know.

Re simply adding the drive, is the Maxtor formatted in any way??? Hopefully it is not, and is just a new drive. Note, for ME, if the Maxtor drive is not formatted, means that it DOES NOT have a Primary DOS partition on it, ME would simply let it be the next letter that is unused, with no big deal. If it has a primary DOS partion it will become the D drive. To get the optical drives out of the way many people change their drive letter to something way down in the alphabet.

Basically XP handles these things entirely differently.

As to how to proceed in this, it would depend on when and how you plan to put XP on it. Using an XP Upgrade CD or a full install. Also what do you want to do with the files that are presently on the ME system. If you are going to do this soon, and if the Maxtor is a newer drive, you may want to take the network down, simply unplug the Fuji, install XP on the Maxtor as the Master [CS jumpered]. If it is an upgrade XP CD you would have to have the ME CD to be able to let XP see that you own ME. Then add the Fuji drive, move files etc, get fully operating and then create the network again.

XP has a Fles and something transfer wizard that is supposed to be pretty good.

As to applications on the ME drive you may have to reinstall them from their CD. This is in order to re-establish the.dll's. Normally this will not destroy any of the existing data on the drive.

Of course everyone will tell you to back up anything that is really important.

I guess you need to get back to one thing at a time and get that item solved first.

As we get deeper into threds such as this, it may become necessary to rebaseline things so that we are all coming form the same direction.

If Grif or anyone else has better ideas, simply go with their's.

Collapse -
BTW, DO NOT use the Maxtor

In reply to: Bios can't see addition slave hdd

installation floppy if you plan to install XP on it. XP does a fine job itself.

Of course you will have to get all of the driver et al files saved from the restore CD that you have. That should also have the motherboard drivers on it.

Collapse -
Installing XP

In reply to: BTW, DO NOT use the Maxtor

Ray. The maxtor floppy is only to help with the installation of the hard disk, not OS or anything else.

have great difficulty getting my head round this installation thing. I know that you have to save your data and any hardware and software that you have installed and want to keep, plus the drivers.

From there on I really don't understand. If I built my own PC and then went out and bought an XP installation disk. I would expect that disk to have on it everything I need for the operating system.
Programmes, applications, drivers etc.

Therefore if I completely clean my hard drive am I not in this same position. Why should I have to pay around 400$ for an operating system only to have to save bits and pieces, (I don't even know what bits & pieces)from a previous system???????

Please explain but better make it new thread.

Thanks marg

Collapse -
A new blank drive needs no help

In reply to: Installing XP

whatsoever to be connected and seen by the BIOS. Having it seen by an Operating System is an entirely different thing. [remember DOS IS an Operating System]

The term installation is not a precise statement of anything re the drive.

Collapse -
The GPNV checksum is bad

In reply to: Bios can't see addition slave hdd

refers to the information stored in the Non-Volatile memory regarding the BIOS results regarding hardware settings.

That's actually CMOS type memory effectively made non-volatile by using the same battery that powers the BIOS chip. It can be in the same chip or elsewhere on the mobo.

Thus, as I re-read, maybe a new battery is in order. They are very inexpensive.

Collapse -
OK Ray

In reply to: The GPNV checksum is bad

How about it in english. What do I ask for at the shop and how and where do I install it please.

Am I right in thinking you mean the little battery that keep the clock, dates and stuff working.

Are they all similar or do I need to have all my motherboard details available.

Cheers marg

Collapse -
It's time for all Englishmen [persons]

In reply to: OK Ray

to go to sleep.

Will continue tomorrow when I get back from work. LOL

Collapse -
Let's start over from the beginning

In reply to: Bios can't see addition slave hdd

First.......don't use the Maxtor floppy disk for anything at this point. There are programs on it that you won't need and we don't need having you accidently install or do something that will need to be undone later.

Now....what I suggest is that you first rejumper the Fuji drive to be the Master...or look for the CS/Cable Select jumper setting...and hook that drive up to the BLACK connector end. Leave the Maxtor unhooked for now. Boot up the computer and see if the bios now sees the Fuji drive again like it did before.

Once you know the Fuji is back, enter your bios setup and look all over for the BOOT SEQUENCE or BOOT ORDER area. It is usually on a tabbed 'page' by itself for most bioses; however, it could be listed on the MAIN or ADVANCED tab instead on some others. You will have to use the keyboard to move around and the 'key' at the bottom of the screen will tell you which keys to use in order to move around, change settings, and how to ESC with SAVE AND EXIT.

Once you locate the boot sequence area, there will be at least three (sometimes four) listings....FIRST device, SECOND device, and THIRD device. Change the FIRST device from A to CDROM......or if they aren't separated by device, change it from A,C,CDROM to CDROM,A,C or CDROM,C,A

Once it is changed, use the ESC key to SAVE AND EXIT so the change you made is saved and the computer will reboot by itself to the Fuji drive because you will have no cd in the drive and no floppy disk in the drive as it is checking those devices during the reboot.

If you get this far, let us know....and we will go on to hooking up the Maxtor as the slave again.

This ALL assumes that the CDROM is NOT attached to the same cable as the FUJI harddrive and is on its own separate cable in the Secondary IDE controller position. If your cdrom IS actually attached to the same cable as the FUJI drive, then the Maxtor will HAVE to be the MASTER on a separate cable in the Secondary IDE controller position. So let us know that as well.

TONI

Collapse -
OK Toni

In reply to: Let's start over from the beginning

Can't continue too much because the maxtor drive is still in the PC shop waiting to be checked.

The CR Rom is on a completely seperate cable from the fuji.

Will look in Bios to see if I can establish how to change the boot sequence and let you know.

Thanks M

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Enter to win* a free holiday tech gift!

CNET's giving five lucky winners the gift of their choice valued up to $250!