Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Browsers, E-mail, & Web Apps forum

General discussion

BIG problem. cannot play any flash in firefox

by Slasher / September 17, 2005 4:46 AM PDT

OK, I hope someone can help me because I spent well over 1 and a half hours on Firefox help IRC and NOTHING they suggested worked!

Situation & Story:
After installing the newest version of Quicktime (v7.0.2) no flash files (.swf) would play. Instead, they showed the Quicktime logo with a big black question mark over the top of them. I then went to the Firefox help IRC and this is what happened (without all the chat etc):

First off they sent me to http://plugindoc.mozdev.org/faqs/flash.html#new-quicktime. I followed the instructions, and nothing happened. They also said to make sure that .swf was noit selected in quicktime mime preferences. It was not.

Then they suggested that I go to about:plugins to see what could play .swf. I found that ''QuickTime Plug-in 7.0.2'' and Shockwave could play it. They were quite stumped, seeing that .swf is not selected in the quicktime preferences.

Next, they got me to reinstall quicktime and shockwave. Nothing happened both times.

Next he got me to go back to about:plugins and see which .dll file it was (it was npqtplugin9), and then delete it out of c:\program files\mozillafirefox\plugins\ After this, the flash animations no longer showed the quicktime symbol or the question mark, just showed empty space.

Then they said to uninstall Firefox, and then reinstall it. I did this; nothing happened.

Other Info & Quick Notes:
When I click on Flash Media, in Mime settings of the Quicktime player it says:
Handeled by: Unkown, check browser settings

Have reinstalled every related software.

Flash plays in IE.

Run:
Windows XP Pro
Firefox v1.0.6
Quicktime v7.0.2

Flash playd fine before upgrade to Quicktime v7.0.2

Flash is not selected in Mime settings or the File Types tab of Quicktime settings.

Any help would be VERY helpful.

Discussion is locked
You are posting a reply to: BIG problem. cannot play any flash in firefox
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: BIG problem. cannot play any flash in firefox
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
stupid smilies...
by Slasher / September 17, 2005 4:48 AM PDT

where it says about:plugins it is meant to say about: plugins (without the space)

Collapse -
A suggestion
by mart44 / September 17, 2005 3:15 PM PDT
In reply to: stupid smilies...

I notice only the Shockwave player is mentioned. Shockwave and Flash players are a bit different and I find it's necessary to install both. Going straight to the Macromedia site for the plugins is perhaps better than following the 'missing plugin' link in Firefox. Installing the Flash Player from here might solve the problem.

Here is the Shockwave Player link in case you need it.

Collapse -
Go to
by PudgyOne / September 17, 2005 7:07 PM PDT
In reply to: A suggestion

If you already have a version of Mozilla Firefox in your computer, uninstall it and restart your computer.

Download Mozilla Firefox from this website?

http://www.mozilla.org/

Install it.

Go and download the Macromedia Flash Player at

http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&promoid=BIOX


Then go here and download the Shockwave player.

http://sdc.shockwave.com/shockwave/download/download.cgi?promoid=BIOY


Also, are you using NoScript? If so, click on tools, extentions and double click on NoScript. Click on advanced and the only check mark should be to forbid JAVA. If the other ones are check marked, then this could be your problem.

Try this and see what happens. Let us know your results.


Hope this helps.

Collapse -
still doesnt work
by Slasher / September 17, 2005 8:47 PM PDT
In reply to: Go to

Done all that. Still doesnt work and I'm not using NoScript.

Collapse -
I don't have XP
by PudgyOne / September 18, 2005 1:40 AM PDT
In reply to: still doesnt work

I don't have XP, but you need to be the administrator when you are installing these things.

If you Install all these things without being the administrator, they may not work correctly.

You also need to have JavaScript enabled to have these things work.

Hope this helps.

Collapse -
I am the admin & Javascript is enabled
by Slasher / September 18, 2005 2:14 AM PDT
In reply to: I don't have XP

what I am saying is it worked fine before I installed the new quicktime, but after Quicktime tried to take over. see my first post to see the rest of the story.

Collapse -
Next instructions
by PudgyOne / September 18, 2005 7:12 PM PDT

Go to

http://www.hersheypa.com/attractions/hersheypark/index.asp

Do you see the top banner and the moving pictures?

If so, they are done with Macromedia Flash Player 7.

No go to and see if you can click play. It uses Shockwave flash player. Shockwave Flash player items take longer to load. Please be patient.

http://www.disney.go.com/disneychannel/originalmovies/games/cadetkellyobstaclecourse.html

If all these items work, then you have both the Macromedia Flash Player and the Macromedia Shockwave player working.

Then the next question is, What website were you trying to view?

They all work for me and I am using Mozilla Firefox with Windows ME.

Hope this helps.

Collapse -
1 works, other doesnt
by Slasher / September 19, 2005 1:32 AM PDT
In reply to: Next instructions

The first link doesn't work and the second one does. For the hey of it I installed Flash player again and... well... you can guess the results!

Collapse -
Firewall help needed
by PudgyOne / September 19, 2005 7:27 AM PDT
In reply to: 1 works, other doesnt

Next guess would be Firewall.

I don't know much about the firewall setting for XP. Also are you using anything like Norton or Zone alarm? You are going to have to look at the settings for your firewall(s).

The first link to HersheyPark was the flash player. The second one that works was the Shockwave player.

It seems that you have most of the needed items but for the flash player to work it seems like a firewall problem. It could also be with the AdBlock or the version of Flash player. Please read the forum listed below.

I found this on another Macromedia's forum

http://www.macromedia.com/cfusion/webforums/forum/messageview.cfm?catid=184&threadid=1043131&enterthread=y#3733045

Let me know what you find.

Hope this helps.

Collapse -
been a couple days...but it's fixed!
by Slasher / September 21, 2005 6:57 AM PDT
In reply to: Firewall help needed

Sorry about the wait but I figured it out! It was adblock, an extension, that was blocking ALL flash (for some reason, don't know why). All I had to do is diasable it! I'm going to write an email to the people who do adblock asking them to fix it. Thanks for all your support. Happy

Collapse -
The Macromedia forum
by PudgyOne / September 21, 2005 5:47 PM PDT

The Macromedia forum says

For those that want to use Flash 8 with the Adblock extension. If there is an ad you want to block with object tagging disabled. When you see an ad you want to block. Go to the Adblock Option and click on Overlay Flash. Then on some images you can left click on the word Flashblock. If that doesn't show up, you can then right click the image and choose to block it.

Also did you see that there is an updated version of Mozilla Firefox?

It can be downloaded at

http://www.mozilla.org/

Glad you have your problem corrected.

Collapse -
(NT) (NT) Thank you again! Didnt know about the overlay flash thi
by Slasher / September 22, 2005 1:54 AM PDT
In reply to: The Macromedia forum
Collapse -
PudgyOne that Disney game is so funny!
by web-browser / November 29, 2005 2:43 AM PST
In reply to: Next instructions

PudgyOne that Disney game is so funny!

Back to the point...

It DOES work in BOTH browsers, HOWEVER, I'm (still) seeing the QuickTime Question Marks around the game (while I do not see the question marks in Internet Explorer).

Collapse -
I'm having the exact same problem
by web-browser / November 29, 2005 2:37 AM PST

Salsher, I've been having the same problem with FireFox, and don't know what to do. Personally, I think FireFox sux. The only reason I use it is because it has this "Text Zoom" feature (Ctrl & "+/-/0"). Other than that I'd rather stay with Internet Explorer.

I've even had online banking problems caused by FireFox... Did a money transfer recently - which is a snap to do with Internet Explorer - but the Mozilla FireFox browser f'ed up and sent the transfer request to my bank TWICE!

Also, that stupid "Greesey Money" plugin is crap and doesn't work with some sites.

I don't know how to fix the QuickTime Question Mark Error problem, and I guess I'll just have to use Internet Explorer on sites where I see the it.

Is there anyway we can send Microsoft a request to add the text zoom feature to Internet Explorer? Or is there such a plugin available for the IE Broswer? Thanks.

Collapse -
have both
by Slasher / September 17, 2005 8:30 PM PDT
In reply to: A suggestion

forgot to mention flash player. i also reinstalled that.

Collapse -
firefox sucks - well the macromedia plugin does
by darknkreepy / September 25, 2005 4:09 PM PDT

so what is it with this company? they get some airplay on screensavers and everyone installs it. why not just use the explorer then? I mean really, its not ready yet, the plugin for flash, even at flash8. strange things happen like the cursor and highlights just dont show up in the firefox player for flash made by macromedia, or mozilla screwed something in its OOP or GUI somehow. more likely macromedia. the mail program from mozilla (thunderbird) is great, but the browser is just junk.

junk
09-26-2005

kristoffe brodeur

Collapse -
I respect your opinion but...
by Slasher / September 28, 2005 4:19 AM PDT

I really do prefer firefox to IE. I like the tabbed system and lots of other stuff. However, if you took the time to read the whole topic you would realise that it was my fault that the flash didn't play, because I didn't read all about the Adblock thing which I downloaded for it.

Collapse -
I still can't get flash on firefox
by Mack7 / October 6, 2005 10:33 PM PDT

I have read all about you problems with Flash on Firefox and I still can't get flash. I don't have adblock as an extension @#!

Collapse -
Go here
by PudgyOne / October 6, 2005 11:15 PM PDT
Collapse -
Go here
by taboma / October 7, 2005 2:41 PM PDT
In reply to: Go here

Rick, The original post mentioned QuickTime that is a Macintosh application. I was not aware that it ran on windows. What was the ? question mark about? Maybe needs to reinstall it? Upgrade?
Can you run Quicktime on a PC? Quicktime Pro is what I have.
I can run Microsoft (viewer apps is what I call them) on my Mac.
Now that I think about it, he may have to install the latest version of Quicktime. About every six months or so. Happened to me with a new OS X install last week.

Apple prompt: need to update Quicktime. Heck, I just bought the Pro version within the last year.
Same scenareo with a Mac user. What do I have to download from Microsoft to run on my Mac? My latest upgrade was three weeks ago.

Rick, set up a link to Go Here for PC and another one, Post Here for Mac Users. Would be helpful for Mac and PC users. Rick, I know you can do it! You have done those links in the past to help out.

-Kevin Smith

Collapse -
Kevin
by PudgyOne / October 7, 2005 7:35 PM PDT
In reply to: Go here

The posters origional problem was with The Flash player. It was an AdBlock problem and was solved.


Quicktime does run on Windows as well as Mac. A link to this should be posted on the PC applications and the MAC applications forum. The link I have copied works for both. I have NoScript working and Quicktime could not determine my OS. So the link was not finished with the os download.

The link to get quicktime is

http://www.apple.com/quicktime/download/

I will go to these forums and post it there also.

Hope this helps.

Collapse -
Same problem
by br5 / October 20, 2005 3:02 AM PDT
In reply to: Kevin

I have the same issue being described in this forum here, and I do not have AdBlock as an extension for Firefox. I have uninstalled and re-installed Firefox, the flash plug-in, the shockwave plug-in and Quicktime. Everything is updated.

When I uninstalled Quicktime, the flash and shockwave movies play just fine. I have de-selected Quicktime as the default player in it's preferences so those files should not be playing with the Quicktime plug-in.

I have tried taking down firewalls, activating and deactivating virus software, adblackers, etc. Nothing has effected the problem except uninstalling Quicktime, which is a bummer since iTunes won't run without it.

I am completely at a loss and have been searching the web for other people who have this issue without success. This is the most comprehensive forum available. I have Windows 2000. Any help would be greatly appreciated.

Collapse -
Me too
by pbernardo / October 20, 2005 5:25 AM PDT
In reply to: Same problem

Having the same problem.

I have unistalled Firefox, I have uninstalled quicktime, etc etc.

When I load www.macromedia.com it tells me I need to install quicktime.

Any help is appreciated

Collapse -
This is what worked for me
by Lokiluca / October 29, 2005 3:35 AM PDT
In reply to: Me too

I didn't have the Adblock extension install in my firefox either. (I'm using the latest firefox v. 1.0.7) After uninstalling and reinstalling QuickTime, Macromedia, and Firefox, I just did a System Restore to a date before I had this problem. After doing the System Restore, it's now playing flash without a hitch. Try that and see if it works.

P.S - If you're using Windows XP, you can easily launch the System Restore by going to Run... on the Start Menu and typing in "msconfig". The "Launch System Restore Tab" is at the bottom of the window that comes up.

Collapse -
Hmmm...
by web-browser / November 29, 2005 2:47 AM PST

Aight, I'll try that (though I'm not blocking any Google Ads - even though I have the plugin).

Collapse -
Removed Ad Block Plugin & FlashGot
by web-browser / November 29, 2005 2:56 AM PST

But I still see the QuickTime Question Mark.

Oh well, I'm not gonna bother wasting time on this. Will switch to IE on sites showing the Question Mark, and find a way to request Microsoft to clone some FireFox features Wink

Collapse -
Same Song Second Verse
by JeffFrankus / November 7, 2005 12:08 AM PST
In reply to: Same problem

Same with me. I had to destroy itunes/quicktime in order for flash to work.

My FF never did recover and so I blew away ITUNES on my PC in order to get my flash-players to work right.

Last thing I did was re-install ITUNES and ensured when installing I removed all the associations except those which I couldn't.

It installed and wow... my flash worked. I went into my FF Options and finally saw NO QT entries in the plugins section. However that was very short-lived. After about 1 - 1.5hrs all the QT junk showed up in the plugins area and flash once again no longer worked. I had to uninstall once more.

What is somewhat strange is I have installed flash plugin, shockwave... and it shows in the plugins that it is NOT running QT for my flash files, however it certainly does. I don't know if it is some conflict between QT and FF or what the deal is, but I'm dead in the water with iTunes and my FF.

I even tried upgrading my FF to the latest Beta and still no success with getting all to play nice. Sad

Collapse -
Partial Fix
by pbernardo / October 20, 2005 5:48 AM PDT

Here is a partial fix.

Uninstall Firefox. Go to C:\Program Files Delete the entire Mozilla directory. You might want to export your bookmarks before hand. My bookmarks stayed around after the delete and reinstall but yours might not.

Install Firefox again, go to www.macromedia.com it should not mention QT again, install the flash plugin.

I am not installing QT again until I hear of a fix.

Good luck

Collapse -
Fixed?
by pbernardo / October 20, 2005 6:34 AM PDT
In reply to: Partial Fix

Well I got daring and after I did what I detailed in the last post I reinstalled QT, everything seems to be working fine for now.... fingers crossed.

Collapse -
well, here's hoping
by br5 / October 21, 2005 5:05 AM PDT
In reply to: Fixed?

i managed to fix the problem as well by installing the flash and shockwave plug-ins before installing quicktime -- and I was careful to not select Quicktime as my default media player. So far, so good. We shall see...

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!