Windows Legacy OS forum

Question

Belkin wireless adapter problem

by mypcissucking / January 8, 2015 5:20 AM PST

Just as disclaimer I'm coming from a macbook trying to relearn windows. A friend gave us an older Dell desktop that has XP and no wireless connectivity. I went and got a Belkin N300 wifi adapter and lo and behold the optical drive for the computer doesn't work. I downloaded the Belkin startup driver from their website here:

http://www.belkin.com/us/support-article?articleNum=4736

I put it on a flash drive and ran it from the PC with no problem. It installed the hardware, prompted me to restart, but it is not working. When I go to device manager there is a yellow question mark next to the adapter and under properties is says there is no driver.

I then tried to update/install the driver various ways including automatically and manually. When I try to select the folder myself on where I want it to point to the 'belkin' folder keeps opening into subfolders with no actual file to point to. It tries to search never finding anything either on the PC where I copied the downloaded file or on the flash drive.

I'm very frustrated and remember why I hate windows so much. Sorry don't mean to offend any windows lovers. I'd appreciate any help or insights. Thanks in advance.

Discussion is locked
You are posting a reply to: Belkin wireless adapter problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Belkin wireless adapter problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Well, that's true.
by R. Proffitt Forum moderator / January 8, 2015 5:24 AM PST

XP (the one without SP1, 2 or 3) doesn't seen to be friendly to such adapters. You may find it far too hard to update XP to the latest as it will require an internet connection. The broken optical drive can mean you can't reload the OS if something goes wrong.

" Windows® XP (SP3 or greater) " was noted but you wrote "XP" so that's a non-starter, should fail and be far too rough on most folk.

I don't love Windows. It's just one of the dozen or more OSes I've used over the years.
Bob

Collapse -
SP3
by mypcissucking / January 8, 2015 5:40 AM PST
In reply to: Well, that's true.

Ah I didn't think about the service pack. I just checked, it's SP3.

Collapse -
I added a no-driver model. Carrying on...
by R. Proffitt Forum moderator / January 8, 2015 5:45 AM PST
In reply to: SP3

XP SP3 = Good but there's a lot more to get this working.

Many front USB ports are just not worth the trouble of fixing. So stick to the rear USB ports and check these out:

1. Enable all USB ports in the machine's BIOS.
2. Install the Intel or other Motherboard Chipset Driver package for this machine.
3. STOP USING THE MICROSOFT DRIVER UPDATE BUTTON. Most folk know why so I don't write why.
4. Remove old antivirus software until this works.
5. Try a new Admin user account.

Good luck.
Bob

Collapse -
thanks!
by mypcissucking / January 8, 2015 5:58 AM PST

I'll try these too. I appreciate that a lot!

Collapse -
Answer
Let me share an adapter that should need no drivers.Linkonly
by R. Proffitt Forum moderator / January 8, 2015 5:41 AM PST
Collapse -
Good call
by mypcissucking / January 8, 2015 5:56 AM PST

I didn't think about the issue being with the Belkin. I might just save myself the headache and go that route, thanks. I just wanted to make sure I wasn't missing something here with this one. If anyone else knows something to try I'd appreciate it.

Collapse -
Belkin
by hightowerz / January 17, 2015 1:43 AM PST
In reply to: Good call

Try the belkin utility for the adapter?

Collapse -
Answer
By any chance do you know the Belkin model #
by Steven Haninger / January 17, 2015 2:03 AM PST

I had a Belkin USB wireless device adapter that had some issue when using Windows wireless zero service. I discover that, rather than use the Belkin installation software, I could download the Ralink driver that Belkin uses and that worked just fine. I did a brief search and found the n300 might be the Belkin F5D8053 which can use the Ralink RT2870 driver. If you've not gotten your issue resolved and don't mind enduring another waste of time, you might consider searching for the wifi chipset driver rather than the Belkin.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?