BDP2500 cannot update firmware

I had my BDP2500 repaired by Samsung 3 years ago. Failed outside of warranty (stopped powering on). As part of the repair they installed new firmware as repaired player had Pandora afterwards as well as Netflix.

However it also had a really annoying new Netflix bug where it crashes on the first frame of streaming a title. Doesn't effect all titles and usually works after reset and resuming title. Never did this before repair and PC on network streaming same title works fine.

For 3 years I've been trying to update via online update and player always says it's running current version. I contacted Samsung tech support several times during this time via text-chat and they always told me that if this is what player says, then there is no new firmware available.

Turns out I'm several versions back and there is an update available (off website) for download to install via USB or CD.

Problem is that neither of these methods work, I'm seeing the exact same problem as detailed in this earlier thread:

Official Samsung update CD doesn't work either.

I've dealt with Samsung tech support via phone now for hours, horribly frustrating experience. Full details can be found here if anyone cares:

Supervisor in tech support claimed the reason the online update no longer works is because (for technical difficulty/reasons) Samsung stopped uploading new firmware for this model to their online server. Not sure if this is actually true?

I have no idea why I can't update via USB or CD. I'm not paying to have it repaired, I'll just go buy a Roku.

If anyone knows a workaround that will allow the player to update the firmware I'd really appreciate hearing it. Thanks!

Discussion is locked
Reply to: BDP2500 cannot update firmware
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: BDP2500 cannot update firmware
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Clarification Request
What is this Official Samsung update CD ?

I've seen folk try to make those and it's pretty finicky. I won't write how to create such but will double check how you created one.

- Collapse -
re: What is this Official Samsung update CD

It's the official disc that Samsung sent in the mail. The version I downloaded and burnt didn't work, I guess believing I was making some error, they sent me an official one. Actually they sent two.

Both official discs fail in exact same way as ISO I burnt, player reads disc for a while, then ejects it saying "this disc can not be played". Exact same as the other earlier thread I linked to.

Formatting a USB stick and copying the RUF file onto it, player recognizes that USB media has been installed. USB icon appears on LCD and message on TV screen but then nothing happens (I've left it installed for 20 minutes). According to instructions, a dialog should appear immediately asking if you wish to upgrade the firmware. Again, same as the earlier thread I linked to.

And of course the online update doesn't work. It definitely makes an attempt to talk to the Internet as if I remove the ethernet cable, I'll get an error. After plugging back in it says "The latest version of the Firmware is already installed. There is no need to update". It's been saying this ever since it was repaired in 2009.

Version of firmware currently installed (since 1999 repair) is 090622.01_111208B1_1254.08_XAA

- Collapse -
link to image of official disc
- Collapse -
(NT) Thanks. Now checking out the RUF use and guide.
- Collapse -
I see Samsung needs to add more to the USB update.

I see no mention of how to format the USB stick, any limitations on stick size. These details are not in the install guide so the user would have to guess that they would have to stick to old fat format and small sticks of the 2GB and smaller ones.

Since it's so far out of warranty you find that most of the time the support is less than folk need. I wish I could try for you but my ideas are to try the usual smaller fat format stick.

-> There is another hurdle in that the file is ZIP'd. I've lost count of the issues this can cause for some users or PCs. And no, short of a trip to the shop I can't fix those issues in a forum.
- Collapse -
Interesting reply

Heh. I was just going to update with some more info and I found you had added the above.

I had already tried using 2 USB sticks I had. Nothing happened.

I just backed up some data I had on an old 4GB stick and tried that and I get new behavior.

I can see an error dialog popping up on the middle of the screen but (genius) it's only displayed for maybe 1/50 of a second.

I video'd the screen and the error is "Error is detected in the update data. Please try it again". I get this if I format this USB FAT16 or FAT32.

The USB firmware I'm downloading is The contains the file 110315_01_BDP2500_XAA.RUF. This file is the same filename that is on the official Samsung update CD.

I ran a checksum and also a byte by byte comparison of the RUF file contained in the ZIP and the RUF file on the official CD and they are identical.

I wonder if this is why the CD refuses to play?

Still, the question is why.

- Collapse -
As to the sticks.

I wrote to stick to small sticks commonly found 3 or so years ago. I have this one old industrial controller that we can use anything over 1GB sticks on. So all the folk at the office know to keep those handy.

To create my own CD it's often plain data CD, single closed session and recorded at 2X speed to help old players along.

From the story, it looks like it has to go to the shop.

- Collapse -
Here is the error
- Collapse -
I hear you.

Let's see if the Samsung Rep has other ideas.

The only thing that shouldn't matter is to unplug it from any network during the update tries and a full reset prior to the update attempts.

-> I did encounter someone that had a download accelerator installed on their PC. What a mess. Lots of bum downloads.

As to support, all the maker support seems to be go away as the warranty ends. I don't see this changing over time.

- Collapse -
I fixed it


So the 1/50th second error made me think of something.

The BDP2500 never had Pandora. That was a feature only available on the 2550 which was a Best Buy only model. I recall this from the time I bought it.

I had specifically asked Samsung about this every time I contacted them. No kidding.

I remember when I got the player back from repair the repair invoice said absolutely nothing. During one of my calls with Samsung they checked there was no information about what repair was performed (original issue was that the unit would not power on).

The supervisor in BluRay support that I later spoke to told me that Pandora was added to the 2500 due to customer requests (in a firmware update) which is why I was now seeing it after repair.

Anyways, what the geniuses at Samsung apparently did was to turn this into a 2550. I'm not sure how, maybe a new motherboard?

I just downloaded the 2550 firmware and burnt it onto a USB and it worked.

The label on the rear of my unit is the same as when I purchased it, still says 2500 along with my original serial number. (label on rear).

I've spent hours on this in the last 3 weeks including writing to Samsung by USPS and beating my head against a brick wall there.

Oh well. At least it's now updated. Now to see if the update fixes the Netflix issue.

I'm now running 110315.01_111208B1_1254.08_XAA

I'm really curious to know if these version strings are different on the 2550 than the 2500 as I've given them to Samsung over and over and if they are it means noone at Samsung ever bothered looking at the issue.

- Collapse -
(NT) Good sleuthing.
- Collapse -

This is after years of being fobbed off on text chat and 3 weeks of beating my head against the brick wall that is their tech support (you really should go read the link to blu-ray-forum in my original comment).

I actually wrote to them via USPS because I was so cheesed off. They claimed to have no record of any of my text chats and unless I could quote the transaction#s for them they were not going to do zip. Obviously I didn't keep the transaction #s.

In the end they offered to exchange it for a 2010 era factory refurbished unit but I had to pay $80. I could find that same refurb to purchase for less than this. No thanks!

I'm a software engineer by profession, so I was finally able to figure this out. I doubt a non-technical person would have stood a chance. Instead they'd have been told they had to pay to have it fixed yet again.

- Collapse -
Me too.

My background is in embedded computing, design and more. One of the areas I think about is what happens after they get a few years of how many models out in the field. Oh, wait, we're already here.

I'm sorry I couldn't help here but what a story. Bob

- Collapse -
You helped plenty

Bob, you helped plenty. I appreciated you at least trying. You made more effort and came up with more ideas than Samsung. The best they could manage was a 2nd tier person telling me to try a factory reset before giving up and telling me he'd get the next level to call me back within 24 hours. After a week of not getting a call back and receiving two e-mails telling me "3rd tier" would indeed call me back in 24/48 hours, I finally had to call back to find out that there was no 3rd tier and I would have been waiting for ever for a call back. Incredible.

On a more positive note, the firmware update seems to have fixed the Netflix streaming bug, I've tried 10 titles now and havn't had a single crash at the beginning of streaming.

Thanks for your help!

- Collapse -
Thanks you did help!

You helped by at least trying.

Netflix streaming bug seems to have been fixed also.

CNET Forums