Samsung forum

General discussion

BD-P3600 Firmware update failure

by themightyed / July 3, 2009 2:53 AM PDT

This morning I was prompted that a firmware update was available so I upgraded over the network. I let it run. Didn't touch anything. After a while it turned itself off.

When I turned it back on I only see the blue background screen with the "water droplets" and the LED on the front just says LOAD. After a while the signal to the TV turns off.

I tried following the steps for the USB firmware option to see if that would help but I never get a prompt.

Any help would be most appreciated.

Thanks,

Discussion is locked
You are posting a reply to: BD-P3600 Firmware update failure
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: BD-P3600 Firmware update failure
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
BD-P3600 Firmware update failure
by Samsung_HD_Tech Samsung staff / July 3, 2009 3:58 AM PDT

themightyed,

I'll see what I can find out on this. In the meantime, you can reset the unit by:

Unplug the player's power cord from the wall.
Hold down the player's power button for 10 Seconds
Plug the power cord back in.

If that doesn't work, we can revert internal settings by:

Turn the player on and with no disc in the player, press and hold the FF button on the front panel until the player turns off.
Follow the instructions for language selection.
(This will likely erase your network settings)

Keep me posted.

--HDTech

Collapse -
I tried both steps
by themightyed / July 3, 2009 4:36 AM PDT

I tried both of the steps and it didn't seem to have any effect.

Collapse -
BD-p3600
by thevigil / July 3, 2009 10:05 AM PDT
In reply to: I tried both steps

I HAVE THE SAME PROBLEM EXCPT IT HAPPENED AN HOUR AFTER IT CAME OUT OF THE BOX. nONE OF THE RESETS WORKED.

SAMSUNG SUPPORT SAID IT'S A HARDWARE FAILURE.

Collapse -
firmware upgrade
by jambalaya / July 3, 2009 11:57 AM PDT
In reply to: BD-p3600

same problem here except that my player is bd-p1600

Collapse -
similar issue... but one difference
by undeadguy / September 22, 2009 4:18 AM PDT

i too have gotten the "load" message after updating the firmware, but MY problem is i accidentally did the update with a disc in the tray. now i cannot get the disc out... the tray will not open. when i turn the player on all i get is the load message on the player and the main home screen appears on the tv (the one showing the blockbuster, netflix pandora and youtube widgets). is there anything i can do?! i've tried the hold FF for 30 seconds (even though i know i was only supposed to do wit without a disc in the player) and i've tired unplugging the unit for a extended period of time and holding the power button ten seconds before plugging back in, both without success... please tell me I'm not completely screwed!

Collapse -
similar issue... but one difference
by Samsung_HD_Tech Samsung staff / September 25, 2009 3:01 PM PDT

undeadguy,

I wish I had a better idea, but if the drawer isn't opening, then it may have to go into service. I don't see why the disc couldn't be returned with the player, but I don't have any other tricks, unfortunately.

--HDTech

Collapse -
BD-P1590 failure
by tmfaber / June 27, 2010 6:51 AM PDT

I finally connected my player to the net. Scrolled through blockbuster and netflix fine, when I clicked on youtube it said it wanted to update. So I let it. Now its stuck just like the one above, except I can open and close the door which usually takes me back to "Load" but sometimes stays on "close." None of the remedies has worked. FF doesn't do anything no matter how long I hold. Neither does unplugging and holding the power button. I tried an iso CD and USB update also (BTW, does it matter if I try it from the front or rear USB port?). No effect. Samsung knowledge base says it send it back.
Oh and guess what. Its 4 mos old so out of warranty. What will Samsung likely do and how much would it cost?

Collapse -
BD-P3600 Firmware update failure
by michael2289 / May 5, 2011 7:51 PM PDT

I was asked for a software upgrade at the time I connected BD-p3600 player to my home network. same problem happened to me. How this problem was solved?

Collapse -
P3600 Update
by SanSon69 / July 4, 2009 1:56 PM PDT

I did update the software this morning, I left it go trough all the process, until the player turned off, I turned it back on, and the Set up screen promted me for a set ulanguage,but then it dissapeared and the LOAD message stayed on until I pressed Stop, I pressed the menu button on the remote and then I had no input signal on my tv, I then ejected the disc (I had a DVD in th tray) after removing it I turned the player off and then back on and everything went back to normal, if I have further problems I'll post them, but for know looks like the problem was the DVD on the tray right after update.

Collapse -
P3600 Update
by Samsung_HD_Tech Samsung staff / July 5, 2009 12:46 PM PDT
In reply to: P3600 Update

SanSon69,

Thanks for the update. The update needs to start with the tray empty. Looks like you shouldn't have any more issues, but if you do, we're here to help.

--HDTech

Collapse -
Update now makes my wireless unstable
by valerate2 / July 5, 2009 4:44 AM PDT

Hello,

Just did my update this morning on my bd-p3600 and the update went fine. However now my wireless dongle gets super hot and has the burning hot smell and the wireless seems to go in and out after a few seconds of function. Same wireless settings on my router and nothing changed there.

Whats strange is when i go to netflix and it looks up the movies, i then exit and head back to the menu, then hit Pandora and then it tells me no network connection can be found, then it looks like it detected the wireless dongle again, but it still doest work until i go back to the menu and re-setup the network... Rinse and repeat, all along my network dongle is capable of cooking eggs... : (

These symptoms were not present before the new update! Please help : )

Collapse -
Update now makes my wireless unstable
by Samsung_HD_Tech Samsung staff / July 5, 2009 1:14 PM PDT

valerate2,

Is the dongle itself heating up, or is it heat from the back of the machine itself?

I'll look into this issue.

--HDTech

Collapse -
After update, my network cannot be found
by mtezak / July 5, 2009 4:20 PM PDT

I ran the software update on my Samsung BluRay BPD-3600, it completely hosed my network access.

First question: why is this?? Why can't Samsung run a software update and preserve settings? Why do I need to reconnect at all?

Now I cannot log onto my wireless network. I am running an Apple Airport Express wireless router. Regardless of how many times I
- restart the router
- restart the Samsung player
- reset the Samsung by powering down/holding power switch 10 sec/powering on (this had NO EFFECT on rolling back the Software UPD
- reset the router wireless password
- try ALL variations of password security

NOTHING HELPS, I CANNOT CONNECT TO MY NETWORK.

Now what?

Collapse -
BD-P3600 Firmware Update problem
by lynn4ever / July 13, 2009 10:59 AM PDT

We appear to be having a similar problem. When we turned on our DVD player tonight, the water drop background and numerous multi-colored flashing pixels appeared on the screen. The display is stuck on "load" - there is no disc in the player. We turned it off and back on with no change until once the firmware update appeared. It got to 80% and then froze - a loud, high-pitched noise sounded constantly. We had to power the player off and now are back to being stuck with the water drops and flashing pixels. Neither unplugging the player and pressing the power button nor holding down FF has any effect.

Any otehr solutions we can try?

Collapse -
After update, my network cannot be found
by Samsung_HD_Tech Samsung staff / July 14, 2009 5:08 PM PDT

mtezak,

I apologize for the inconvenience.

The Firmware resets everything - it's as if you're loading an entirely new operating system into the Blu-Ray player. Also, holding down the power or FF wouldn't revert the Firmware, because the new firmware was installed over the old.

If you've tried to connect to the Airport without success, you've gone through all the steps I'd have suggested already. Apple hasn't updated the WEP compatibility, so the only other two that I know may work are WPA or WPA2 with the Airport.

You might try 800-SAMSUNG to see if an agent can walk you through the process, and if that doesn't work, the unit may require service.

--HDTech

Collapse -
Any final fix for the bd-p1600 Pandora issue??
by henty / August 26, 2009 3:13 PM PDT

Has there been any sucessful fix for the 'network connection is unstable' issue that many people have had when trying to use the Pandora streaming? I see many people writing about the problem but no solid answers as far as I can tell.

Thanks

Collapse -
RESOLUTION: Had to reset the entire network
by mtezak / August 26, 2009 4:24 PM PDT

Well, the solution for me was to completely reset the entire network. Meaning I had to go through the router setup again, gave an entirely new password for all devices, since the Samsung device refused to rejoin my existing network using the identical password it had before it decided to update its firmware.

You just need to know that if the BDP-3600 decides to update its firmware, it may be (if your system is similar to mine) that you'll need to reset and reboot your entire network and all connected devices.

This included obviously the router, 2 PC's, 3 Macs, an access point upstairs, my Apple TV, and last-but-not-least, the Samsung BluRay player.

Pain in the butt. Samsung should hire some developers who can figure out how to do a non-lethal upgrade and absolutely not touch the device settings, or at least preserve them into the new UI.

Collapse -
Any final fix for the bd-p1600 Pandora issue??
by Samsung_HD_Tech Samsung staff / August 27, 2009 6:21 PM PDT

henty,

Changing your router's SSID so that it has no spaces or odd characters is probably the first thing to check.

I don't have any solutions for an Apple router.

Disabling the firewall temporarily can help, at least until you get it connected.

Change the channel of your router (inside the settings) to Channel 1, 6 or 11.

--HDTech

Collapse -
BD-P1600 never asks if I want to upgrade
by ajseagles3 / September 20, 2009 11:56 AM PDT

I brought this home today and am darn near throwing it out the window. I have followed the instructions exactly for downloading and installing v2.03, via BOTH the USB and CD methods to update firmware. Behavior is the same for both... The "Verifying Firmware Version" message comes up for a few minutes, then the screen goes blank, and the player becomes unresponsive. It doesn't even ask me if I want to upgrade. Hey, last time it didn't just go black either... It went black, then PINK. Pretty. Anyone actually have any answers?

P.S. I have tried to unplug for 15 minutes, then reset by holding the FF button until the language selection comes up. Then, I tried to update. Same behavior.

Collapse -
Update: Firmware done, FWIW
by ajseagles3 / September 21, 2009 10:43 AM PDT

I pulled the player from the family room and updated the firmware hooking into the monitor in my office. I would still like to know why the CD and USB methods failed, though.

Collapse -
BD-P1600 never asks if I want to upgrade
by Samsung_HD_Tech Samsung staff / September 24, 2009 9:53 AM PDT

ajseagles3,

Pink is usually when one input is selected (such as HDMI) but another one is plugged in (such as component or composite). Switching the output in the Blu-Ray's menu settings will usually fix this.

--HDTech

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?