weotu,

For the first issue, what discs are showing this issue? Depending on how the disc was encoded, it may or may not be adjustable. Try navigating the TOOLS button, and make sure that the main menu after the disc loads doesn't have subtitles set by default.

For the CGI issue, if you have a Samsung TV, try adjusting the AutoMotion Plus feature to "SMOOTH" or "OFF" to see if that helps. If you have a different model, see if there's a picture processing option, or try changing the output setting on your Blu-Ray player to 24fps.

--HDTech