I worry that it's not shut down but sleeping. Did you check your settings?