Avast & AVG forum

General discussion

AVG update - computer will not boot now!

by erin_mcg / February 11, 2010 12:22 AM PST

I hope someone can help me!

Let me first start with:
OS: Windows XP Pro
Service Pack: 3
AVG version: 8.5.435
Virus DB: 271.1.1/2679 - updated 02.10.10 - 2:40AM EST

Yesterday, when I came to work, I turned on my monitor and had the "blue screen of death" and when I tried to reboot my machine in safe mode, the system halted at the file: AVGIDSxx.sys

I tried to contact AVG and they told me to:
First send them files that I cannot access via Windows (meaning logs, dumps, etc).

I replied back to them and told them that I cannot log into Windows at all (either in safe mode or normally)

They then replied and instructed me to do this:
1. Please insert Installation CD of Windows XP and boot your computer.
2. Choose and run Recovery Console.
3. Choose operating system Windows you want to repair.
4. Type listsvc command and hit <Enter> key. This command shows the list of all services and drivers that are being loaded with your system. Note all services/drivers beginning with avg string.
5. You can disable loading these services/drivers with disable command, i.e. you have to type the following commands:
AVG Identity Protection:

* disable avgidsagent (IDP detection engine)
* disable avgidswatcher (Behavioral event monitoring)

6. Restart your computer and boot your Windows normally.

I did that and could not disable the avgidswatcher file - it came up as "not found" on my system

In efforts to further try to resolve this issue, I ran chkdisk /r twice on my machine, with errors being found the first time, and fixed on the first run, ran it again to make sure it was clean, and it was.

Then, I proceeded to search the AVG forums more for information on this issue, and found this:

(The information below was pulled from the same post)
Let me just check a couple of things with you first up:
1. When you access the Recovery Console, do you get to log in to C:\WINDOWS ?
And when you get to the command prompt, does it look like this C:\WINDOWS> ?
2. You wrote: "Yes, I have run chkdsk approx 10-12 times over the past 11 days"
Have you run "chkdsk /r", not simply "chkdsk", from the command prompt ?
At the command prompt, type chkdsk /r and press <ENTER>
(Note the space after chkdsk.)
Some instructions:
How to use CHKDSK in the XP Recovery Console:
http://pirules3.14.googlepages.com/reco ... ole_chkdsk

Type the command chkdsk /r (with a space before the /) and press ENTER key.
There are 5 stages. This might take some time to complete.
The system will attempt to re-start normally.

Does your computer start normally now?
(If errors were found, it may be prudent to repeat the process.)

There are ways and means to access your system to make changes, which will hopefully allow you to get your system started. My first option would be to suggest that you use a version of Linux. To that end I will provide a link to detailed instructions that I have previously posted, so that you can get started making your own Linux CD to boot from.
Download Linux Mint 8 Helena
'Alien's instructions for burning an .ISO image

I believe that there is a way to access your entire C:\ drive using the RC, but I have not tested it for anything but performing an off-line system restore (accessing the C:\System Volume Information folder to use the system restore points) as described in the following link ...
System Restore from Recovery Console
http://2pure.net/index.php?session=0&ac ... 1150238652
(There are a few mistakes in the the instructions text, but simply ignore those.
There is a significant mistake in Step #6 when changing the prompt back one directory level: This is given as cd..
In fact you must enter a space between cd and the two dots, so that it looks like this cd .. )

It seems that by "disabling" the system file
C:\windows\system32\config\system <<< file
access can then be gained to other areas of the hard drive that would otherwise return an "access denied" message. "Disabling" of the system file is achieved by renaming the system file to "system.bak" (not a good choice of name since it may already exist, and I would suggest using something else, like "system.old") and then re-starting the Recovery Console by booting the computer from the CD again.

I am inclined to think that performing an off-line system restore as outlined in the above link, may get your system back up and running again.

I followed the instructions on the links and have had no result.

Then, while reading the same information, I headed over to the recommendations that Dell had to disable files:

I tried to disable the files, but some were unsuccessful.
disable avgMfx86 - successfully disabled it
disable avgMfa86 - file not found
disable avgldx86 - successfully disabled it
disable avglda86 - file not found


Next, I've emailed AVG technical support a few more times to see if they could suggest anything else, or support me further, and have not heard one word from them.

After that, in desperation, I decided to disable everything AVG that boots up in my system (using a listsvc in windows recovery area).
I disabled these files:

When I rebooted my machine, still not able to get into Windows normally, tried Safe mode, and now my system halts at this file:

I have tried to contact AVG support again today, with no success, and now the forums aren't even working on their site. I get a message that reads:
An internal error occured

Sorry, the page you have requested cannot be displayed now. Please try it again later. It is also possible that the link you clicked is out-of-date and the information has been moved. In that case please use one of the following links to continue:
and they post links to the support/forums area which do not work right now.

Is there anyone out there that can help me? I do not want to wipe my HD because this is an AVG issue, and I know it can be fixed with the right support, IF I can find it. Also, I do not believe this is a problem that I should have to fix, everything on my machine was perfect until the AVG update on Wednesday night.


Discussion is locked
You are posting a reply to: AVG update - computer will not boot now!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: AVG update - computer will not boot now!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Technical support
by Dusan_AVG / February 11, 2010 2:29 AM PST


Could you please give us some of the Case IDs used to contact our technical support so we can check what happened with the communication?
AVG# or G# numbers.

Also, it may take some time to get reply from our techsupport due to larger amount of queries submited.

Thank you for your understanding.

Collapse -
Case # for you
by erin_mcg / February 11, 2010 2:54 AM PST
In reply to: Technical support

Thanks! Here is the case #
Case AVG#0000249772: [ ref:00D4000000086fU.50040000009ruud:ref ]

Please let me know if you need anything else. I really need to resolve this!!!

Collapse -
Re: Case # for you
by Ondrej_AVG / February 11, 2010 3:48 PM PST
In reply to: Case # for you
Collapse -
Case # for you
by erin_mcg / February 11, 2010 4:49 PM PST
In reply to: Re: Case # for you


I have tried the step as recommended by the moderator. It did not help.

Please read my original post carefully, as I have disabled most of if not all of the boot records for AVG in the boot sequence. Now my system halts at mup.sys.

Still cannot get into Windows in any way.

I hope to hear from someone sooner than 6-8 hrs after this post. My machine has been down for 3 days now, and I have a lot of work piling up!

Please, please help.

Collapse -
by Ondrej_AVG / February 11, 2010 7:25 PM PST
In reply to: Case # for you
Collapse -
Paying to break your computer
by Shawn Claypool / February 14, 2010 2:09 PM PST
In reply to: Case # for you

Yeah, what is AVG doing to fix this?
My Aunt recently actually bought and paid for AVG, only to have it turn around and break her computer(2/09/10 after the definitions update) beyond any quick and simple fixes. I can't even get safe mode working either. I have renamed all the associated avg files within the C:\Windows\System32\Drivers\ folder, but as you say it just crashes at mup.sys now. I've taken the drive out and through SATA to USB conversion successfully performed chkdsk on the drive.

Please let me know what can be done or if avg has compiled some kind of script I can run to easily repair this.

Collapse -
Re: Paying to break your computer
by Ondrej_AVG / February 14, 2010 10:10 PM PST


the "avgidsxx.sys" and then "mup.sys" crash issue as described by "erin_mcg", was discussed with product specialist and he has pointed the reason of this to corrupted operating system, where repair option (from installation CD, without formatting, not new installation) is needed.


Collapse -
So repair Works?
by Shawn Claypool / February 14, 2010 10:22 PM PST

Ok, so the repair option ended up working for him?
Thats what I'll try then, the only issue with that is my Aunt doesn't know what the "Admin" password is for the install, and I haven't been able to guess it yet.

Collapse -
Yes, repair DID work!
by erin_mcg / February 14, 2010 10:38 PM PST
In reply to: So repair Works?

Hello Shawn,

I just wanted to let you know that with the help of AVG support specialists, the Windows repair did work for my machine.

Also, I wanted to share this link with you because I feel this may have been the cause of my dilemma...


I have sent this link to AVG, and they cannot confirm that this was in fact the reason for my system crash, but it makes me think that it may not have been AVG's software... actually, I am thankful that AVG did what it is supposed to do, which is prevent damage to my system.

I would try the repair of Windows, and continue to work with AVG to see if you can correct your situation.

Have you tried leaving the password blank for the Admin password? If you just hit enter when the prompt comes up, it just may get you in.

If you are not able to get in as Admin, then you may have to do a fresh install of Windows, but I am NO expert by any means, so there could be some other way in, but I just don't know how to with out the Admin pwd.

Good luck!

Collapse -
Still Nothing
by Shawn Claypool / February 17, 2010 8:57 PM PST
In reply to: Yes, repair DID work!

Ok Well still not making any progress past trying to boot in safe mode, then reboots on "mup.sys". I've followed the instructions at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q307545 but can basically only do part one of the instructions, since safe mode still doesn't work.

I have been able to recover the administrator password, to get to the recovery console, and I also have an external STA-to-USB convertor to hook the drive up to my computer. I've performed multiple chkdsk operations as well, as an external drive & within the recovery console.

What can I do to get this working without reformatting?

Collapse -
Re: Still Nothing
by Ondrej_AVG / February 17, 2010 10:39 PM PST
In reply to: Still Nothing
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.