Computer Newbies forum

General discussion

Automatic redirect

Just today, my computer browser started redirecting me to gateways "could not find the page you were looking for" page. this page also has a bunch of sponsers listed on it. It only seems to happen when I visit a yahoo groups forum that I am subscribed to. I can go to the forum home page but after I click on a title message, I get about two seconds of reading the message before I am redirected to the Gateway page. This morning I downloaded a hosts file and am wondering if that could be the cause. Any idea of how I can fix this?
Thanks for your help.
John
Win XP Media Edition
IE7

Discussion is locked
You are posting a reply to: Automatic redirect
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Automatic redirect
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
And Did You Try??

In reply to: Automatic redirect

...removing the new HOSTS file? OR....opening the HOSTS file and removing the URL to that particular page?

Hope this helps.

Grif

Collapse -
hosts file

In reply to: And Did You Try??

I started finding more web pages that would redirect so from a search, i found a fix that said to rename the file(s) so I found where the hosts file was located and there were 4 or 5 different files named hosts. I renamed them to hostsold and rebooted. That seemed to solve the redirect problem but does that mean I will not be able to use a hosts file now?
Thanks.
John

Collapse -
John, Here's How To Continue Using HOSTS...

In reply to: hosts file

First, go back and rename the HOSTS files back to their original names.. IN regards to the HOSTS file that you're going to end up using, REMEMBER, it must be named HOSTS with NO FILE EXTENSION in order for it to work.. (You'll need to have all file extensions showing and it can't have a file extension such as .txt at the end.)

I use an extremely large HOSTS file by HpGuru (now HpHOSTS) and I edit it substantially each time I replace it with an updated version.. IN order to edit the HOSTS file, double click on the true HOSTS file which should reside in the C\Windows\System32\Drivers\etc folder.. If it's the correct HOSTS file, an "Open With" window should load which asks you to "choose the program you want to use to open this file".. Scroll through the programs and double click on "Notepad".. When Notepad opens, you should see a HUGE list of websites that belong to the "banned" list.. In order to edit the list, click on "Edit" in the upper left, choose "Find Next", then type in the name of the website you want to allow.. (For example, typing in "myspace" might bring up a number of listings where those letters are used.) Find the EXACT website of your choice, highlight it, then press the "Delete" button and the website listing will disappear.. Pressing the "Backspace" button now will cause the extra space left by the deletion to be removed.. You can search for all listings with the "myspace" letters, or your website of choice, by repeatedly clicking on the "Find Next" button.

One other note about using a HOSTS file.. Make sure to disable the "DNS Client" service like this. (The DNS Client service will cause a huge slowdown in your computer when a large HOSTS file is used.) : Click on Start-Run, type: services.msc, then click on OK. When the "Services" windows loads, scroll down till you see the "DNS Client" listing and double click on it.. When that window opens, in the "Startup Type" line, use the drop down arrow to select "Manual", then click on the "Stop" button in the "Service Status" section.. When that's done, click on "Apply".

Hope this helps.

Grif

Collapse -
(NT) Thinks I got it. Ur the man Grif!

In reply to: John, Here's How To Continue Using HOSTS...

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.