Linux forum

General discussion

Auto mounting NTFS drives

by Adi / April 11, 2008 11:38 PM PDT

Hi,

I'm using Fedora 8 and every time I boot, my two other Windows NTFS partitions are automatically mounted. I'm not sure what is doing this! I can't remember how they originally got mounted, but I'd prefer to change how they are mounted as the folder they are mounted into varies which makes accessing music through RhythmBox awkward, for example. I know a much better way to mount drives is through the fstab, but I want to stop this automounting first. What program is doing it?


Thanks in advance,
Adi

Discussion is locked
You are posting a reply to: Auto mounting NTFS drives
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Auto mounting NTFS drives
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Look to see if you have SMB/CIFS enabled
by welrdelr / April 13, 2008 12:04 AM PDT

You will need to disable both in the services.
As root, mount the partitions as read only with "mount -t ntfs -o ro /dev/windows-partition-you-wish-to-mount /mnt"
You can also make it to where all user accounts can mount but only with read only.
See the man pages for chmod and chattr.

If NFS is enabled, disable if you are not using a network.

Collapse -
Thanks for your reply
by Adi / April 16, 2008 8:52 PM PDT

I looked for SMB and CIFS and couldn't find them in the services list. I did notice netfs and tried disabling that but it didn't seem to make any difference. I've looked in all the config files for automount/autofs and can't find any reference to the drives that are being mounted (or in fstab). Any more ideas...?


Cheers,
Adi

Collapse -
AMD Auto Mount Daemon
by welrdelr / April 17, 2008 6:13 AM PDT
In reply to: Thanks for your reply

You may have to disable the amdaemon to see what program is accessing the drive. Only make this temporary.
Do you have any programs that require access to a ntfs partition?
Also, you need to do a search of which RPM s you have and see which would use auto mounting.
If no help here, try the Fedora forum.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!