HolidayBuyer's Guide

Computer Help forum

General discussion

ATTRIB command not working; registry corrupt

by pctech2112 / October 13, 2005 3:20 PM PDT

hi folks,

attrib command not working; registry corrupt

can someone help me please....

i'm unable to use the DOS attrib command on a w98 dell pc. i have used this command successfully before on other PCs. the registry is suspected to be corrupt.

used w98 boot disk and
in order to see system.dat & user.dat so i can rename and use the .bak i have to unhide and show all system files, so the command is:

c:\windows>attrib *.* -h -s

i get: bad command or not found

no matter how i say it or what folder i'm in, i get the same thing.

Discussion is locked
You are posting a reply to: ATTRIB command not working; registry corrupt
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: ATTRIB command not working; registry corrupt
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: attrib not working
by Kees Bakker / October 13, 2005 7:50 PM PDT

Pctech,

This (luckily) has nothing to do with the registry. It's a socalled 'external' DOS-command, i.e. a program that's supposed to be in c:\windows\command in Windows 98. And, if you're not in that directory, it should be included in the path (and if you boot from a boot diskette, that's not likely to be so). All very regular very old DOS-stuff. Try:
cd \windows\command
attrib ...

If that doesn't work (because the program isn't there), just get the attrib.exe from the Windows 98 CD or the boot diskette or any other Windows 98 system. Whatever is the easiest for you.

I trust that you know what you're doing with the registry files. It's easy to mess it up. Can't you use scanreg /restore, or is a reliable backup too old?

Hope this helps.


Kees

Collapse -
Kee's response is correct...
by Edward ODaniel / October 14, 2005 3:37 AM PDT

but I would suggest taking advantage of simply setting your path.

Boot the floppy then issue the command SET path=a:\;C:\;C:\windows\;C:\Windows\command\ press the enter key and the commands you want to use should be available.

Collapse -
problem solved
by pctech2112 / October 14, 2005 6:47 AM PDT

thanks for your response.

yes, both of you are correct. and yes my subject line has two problems which are not related to one another.


i COPIED the attrib file from c:'s command folder to a: the attrib worked since i did not get the bad command error. it is important to point to the proper dir as well. so the fix was:

a:>attrib -h -s c:\windows\*.*

i guess one of the startup disks had the attrib on it since i had done this on another pc.

equally disturbing was hearing my mother tell me i told her to do back-ups every 6 months. uhhh, no that was fertilizing the yard...

registry is AOK now, back-ups are taking place, and don't ever use the program system suite. at least with regards to their registry cleaner & fixer which turned a 10mb system file into a 2,806kb with 84% defragmentation.

for those new to a corrupt registry--FYI:
First reanme system.dat:
c:\windows\>ren system.dat systemold.dat
c:\windows\>ren user.dat userold.dat
Then restore backup
c:\windows\>copy system.bak system.dat
c:\windows\>copy user.bak user.dat

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.