HolidayBuyer's Guide

Computer Help forum

General discussion

ATI driver newer than 10.3 not working

by askkak / August 5, 2010 8:02 AM PDT

Some how i been unable to install new driver for my power colour hd5770. they latest one i able to install is 10.3. somehow newer driver never work. even when i go to check install log. it say everthying is fine. but when i reboot after installation. it say driver may not installed properly. i even when as far as reinstalling my window 7 32 to wipe all file. but still doesnt work.


here a few thing i notice.

the 10.3 is call 10-3_vista32_win7_32_dd_ccc_wdm_enu
while anything newer is called 10-7_vista32_win7_32_dd_ccc_enu notice no wdm


also when i install 10.3. it flicker to low resolution back to high resolution. while newer drvier flicker to low resolution and stay at low resolution.


i am runing window 7 32bit. can anyone tell me what wrong? and how to install newer driver?

Discussion is locked
You are posting a reply to: ATI driver newer than 10.3 not working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: ATI driver newer than 10.3 not working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Need a little more detail.
by R. Proffitt Forum moderator / August 5, 2010 9:32 AM PDT

This is a common complaint for AGP cards but your post lacks details.

Collapse -
I have had similar happen with older ATI cards
by Steven Haninger / August 5, 2010 6:48 PM PDT

but I don't think it has anything to do with the manufacturer. Unless a new feature you want or a fix for a problem you are having is included in the new driver, just wait it out for a few months. Once I had to go over six months months until ATI got things sorted out. As well, I only download and install drivers and not their Catalyst suite. I'll suggest you try skipping a few of their monthly updates for the time being.

Collapse -
eeeeeeeeeeeeehhh?
by askkak / August 5, 2010 6:54 PM PDT

but i waited for like 5 months.

what detail you want?

i am runing window 7 how premium 32bit . powercolour hd5770 play edition.

Amd phemon 9650 quadcore processor 2.3 ghz
4G Ram . directx 11

Collapse -
oh
by askkak / August 5, 2010 7:07 PM PDT
In reply to: eeeeeeeeeeeeehhh?

i just found something in the release not of 10.7

WDM drivers are no longer bundled in the ATI Catalyst?
software suite. The WDM drivers install bundle can be downloaded
independently through the AMD website.

what is WDM driver? 10.3 has it. and it work. should i go download it ?

Collapse -
All I have read about WDM says it is used
by Steven Haninger / August 5, 2010 7:38 PM PDT
In reply to: oh

for video capture but I don't know what else. I have an ATI card in my own machine and have the 10.7 driver installed without issues. I didn't separately install anything else. I've built quite a number of PCs using ATI cards (when it was really ATI and not AMD) and never had a problem I couldn't sort out with a little patience. If this meant waiting a few months, so be it. You can always try installing the WDM component if you wish. Personally, if my machine was working satisfactorily with an older driver, I'd not lose a wink of sleep over this. You might try the PowerColor site to see if other's are experiencing your issue.

Collapse -
why cant i edit post?
by askkak / August 5, 2010 7:39 PM PDT
In reply to: oh

is it a pcie not agp

Collapse -
The edit feature has never been in this forum.
by R. Proffitt Forum moderator / August 5, 2010 9:35 PM PDT
In reply to: why cant i edit post?

And has been explained. Please reply to yourself or others when the details need to be added.

As this is not AGP, then it's time to ask the card maker how to use the later drivers.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.