Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Windows 10 forum

General discussion

Another network connectivity post but with strange findings

by Steven Haninger / January 28, 2018 3:01 PM PST

I've been trying to resolve a connectivity issue in a school with what seems to be a specific group of computers all of which have the same MB. The strange finding is that, if I bring home one of these PCs that misbehaves on the school network, it works fine at my place. What will happen is when the computer is started, the network icon will show no connection. Checking device manager finds the network device to say it cannot be started and that it does not exist. I can find references to this exact message on the web. What I also see is that the devices shows as an Intel 82579LM. I can temporarily correct this by going to the programs and features and uninstalling the network software and driver and installing the latest from Intel. The device now shows as an Intel 82579V and works fine. If I restart the PC it may work fine until shut down and restarted. It will then revert back to misidentifying the device with the LM suffix. The school has 12 of these in the lab and all of them will do this. I have tried older drivers and the symptoms don't change. Once the PC has gone through 2 restart cycles, the network device fails to start. Why I cannot simulate this in my home is a puzzle. I could wonder if it's related to something in the network cabinet. There are 3 switches connected to a Cisco layer 3 switch in daisy chain fashion. I don't see anything that suggests there are loops. I can move the 12 PCs to other switches but the symptoms don't change. I can connect PCs directly to the Cisco router/switch and get the same odd results. I'm at a loss here and need some other things to try. These are older Intel boards but are at the most current BIOS level which was to make them compatible with Windows 8. It's quite possible that they're not all that good with Windows 10 but the upgrades, against my advice, were allowed to take place about 2 years ago...nothing but trouble since then. Any thoughts out there? TIA

Post a reply
Discussion is locked
You are posting a reply to: Another network connectivity post but with strange findings
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Another network connectivity post but with strange findings
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
What I find with this story,
by R. Proffitt Forum moderator / January 28, 2018 3:46 PM PST

Is the usual. I take one of the bad machines and update the BIOS then go get the drivers for CHIPSET (always do this first) then the Ethernet and install those in that order. I find a lot of IT staffers have not lived with Windows long enough to know driver swamp rides like this.

If this fails we pop in PCI or PCIe network cards and move them out. Only the newest IT will spend more time on this.

Collapse -
I'd considered the add-in card option
by Steven Haninger / January 28, 2018 4:33 PM PST

as a last resort until I brought one of the PCs into my home and, try as I may, I cannot get it to misbehave. The machines are already at the latest Intel BIOS and the Intel drivers are also current. The board, however, was not supported past Windows 8.X by Intel. I was surprised that MS insisted it was a candidate for Windows 10 and hounded the new tech coordinator to allow the upgrade. The rest is just bad history. Thanks for the thoughts. I may try a new NIC if no one has a magic cure. This all seems to have happened currently with the recent MS updates and, maybe if enough complaints, MS will fix it. Thanks

Collapse -
Wait. It works fine on another network?
by R. Proffitt Forum moderator / January 28, 2018 4:50 PM PST
Collapse -
That's the strange part
by Steven Haninger / January 28, 2018 5:28 PM PST

When it's working, the device is recognized as an 82579V with an Intel driver. When it's not working, it's an 82579LM with a driver from MS. I'm of the impression that the LM was for laptop and mobile devices but I could be wrong. The latest 22.10 driver is what I installed. It's strange, however, that drivers with a higher rev. # such as 22.7 are actually earlier drivers. I've tried several with the same effect. As for DHCP reservation, I don't know. The first 50 addresses are reserved for static use but these PCs are set to the request an IP. But, I don't know that they even get to that point if the device, as the message will say, cannot start and that it does not exist. What I may try, if opportunity presents, is to just do a network reset on all of these. I don't have Win10 so am not that comfortable with it yet. I'd hate buy new NICs and find this to be something external to the PCs but I cannot explain why the one I brought home acts differently here than there. Cave people didn't have it so bad.

Collapse -
MS drivers are not great to see.
by R. Proffitt Forum moderator / January 28, 2018 5:30 PM PST

Boot safe mode to see if you can uninstall that version. In a pinch I've had to note the files and manually nuke them.

Collapse -
Done that through device manager but not safe mode
by Steven Haninger / January 29, 2018 1:44 AM PST

The other oddity is that, when this happens and I run ipconfig /all, I get no host information whatsoever. If I try to ping the router at it's known address, I get zero lines of information about any attempt being made. To me, this sounds more like a hosed device or driver issue but I'm at a loss as to why it works so well in my home. There are plenty of other PCs in the school used by teachers and I know of no connectivity complaints by them. They'd be the first to holler. There is also a Lenovo brand "Think Station" in the lab with a similar Intel network device that gives no trouble. Thus far, this issue is only seen with the ones using the Intel DH61CR MB so this issue defies all conventional logic. There had been issues with connectivity a while back when devices could not get an IP address due to none being available. That was resolved by trimming the lease times from 24 hours to 30 minutes. The school does have enough devices to push the IP address limit but most of these are such as iPads and Chromebooks which are in carts. Since I was there yesterday (Sunday) when no classes were being held, the idea of there being a shortage of IP addresses goes out the window. When my wife retired as the tech coordinator there, I warned the new person to continue the fight with the Windows 10 nags and don't let the devil enter. I advised to only do this when it was time to buy new PCs. Stuff happens.

Collapse -
A network card is usually the fix for this.
by R. Proffitt Forum moderator / January 29, 2018 7:54 AM PST

If you can't get the drivers under control (all covered in Microsoft training which I can't replace here) then get a NIC, test and deploy.

Collapse -
Finally, a possible solution

After failing to fix this after many hours of trying, I replaced all of the on-board Intel network devices with Realtek add-in cards. This took care of it in the computer lab. Later, I had the same issue show up in a classroom. The OS had become corrupt and I needed to do a complete reset of Win10 to resolve it. But, in the process, I'd also updated the BIOS which seemed a good idea as the previous BIOS was only to support to up Win7. Within a few days, this PC began exhibiting the same problem as the previous ones in that, after turning it off and back on, the Intel network device was misidentified and would not function. I had already turned off, through group policy editor, the function which allowed MS to update drivers but it must have been too late. What has worked so far is to turn turn off Windows 10 "fast startup" feature and disable it's ability to turn off the network device to save power (through power management utility). I could easily reproduce this problem. All was OK with a warm boot but a cold boot messed up and loaded the wrong driver for the network device. FWIW, that device was the Intel-8259V which was being identified as the 8259LM.

This is a bit late coming but hope it helps someone.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!