Mac OS forum

General discussion

airport connected but no internet

by daveed_o / October 21, 2006 5:19 AM PDT

ok so i've been tryin to fix this problem for a couple of days and its driving me crazy. i have a 13" mac book and i use a linksys wrt54g router to connect to the internet (this router is plugged to my PC which DOES connect with no problem).

When i open airport and connect to the linksys network it shows its connected but when i open safari it tells me "you are not connected to the internet" it seems i have a strong airport signal but cant go online, i checked system pref. on my mac and it says "airport connected to the network but it does not have and ip address or cannot connect to the internet"

I've called linksys and apple and they cant seem to give me an answer. Ive tired everything they've told me and NOTHING works. im so frustrated with this. can someone help me plz? i would really apreciate it

Discussion is locked
You are posting a reply to: airport connected but no internet
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: airport connected but no internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by mrmacfixit Forum moderator / October 21, 2006 5:35 AM PDT

Take a look at the wireless settings on the Router and make sure that the router is acting as a DHCP server.
This would be where the Mac gets its IP address from. If that is not set, then the Mac will not connect to the outside world.
Even though the Mac can "see" the wireless signal, it still has to join the wireless network before anything will work as expected.

What happens when you tell the Mac to join this network? Any dialog boxes?
Did you make the network a closed one with a password?

What happens when you run the Airport setup Assistant?

I'm sure that the Mac will connect to the Internet if it was directly connected to the Router, like the PC. You could try that just to satisfy your curiosity. It would not really prove anything but it might make you feel better.

Good Luck


Collapse -
re: router
by daveed_o / October 21, 2006 6:38 AM PDT
In reply to: Router

i did check my connection, it says its using DHCP but no ip addreess or subnet mask shows up.

when i want to join the network it does show me a dialogue box. It tell me to write the WEP password, which i do and it connects. but thats about it, no internet

i also ran airport setup and it cant find any base station.

when i plug the ethernet cable from my modem to my mac, internet works perfect.

i still dont know what to do, thanks for the help

Collapse -
(NT) (NT) Is SSID enabled or disabled?
by R. Proffitt Forum moderator / October 21, 2006 6:52 AM PDT
In reply to: re: router
Collapse -
by daveed_o / October 21, 2006 7:12 AM PDT

yea its enabled

Collapse -
Ok, what happens if..
by R. Proffitt Forum moderator / October 21, 2006 7:15 AM PDT
In reply to: re:

We use no encryption and enable MIXED MODE (on the router)?


Collapse -
by daveed_o / October 21, 2006 8:03 AM PDT
In reply to: Ok, what happens if..

same thing. no internet

trust me i've tried everything like that and it doesnt work. thats y it gets me so frustrated cuz anything i try doesnt work.
what really bothers me is that i think there has to be some little setting i have to change but i just cant seem to know what it is

Collapse -
Does it connect at hot spots?
by R. Proffitt Forum moderator / October 21, 2006 8:21 AM PDT
In reply to: re

Also, there was this other discussion where the antenna was not plugged in. Anyone been inside this machine?


Collapse -
by daveed_o / October 21, 2006 8:46 AM PDT

yea i was able to connect to the wireless from my school with no prob. do u mean the antenna from the router? cuz its brand new i just exchanged it for a new one cuz i thought it was the router

Collapse -
There's a clue.
by R. Proffitt Forum moderator / October 21, 2006 8:52 AM PDT
In reply to: re

Since you exchanged the router it's a fairly safe bet the router firmware is out of date.

Let me ask a silly question. Your first post noted the router connected to the PC but the more usual setup is to connect the router to the DSL/Cable modem then the PC to the router. That is...

DSL/Cable -> Router -> PC/Macs.


Collapse -
by daveed_o / October 21, 2006 9:04 AM PDT
In reply to: There's a clue.

yea i updated the firware and everything like that.

yea its connected how u said. i guess i didnt specify that. but it still doesn nothing

Collapse -
Then some setting is wrong or the router is incompat.
by R. Proffitt Forum moderator / October 22, 2006 1:30 AM PDT
In reply to: re

The remaining item I didn't note is distance. Some tried this setup with the Mac some hundred feet away. When first starting, all the defaults on the router, no security, don't disable ssid, etc.

If that doesn't work, get a different router model.


Collapse -
Is there an antenna on the router?
by R. Proffitt Forum moderator / October 22, 2006 1:31 AM PDT
In reply to: re

One owner thought it was optional. "Hey it worked without it."


Collapse -
Same problem
by Pachacuti / October 29, 2006 9:55 AM PST

I have the same problem, same computer (MacBook 13"), same router (Linksys WRT54G). I saw all the messages and see there's no solution yet Sad

Collapse -
Found a solution
by Pachacuti / November 1, 2006 1:11 PM PST

I hope this helps you too.

What I did (with the help of Linksys Live Chat support) was to set a static IP in my MacBook and it worked! Happy

Collapse -
It will if
by mrmacfixit Forum moderator / November 1, 2006 8:55 PM PST
In reply to: Found a solution

the modem also acts as a DHCP server. The ones that BellSouth uses here are Modem/Routers(DHCP Servers) which push out IP addresses to whatever is connected to them. Placing another Router(DHCP server) in the system causes complete confusion. Disabling the Linksys DHCP will allow the modem to act as the sole DHCP server and all should be well.

If you have another machine on your network, see if you can share files using that working setup.


Collapse -
need Linksys help, too!
by caribsea / November 16, 2006 5:39 AM PST
In reply to: Found a solution

G4 PB OS 10.3.9
Alacatel Speedtouch Home to Linksys RT21P2 to Linksys BEFW11S4 wireless 802.1B

Sending this from my PC laptop which works with the wireless network, as it always did.

I've used this system successfully and with absolutely noproblems until I went on a trip and used the G4 in a notel room with wireless Internet access. Since I've been home, it doesn't work. I believe it's looking for the hotel settings but I don't know how to reset it. I've been on with Linksys for hours, disconnected from Live Chat twice and have received unhelpful info from their email. I also tried a suggestion from a Google search. At this point, I've fooled around with every thing that could be changed and need to start over. The weird thing is that once in a while it will work for a minute, then the Airport icon goes grey again. I'm getting desperate!

Collapse -
by mrmacfixit Forum moderator / November 16, 2006 7:38 AM PST

When you click on the Airport Icon, do you see your network or do you see another network?

When you go into the System Preferences and SINGLE click the network icon, you should see a list of possible connections.
One of them should be Airport. Single click on it and choose Assist Me. Choose Diagnostics from the first window. If all is well, and it should not be, choose Assistant and let it walk through the set up.

When the Airport icon goes "grey again" does is still say Airport On?


Collapse -
no "diagnostics"
by caribsea / November 16, 2006 1:07 PM PST
In reply to: Airport

"When you click on the Airport Icon, do you see your network or do you see another network?"

Sometimes I see Linksys and sometimes I don't. If I click on Linksys I get "There was an error joining the AirPort netowrk "Linksys."

"When you go into the System Preferences and SINGLE click the network icon, you should see a list of possible connections.
One of them should be Airport. Single click on it and choose Assist Me. Choose Diagnostics from the first window."

I don't see a Diagnostics option.

"If all is well, and it should not be, choose Assistant and let it walk through the set up."

In the Network systems panel after running Setup Assistant, the AirPort selection reads: "AirPort is connected to the network linksys. AirPort has a self-assigned IP address (and now system preferences unexpectedly quit. Within the Network Setup Assitant, a message reads: Unable to establish a network connection. Your computer culd not connec to the Internet. Clik OK to go back and change your network settings and try again."
Now the Airport icon in the menu bar has gone from gray to partially black to completely black and back to partially black.
I've been working on this since early this morning and now have to go to bed. I hope tomorrow will bring a solution. Thanks for your help.

When the Airport icon goes "grey again" does is still say Airport On?

Message was edited by: admin to remove email address

Collapse -
"Diagnostics" is a 10.4 thing, sorry
by mrmacfixit Forum moderator / November 16, 2006 8:53 PM PST
In reply to: no "diagnostics"

Even when the Mac is connected to the Linksys, it does not seem to be getting an IP address from it. The self assigned IP address, which is probably 169.x.x.x indicates the system did not receive anything.
Usually the system will send a request to the DHCP server, the Linksys, for an IP address but apparently not in this case. While the machine can actually "see" the Linksys, reboot it. Check the IP address again.
If that fails and you still get the self assigned IP address, go one step deeper into the Network Pane and click on Renew DHCP Lease. The IP address window should change.
While you're at it, check that the Linksys is still acting as a DHCP server and that its settings have not changed.


Collapse -
email address
by mrmacfixit Forum moderator / November 16, 2006 8:56 PM PST
In reply to: no "diagnostics"

I forgot to mention this.

It is never a good idea to put your email address on public display in any forum. Email bots harvest email addresses from them.

CNET has a facility whereby you can put your email address in your profile, along with an Email Me button. This is information is stored elsewhere and is not susceptible to snooping


Collapse -
Having the very same problem.
by direct45 / November 26, 2006 3:52 AM PST

I just got myself the new C2Duo MacBook, and have the same make/model router that you list here, with all the firmware updates, and am having the exact same problem. Did you ever find a solution?

Collapse -
Similar Problem
by nickmoswen / November 27, 2006 1:31 PM PST

I, too, am using the linksys wrt54g wireless router. About a month ago my wife's 13" powerbook stopped getting on the internet even though it was connected to the router and had received a valid ip address and showed up in the routers DHCP clients table. My Windows/IBM laptop could connect wirelessly no problem. I plugged her laptop into the router via one if its wired ethernet ports and everything worked fine.
After about a week of having an ethernet cable running from the living room into the bedroom, I tried to connect her powerbook wirelessly and it worked! I hadn't changed a thing. Skip forward to last week. I got my new C2Duo MacBookPro home, set it up and got online wirelessly without a problem. Then I went out of town over thanksgiving weekend, and connected my new MacBookPro to many different wireless networks. The router at home had been unplugged while I was out of town. When I got home and powered it up my MacBookPro would connect to the router, but couldn't surf the web, just like the problem my wife had with her powerbook just weeks before. Here's the kicker...her powerbook, which had been everywhere my new MacBookPro had been over the holiday, could surf just fine. I still haven't been able to get online with the MacBookPro. Amazing.

Collapse -
What's the deal with this?
by Control301 / November 28, 2006 6:17 AM PST
In reply to: Similar Problem

Works wired, but not wirelessly. I updated the firmware earlier last week and everything was fine until Friday. All of a sudden no interweb!

Nothing was changed (besides that router firmware update) to any of my wireless macs. Of course, my pcs can connect sans wires.

Best of all, Linksys' answer (given after two and half hours on the phone) was "we don't really support mac, but we can swap out your router for a new one."

I'm guessing the new one isn't going to be of much help. My father had the same issue with his WRT54G v5 and his macs. I'm really curious to know what is going on here.

Collapse -
New Linksys firmware solves DHCP issue in WRT54G
by imajedinite / December 1, 2006 7:43 AM PST

Linksys has released a firmware upgrade for the WRT54G v5 and v6 that should fix the problem. Apparently there was an issue in the way the router assigned IP addresses to Mac clients. For more info: <a href="">macnewsonline</a>.

I tested it out using my Intel and PPC computers. The new firmware seems to fix the problem.

Collapse -
Good News
by mrmacfixit Forum moderator / December 1, 2006 11:04 PM PST
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.