PC Hardware forum

General discussion

AGP cards only recognized as PCI

by eCobwebs / February 23, 2004 8:06 PM PST

I have just gone from Windows 2000 to Windows XP Professional, full, clean install, and now my graphics card is being recognized only as a PCI card (under the cards properties it says that the location is PCI 1), also I know that it there is a problem because every time I load up Savage, it tells me that my card is in PCI mode and this will cause problems, which it does. I have tried uninstalling the card, reinstalling it, using an older card (that still came up as PCI), and had no joy with anything.

My PC Specs are as follows:

Windows XP Pro SP1
Abit AT7 Max2 Motherboard
AMD Athlon XP 2600+
Galaxy Geforce FX 5200 (the other card I tried was an ABIT GeForce Ti 4200)
1GB PC2700 RAM

NOTE: I have noticed a few people suggesting that you need to reformat reinstall to resolve this problem, however, seeing as that's what I have just done, I don't see how that would have any effect.

Any ideas or suggestions would be much appreciated.

Cheers

Ben

Discussion is locked
You are posting a reply to: AGP cards only recognized as PCI
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: AGP cards only recognized as PCI
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re:AGP cards only recognized as PCI
by R. Proffitt Forum moderator / February 23, 2004 8:49 PM PST

This is a cosmetic item with no real effect.

I would not fix this.

Bob

PS. You didn't note if the BIOS and motherboard drivers were current.

Collapse -
Did you install the motherboard drivers.
by R. Proffitt Forum moderator / February 23, 2004 9:29 PM PST

For reference, another discussion about it:

"I fixed this on my computer. I have a Ti4600 on an Asus P4T-E
motherboard. Any time I went to the adapter settings screen I saw
that it said my card was AGP running in PCI mode. After a lot of
reading and searching, I read on Intel's site that you need to run an
Inf updater to get this motherboard (and 100 others) to communicate
properly with the AGP slot. I looked up the files for my chipset
(I850) and downloaded the Inf updater. I ran the updater (had to
unzip it and then run the 'setup' program) and rebooted my computer.
It found all kinds of new hardware for the bridges and installed it
automatically. "

Collapse -
Re:Did you install the motherboard drivers.
by orubassman777 / February 25, 2004 11:47 PM PST
Collapse -
In closing, my best advice is to not fix this. Unless there is a "broken", don't "fix."
by R. Proffitt Forum moderator / February 25, 2004 11:51 PM PST

The item in question has been spotted by me a few times and some descend in another spiral of problems as they "fix" such things.

Proceed with care.

Collapse -
Re:AGP cards only recognized as PCI
by Willy / February 23, 2004 11:03 PM PST

Install using XP specific drivers for your mtrbd. video. If needed, try the latest ones available from the mtrbd. support website. Under the bios, verify what AGP setting are at, try going to a lower level just to get it to work and if does, goto the next level or higher rate. If capable, allow the bios to "use optium setting" or "safe setting" to restart that area. If all fails, simply "clear" the bios and then reset values.

FYI, I found video to be an increasing difficult area to work in lately. In many cases going back to older drivers or recheck the newest driver is a perfect match for the video card installed. So, I don't find your problem a lone one, others I'm sure have similar problems.

good luck -----Willy

Collapse -
Re:AGP cards only recognized as PCI
by orubassman777 / February 29, 2004 3:44 PM PST

Found out some stuff for ya. Turns out, when you see the location of the Video Card as "PCI bus 1", that is OK. If you want to make sure, download the latest drivers for your video card from NVidia's website (www.nvidia.com), or use Gainward's own drivers from their website. Also, if you are able to edit your registry (regedit.exe), go to the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak

Right-click the right side of the two "sides", then click on "New/DWORD Value". Name the value "CoolBits", then set it as "ffffffff". This will enable all the "secret" pages in the video properties page. Right-click on the desktop and then on "properties". Under the NVIDIA properties, go to where it (should) says "AGP Settings". On that tab, there is a slider that enables you to change from "PCI" to "AGP".

Collapse -
Re:AGP cards only recognized as PCI
by Scuffy / February 29, 2004 8:45 PM PST

Did you change the option in the CMOS to show you are running an AGP card? I believe the default for this setting is PCI.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!