Spyware, Viruses, & Security forum

General discussion

Adobe Security Bulletin: APSB07-01

Security bulletin
Update available for vulnerabilities in versions 7.0.8 and earlier of Adobe Reader and Acrobat
http://www.adobe.com/support/security/bulletins/apsb07-01.html
Release date: January 9, 2007

Vulnerability identifier: APSB07-01

CVE number: CVE-2006-5857, CVE-2007-0045, CVE-2007-0046, CVE-2007-0048

Platform: All Platforms
Affected software versions

Adobe Reader 7.0.8 and earlier versions
Adobe Acrobat Standard, Professional and Elements 7.0.8 and earlier versions
Adobe Acrobat 3D
Revision

January 9, 2007 - This Security Bulletin provides a solution for the issue originally documented in Security Advisory APSA07-01 on January 4, 2007, as well as other issues.

This Security Bulletin addresses several vulnerabilities, including issues that have already been disclosed. An update is available for a cross-site scripting (XSS) vulnerability in versions 7.0.8 and earlier of Adobe Reader and Acrobat that could allow remote attackers to inject arbitrary JavaScript into a browser session. This vulnerability, previously reported in APSA07-01 on January 4, 2007, has been assigned an important severity rating. Additional vulnerabilities have been identified in versions 7.0.8 and earlier of Adobe Reader and Acrobat that could allow an attacker who successfully exploits these vulnerabilities to take control of the affected system. These vulnerabilities have been assigned a critical severity rating. A malicious file must be loaded in Adobe Reader by the end user for an attacker to exploit these vulnerabilities. It is recommended that users update to the most current version of Adobe Reader or Acrobat available.

Solution

Adobe Reader on Windows

Adobe strongly recommends upgrading to Adobe Reader 8, available from the following site:
http://www.adobe.com/go/getreader.

Users with Adobe Reader 7.0 through 7.0.8, who cannot upgrade to Reader 8, should upgrade to Reader 7.0.9. Adobe Reader 7.0.9 is available as a full installation package and not a patch. It can be installed on top of any older version of Reader 7 and user preferences will be preserved:
http://www.adobe.com/go/getreader.

Adobe Reader on Mac OS

Adobe strongly recommends upgrading to Adobe Reader 8, available from the following site: http://www.adobe.com/go/getreader.

Users with Adobe Reader 7.0 through 7.0.8, who cannot upgrade to Reader 8, should upgrade to Reader 7.0.9. The Reader 7.0.9 update requires that Adobe Reader 7.0.8 is installed on your Mac system. To determine which version of Adobe Reader is installed, choose Adobe Reader > About Adobe Reader. The version number appears in the upper left corner below the Adobe Reader logo.

If version 7.0.8 is installed, download and install this incremental patch.
After downloading the update file, double-click it to begin the update process and access the file's contents.

If version 7.0, 7.0.1, 7.0.2, 7.0.3, 7.0.5, 7.0.7 or an earlier version of Reader is installed and customers cannot update to Reader 8, Adobe recommends that customers download the full Adobe Reader 7.0.9 installer from the Reader download page.

Adobe Acrobat on Windows or Mac OS

For version 7.0-7.0.8, users should utilize the product's automatic update facility. The default installation configuration runs automatic updates on a regular schedule, and can be manually activated by choosing Help > Check For Updates Now. Alternatively, the update files can also be manually downloaded and installed from www.adobe.com/downloads.

Adobe Reader on UNIX

For version 7.0, users should upgrade to Adobe Reader 7.0.9 from http://www.adobe.com/go/getreader.

For versions prior to 7.0, users should upgrade to 7.0.9 http://www.adobe.com/go/getreader.

Adobe is working on an update to versions 6.X of Adobe Reader and Acrobat that will resolve this issue. It is expected to be available in the near future. This Security Bulletin will be updated as soon as the update is available.

Server-side workarounds for website operators

Adobe has provided workarounds for website operators to prevent the cross-site scripting vulnerability (CVE-2007-0045) from the server side. Please review Security Advisory APSA07-02 for more information.

Severity rating

Adobe categorizes this as a critical issue and recommends affected users update any affected software.
Discussion is locked
You are posting a reply to: Adobe Security Bulletin: APSB07-01
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Adobe Security Bulletin: APSB07-01
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.