General discussion

Adding New Fonts to OpenOffice Fonts Menu

Dec 15, 2007 3:54AM PST

To Bob Proffitt:

Bob,

I am first reproducing in this new tread the essence of our previous Q&A, and then adding some information in view of your answer.

I have a certain font installed in my Vista Fonts menu, and I would very much like to add it to my Open Office Fonts menu. The procedure stated in OO's Help starts by saying: "Go to {install_path}/program directory; Enter: ./spadmin; Click "Fonts" "(and so on).
Exactly WHERE am I supposed to ""Go to {install_path}/program directory; Enter: ./spadmin; Click "Fonts"" (and so on)?

Thank you very much.

Chuck

................................................

From R. Proffitt Moderator - 12/15/07 11:10 AM

spadmin is primarily used by those on Linux. I have yet to run this on Windows (and would have to check if it is on Windows.)

In parting the usual reason is that the font is not shown because the printer driver is not installed (your post lacks this detail) or it's not showing in the Fonts tool in the control panel.

Remember to make a new post and add a few more details.

Bob

========================================================

Bob,

The font of interest to me is definitely there in my Vista Control Panel > Fonts menu, and I am also able to readily print on my Canon printer anything written by me in a Firefox Thunderbird emailing page using that particular font.

I did not comprehend the connection between a printer driver installation and installation of a new font in the Open Office Fonts menu, but since you asked for the information, I supplied the above information concerning printing on my printer some material written using that font in a Thunderbird email page. Were you looking for some different additional information from me?

Thank you!

Chuck

Discussion is locked

Follow
Reply to: Adding New Fonts to OpenOffice Fonts Menu
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Adding New Fonts to OpenOffice Fonts Menu
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Printer drivers and fonts.
Dec 15, 2007 3:57AM PST

I will not duplicate the long answers about how Windows tells applications what fonts to use based on the installed printers and which printer is default. I'm going to decline writing how that works.

But if the printer driver is installed and it's the default printer then all I've even needed to do is add the font with the fonts tool in the control panel.

Bob

- Collapse -
Details that might help.
Dec 15, 2007 3:58AM PST

The name of the font, printer and such.

- Collapse -
Bob, I'm sending some additional information
Dec 15, 2007 4:39AM PST

Bob,

I have only one printer connected to my computer, namely, Canon Inkjet i560. (It is set as my default computer.)

The name of the font which I would like to include in my Open Office Fonts menu is "BRH Devanagari." It is definitely there in my Vista Control Panel > Fonts menu (along with a few other "BRH" [Baraha] fonts like BRH Latin, BRH Tamil, and so on. Mysteriously, a subset of of those BRH fonts got automatically installed in my Open Office Fonts menu too but NOT the one, namely, BRH Devanagari, which I am interested in! In fact, I would like to get rid of all BRH fonts like BRH Latin EXCEPT BRH Devanagari from my Open Office Fonts menu. I expect that the same method which would help me add BRH Devanagari would help me get rid of the other BRH fonts from Open Office Fonts menu.)

Thank you for your follow-up help.

- Collapse -
I see some issues here.
Dec 15, 2007 4:45AM PST

I need to read other links that don't note items like "fonts of Baraha follow a proprietary encoding."

-> Proprietary encoding is bad news. I have my latest Open Office installed and if you can provide a link I'll test it here.

- Collapse -
I did not understand...
Dec 15, 2007 5:35AM PST

Bob,

Unfortunately, it went over my head completely as to what link you were asking me to provide you. Is it some link concerning some other font which I have installed in either my Control Panel Fonts menu or Open Office Fonts menu?? Where would I get that whichever link you were asking? I am sorry that I did not understand what you were asking for.

I did understand that because of the proprietary nature of encoding which fonts in Baraha follow, it may be difficult to figure out the solution to my original problem of getting BRH Devanagari included in the Open Office Fonts menu. I do not want to take up too much of your time about that problem of mine. It is not a huge problem, for I can write in BRH Devanagari at least in Thunderbird.

On the other hand, if you want me to supply you any information, I shall gladly do so on hearing from you.

Thank you so much.

Chuck

- Collapse -
In one sentence.
Dec 15, 2007 7:03AM PST

Tell me how to get the font so I can test it.

- Collapse -
Now I understand!...
Dec 15, 2007 8:22AM PST

Bob,

Now I understand which link you were looking for. It did not occur to me earlier that you would want to go through the trouble of downloading the software for installing BRH Devanagari on your computer and then figuring out the source of my problem in getting it installed in my Open Office Fonts menu.

I had downloaded the BRH Devanagari font by clicking on the icon which looks like two horizontal ellipses with two lines above each of those ellipses in:

http://www.baraha.com/baraha.htm

(I am interested only in the BRH Devanagari font out of the many fonts which the above link provides.)

Thank you for your interest and follow-up.

Chuck

- Collapse -
Works on my Windows 2000 workhorse.
Dec 15, 2007 8:36AM PST
- Collapse -
BTW. PS, etc...
Dec 15, 2007 8:38AM PST

To get to that font, I clicked in the font name bar then typed BRH D... and it showed the font in question.

- Collapse -
Problem Solved!
Dec 15, 2007 11:06AM PST

Bob,

From what you wrote in your BTW, PS note, it dawned on me why I was never having problem in typing in BRH Devanagari font in Thundebird, but I was not able to do so in an Open Office (OO) document until I got a hint from your above note!

My problem used to be this: Not finding the name of BRH Devanagari in my OO Fonts list, I used to think that I cannot write in that font in an OO document. I newly found that that was not the problem. What I needed to do was (and is) to turn on BRH Devanagari in VISTA, and that enables me to write in BRH Devanagari in OO REGARDLESS of what font name is shown in the OO's Font window!

Once I turn off BRH Devanagari and revert to English in Vista, whichever font I select from the available menu in OO's Font window becomes effective again!

It is a mystery to me why the name of BRH Dedvanagari is not there in my OO Fonts menu while names of some other BRH fonts (like BTH Latin and BRH Tamil, which I don't need) are there, but I delegate that mystery to the heap of other mysteries in Life! I am happy that my above problem is solved at the practical level.

..................................................................


Now, I have a diiferent, strange problem concerning fonts! I want to get rid of all BRH fonts EXCEPTING BRH Devanagari form my "Control Panel - Fonts" menu.

The straightforward procedure would seem to be to click on the name of an unwanted BRH font in my "Control Panel - Fonts" menu, and then click on the "Delete" option in the pop-down menu. However, after doing that, the BRH font meant to be deleted continues to remain undeleted!! What do I have to get rid of unwanted fonts?

Thank you very much, Bob, for all your help with my minor/major problems!

Chuck

- Collapse -
The reason I used the keyboard to get to the font was...
Dec 15, 2007 10:43PM PST

The font list gets too long and you have to scroll and scroll and scroll some more. I said the heck with that and used the keyboard method to jump to the font in question.

As to selective fonts try this. Copy the one font out that you want (the .TTF file) and then uninstall the BRD package. Now install that one font.

-> Let me be clear here. That package appears to use some proprietary encoding in the font package so it may not follow the rules as we know them.

Bob

CNET Forums

Forum Info