Networking & Wireless forum

General discussion

Ad-Hoc Wireless Network Connection Troubleshooting

by asym / January 6, 2005 10:21 PM PST

Hello mates, i hope someone can help me, cause i'm gonna get mad. I have been trying to setup an ad-hoc Wireless Network for the last 2 months now, and today i decided it's time to share this problem with you.

So, i have a Desktop Computer and a laptop, both running Windows XP SP2. I have a broadband connection, which i connect to using the Desktop Computer. The laptop (Aspect) came built in with a pcmcia card which is an Intel(R) PRO/Wireless 2200BG. I have bought a wireless network card also for my Desktop Computer which is actually a KLG-530.

The connection between the two machines gets established actually, cause when i switch on the laptop they both detect the wireless network, however there doesn't seem to be sending and receiving of packets, and unfortunately i don't seem to be able to share the internet connection and any other resources. Below are the settings i have actually tried.

LOCAL AREA CONNECTION (Desktop Computer (Server))

Internet Protocol (TCP/IP) Properties

IP Address:
Subnet mask:
Default Gateway:

Preferred DNS Server:
Alternate DNS Server:

and i have check "Allow other network users to connect through this computer's internet connection."



IP Address:
Subnet Mask:
Default Gateway:

Preferred DNS Server:
Alternate DNS Server:



IP Address:
Subnet Mask:
Default Gateway:

Preferred DNS Server:
Alternate DNS Server:


And about my Internet Connection Properties, Host name or IP Address of destination is set to

I have tried other configuations but they didn't work, maybe i am doing something wrong, can someone guide me pls? Maybe the 2 wireless adapters are incompatible with each other? But if this is the case..they wouldn't detect each other, no? sorry for my long post and thankx in advance for your help. I hope we will come to a solution.

PS: I have tried the option "Obtain an IP Adderss automatically" but it didn't work, Windows assigned a 169... ip address and a subnet mask, but it didn't set any gateway.


Discussion is locked
You are posting a reply to: Ad-Hoc Wireless Network Connection Troubleshooting
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Ad-Hoc Wireless Network Connection Troubleshooting
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I don't see...
by R. Proffitt Forum moderator / January 6, 2005 10:58 PM PST

1. Any mention of the desktop sharing the internet with ... ICS. I will not duplicate the content about ICS from If you ask me a question about ICS and it's at WOWN, then I don't answer it.

2. I know better than to try this setup. For about the same dollars as the desktop PCI wifi card, you get the Wifi Router and it works.


Collapse -
Ad-Hoc Wireless Network Connection Troubleshooting- ???
by micahasani / February 7, 2005 11:14 AM PST

hey chris,
i am having the exact problem as you. i have a desktop and a laptop. My desktop has a wireless card as well. When i didn't have SP2 on my desktop, everything worked fine, but it seems that SP2 has messed it all up. Still can't get it working, my buddies are telling me to just buy a router, but i don't want to. I still have hope. Anyways, if u have figured out a solution to this, please write and tell me. thanks.


Collapse -
Wireless reception but no internet connection
by eytwong / February 8, 2005 10:42 PM PST


I'm not sure if this is quite the same problem as you, but I have wireless PCI cards from Lynix - one in the computer downstairs (which is fine with the interent) and one upstairs.

The wireless connection is fine - connectivity is low, but enough for me to get the internet upstairs. This only works during the day however - weirdly, I can't seem to get any internet connection at all in the evening.

Anyone got any ideas?

Collapse -
by jimmyjim / February 17, 2005 3:03 AM PST

Hi iam having the dead same problem as you, an am so fed up. Dell says you have to have wimdows xp pro to go adhoc xp home needs a router,is this right or was ijust fobbed off would be pleased if you know the answer jim.

Collapse -
The answer is you need the router.
by R. Proffitt Forum moderator / February 17, 2005 7:07 AM PST
In reply to: ad-hoc

But in spite of this, people keep trying it.

Collapse -
long shot
by kishu111 / March 3, 2005 2:19 AM PST

It's a long shot but why don't you try giving all of your default gateways the same address.

Collapse -
by EGC / March 18, 2005 1:29 AM PST

Wireless on laptop's gateway should b, which is the desktop wlan IP!! also i'll recommand u to use 192.168.0.X, the 'offical' style of LAN address..:)

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?