Spyware, Viruses, & Security forum

General discussion

ActiveX Problem..

by Larry38 / December 10, 2007 1:43 AM PST

I have this ActiveX File that downloaded last evening. The name of it is "hpdns_ax.ocx" and is supposed to be from Hewlett-Packard? It is blocking entry to my "HP Image Zone" The only way I can find it is to do a search. It is located in H-P Digital Imaging bin, on C drive. When I google it, it is an unknown file. Also when I try to enter the HP Image Zone I get a Popup that says...

IE has encountered a problem with an add-on and needs to close.
Also says

The following add-on was running when this problem occured:

Add-On Name: "hpdns_ax.ocx"
Company Name: (Not Verified) Hewlett-Packard
Description: "hpdns_ax.ocx"


I'm going to do some scans,but has anyone seen this before? and can I delete it without any problems to my PC,if it don't show up in any scans?

Will let you know if any of the scans find anything.

My Profile should be up to date, but running WXP Home SP2 IE7.
Hope it's nothing bad!
Thanks For any Help.
Larry

Discussion is locked
You are posting a reply to: ActiveX Problem..
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: ActiveX Problem..
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) can you delete it?
by jimandjerry / December 10, 2007 1:55 AM PST
In reply to: ActiveX Problem..
Collapse -
I haven't tried yet...
by Larry38 / December 10, 2007 3:30 AM PST
In reply to: can you delete it?

Thought I had better get some advise first from someone that knows more than I do, don't want to do the wrong thing.

My PC is about 4 years old and have never had a problem with it.

Collapse -
The Latest...
by Larry38 / December 10, 2007 4:00 AM PST
In reply to: ActiveX Problem..

Went to Safe Mode, and SUPERAntiSpyware found nothing. AdAware found nothing.

Spybot S&D Did find something.
Microsoft Windows Security Internet Explorer.

When I clicked on the plus sign, I got this.

Settings & Registry Change
HKEY_USERS\ (a bunch of numbers)\Software\Microsoft\In...

I did not delete it as yet. should I go ahead and delete it, or try a system restore?

I will do some more scans, and see if anything else can be found.

Collapse -
hpdns_ax.ocx
by Marianna Schmudlach / December 10, 2007 4:32 AM PST
In reply to: The Latest...

Larry,

about the above file:

COMPANY NAME: Hewlett-Packard
FILE ATTRIBUTES: Archive
FILE FOLDER: %PROGRAMFILES%\hp\digital imaging\bin
FILE NAME: hpdns_ax.ocx
FILE SIZE: 1,081,344 KB
FILE VERSION: 1.0.0.4
INTERNAL NAME: hpdns_ax.ocx
LEGAL COPYRIGHT: Hewlett-Packard. All rights reserved.
MD5 SIGNATURE: 0c548f1ecc272a8a3c3f3830239544d2
ORIGINAL FILE NAME: hpdns_ax.ocx
PRODUCT NAME: hpdns_ax.ocx
PRODUCT VERSION: 1.0.0.4
SPECIAL FOLDER: PROGRAMFILES

http://www.internetsecurityzone.com/Entities/?_hpdns%5Fax%2Eocx

Do you have the same?

Collapse -
Hi Marianna,
by Larry38 / December 10, 2007 7:06 AM PST
In reply to: hpdns_ax.ocx

I did see that link last night when I did a Google, but was getting late so waited till today to do anything.

I can go to the hp bin files, but can't find it listed. I go to search and can find it. Pull up properties, and it says
ActiveX
unknown application
location, same as I listed above.
size 552KB
created.. Aug. 01 2003 (got this PC new in Dec. 2003)
modified..Dec. 09 2007
file version...1.0.0.2
Windows won't open it, they don't know what program created it.

Larry

Collapse -
Hi Larry..
by Marianna Schmudlach / December 10, 2007 7:13 AM PST
In reply to: Hi Marianna,
Collapse -
Thanks Marianna...
by Larry38 / December 10, 2007 10:05 AM PST
In reply to: Hi Larry..

HP Image Zone has started working again, unknown why?

Larry

Collapse -
(NT) ROFL - did you use your "magic wand" ? :)
by Marianna Schmudlach / December 10, 2007 10:16 AM PST
In reply to: Thanks Marianna...
Collapse -
(NT) Nope, I used a few "Magic Words" LOL
by Larry38 / December 10, 2007 11:43 AM PST
Collapse -
Larry, Why Not System Restore To Two Days Ago?
by Grif Thomas Forum moderator / December 10, 2007 5:48 AM PST
In reply to: ActiveX Problem..

Although the file looks to be a genuine HP file, it's not clear how you "downloaded" it? Generally, they're installed when installing HP software of some type. (If you've got the "HP Software Update" program installed on your computer, it may have caused the update.. Personally, I delete the "HP Software Update" software because it's really not needed.) . Either way, a System Restore should cause it to disappear.

Hope this helps.

Grif

Collapse -
I tried to restore....
by Larry38 / December 10, 2007 10:00 AM PST

two days ago, and four days ago, neither point would restore.

Can't find "HP Software Update" listed under HP or "msconfig" Startup.

The last program I downloaded was Sun Java on the 6th and it has worked fine. I even set a restore point before upgrading.

HP Image Zone has started working again, unknown why.

Thanks Grif, Getting tired, will play more tomorrow.
Larry

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?