Question

Accidentally selected USA band in Moto X Play

While trying to force the Sim-1 slot to WCDMA only using 'Phone Testing' feature in my Moto X Play, I accidentally selected the USA band in 'Select Radio Band'. I was trying to force the network mode of Sim-1 to 'WCDMA only' as 3G network in my area is slow and erratic and the phone switches automatically to 2G when the 3G signal is weak even if the presferred network is set to 3G (only preferred network can be set to LTE/3G in the phone and no 3g/WCDMA only option is there). After selecting the USA band the Sim-1 slot cannot detect a network even if the sim is detected. Even a factory reset could not solve the problem. I live in India. Now I am clueless how to rectify the problem. I have read about the possibility of solving the issue by flashing the memory, but am not sure how to do the same.

Discussion is locked
Follow
Reply to: Accidentally selected USA band in Moto X Play
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Accidentally selected USA band in Moto X Play
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
sim-1 slot USA bAND

Hi, i'm french so excuse me for my english.
I have the same problem, the sim-1 slot is on USA BAND.
Did you find a solution?
I'm trying with motorola assistance but for the moment there is no solution.
thank you

- Collapse -
Answer
(NT) When I mess up I do a factory reset of the phone.
- Collapse -
Factory reset did not work

In this case even factory reset does not work.

- Collapse -
Ouch.

Now a call to the phone's maker to see why that didn't work. Yes, I've done that more than a few times so I start over.

- Collapse -
Answer
Solution!!!!!

I really worried about taking my phone to the service center as i live too far from the service center also they took it for 2 weeks when i last gave them for speaker issues. So i googled and found this. I was first worried about corrupting my phone data by doing it, but to my surprise it really worked.


Steps:
(Skip 1 and 2 if developer options show in your phone settings)
1. Open settings in your phone tap on about phone tap 5 times on build number.
2. Come back to the settings and you can find Developer options. Tap on it.
3. Tap "ON" and enable "USB debugging"
4. Download adb kits in your PC from "http://adbshell.com/downloads"
5. Install the same. When asked for driver installation press "y"
6. Connect your phone to PC through your charger cable.
(your phone will be detected by PC at this step. If not download the drivers from same site)
7. A popup "Allow USB debugging" appears on your phone screen. Tap ok
8. In your PC, open command prompt and enter
adb reboot bootloader
fastboot erase modemst1
fastboot erase modemst2
fastboot reboot


Don't worry about the erasing part. Wait till the phone boots up, and in a while your signals pop up.

Thats it!!

- Collapse -
Thanks a lot!

Thanks bro, your solution perfectly works on my Moto G4, highly recommend to every Moto users who have faced up with this problem.

- Collapse -
Need some clarification

Hi Adi,

Firstly, thanks for your post. Looks like I may have a solution for my network issue too.
I followed your steps, however for the following commands:
fastboot erase modemst1
fastboot erase modemst2
fastboot reboot

Do i need a setup of fastboot? I only installed adbkits on my PC. Do i need fastboot files or setup too? If yes, could you advise the link for that too?

- Collapse -
Thanks a lot

Thanks a lot, I will stuck with this for one month now solved with your help....

- Collapse -
lenovo p2

Can this steps work for lenovo P2?

- Collapse -
THANKS A TONNNNN!!!!! :-D

Really worked and very much appreciated. Thank a lot again, signal just got popped up again exactly like you said. :-D

- Collapse -
<waiting for any device>

Hi,
Thanks for your post.
I need a small help. I am using Android 6.0.1 moto x play with Jan 17 security patch update. I am also facing the same issue (accidentally selected USA band).

I tried your method:
1) adb devices : It is showing my device
2) adb reboot boot loader: navigate to boot loader menu
3) fastboot erase modemst1 : ************* got stuck <waiting for any device>
Can you please help me ?? Sad Confused

- Collapse -
See my reply above

See my reply to Aditya. it could help you Happy

- Collapse -
Worked

Worked well. Thank you.

- Collapse -
Swipe Elite Plus

@Aditya I just signed up to CNET for only one reason. To thank you Happy

Guys,
Follow Aditya's guideline and you should be able to save yourself from ending up with a brick phone or having to explain to that mobile service person why the hell we selected the USA band in the first place!

just make sure to do the following before you input those commands in the command window:
1) Make sure to install " Android ADB Interface" Driver for your mobile.
2) Make sure to install "Android Bootloader Interface" Driver (also called "Fastboot driver") for your mobile.

The "fastboot erase" commands will NOT work if you do not install the fastboot driver. In other words, if this driver is not present, the "fastboot erase modemst1/st2" commands will just keep waiting in an infinite loop. It will just say <waiting for any device> and will not proceed with deleting the modemst1 or modemst2 folders in our phone that were created when we stupidly selected the USA band Happy

So make sure you do that. Below is a tutorial I stumbled upon, that would help you install the above 2 drivers. The tutorial is pretty long, overdrawn and the suggested software occupies a lot of space. But we can always uninstall these unwanted software (JDK and Android Studio) once we have executed the commands outlined by Aditya and as soon our phones are back to normal.

Tutorial --> How to Set Up ADB and Fastboot with Android SDK on Windows 7 & Windows 8
http://www.teamandroid.com/2012/07/30/how-to-set-up-adb-fastboot-with-android-sdk/

Note: During the fastboot driver installation process (page 3 of the tutorial), if you are unable to get into your phone's "fastboot mode" even after pressing and holding down combinations of volume and power buttons, just make sure you have the "ADB interface driver" mentioned above all set and that the command prompt command "adb services" correctly returns your device number as described in that tutorial. Then, just key in the first command alone, which is:
adb reboot bootloader

This command sends instructions to your phone that puts it in "fastboot mode" or "bootloader mode", which is essential for:
1) Installing the fastboot driver
2) Executing the "fastboot erase modemst1/st2" commands in the command prompt window.

CNET Forums